x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.7.2 crashes when building banks in FMOD

When building banks using the FMod Plugin places files in the Contents/FMOD/Desktop/ directory causing UEditor to crash. When removing the Banks from said directory the FMod folder is still not visible in the contents browser though plugin seems to be enable and loaded in the Project Preferences.

Produces following report:

MachineId:7CE4F4B14E3AAD4586042DA061DB1E66 EpicAccountId:5a4d6a18219f4865a37fce0dea27cf39

Access violation - code c0000005 (first/second chance not available)

UE4Editor_FMODStudio!FFMODAssetTable::AddAsset() + 3755 bytes [c:\source\ue4\ue4-releases\4.7\engine\plugins\fmodstudio\source\fmodstudio\private\fmodassettable.cpp:202] UE4Editor_FMODStudio!FFMODAssetTable::Refresh() + 1677 bytes [c:\source\ue4\ue4-releases\4.7\engine\plugins\fmodstudio\source\fmodstudio\private\fmodassettable.cpp:104] UE4Editor_FMODStudio!FFMODStudioModule::RefreshSettings() + 27 bytes [c:\source\ue4\ue4-releases\4.7\engine\plugins\fmodstudio\source\fmodstudio\private\fmodstudiomodule.cpp:374] UE4Editor_FMODStudio!FFMODStudioModule::StartupModule() + 228 bytes [c:\source\ue4\ue4-releases\4.7\engine\plugins\fmodstudio\source\fmodstudio\private\fmodstudiomodule.cpp:211] UE4Editor_Core!FModuleManager::LoadModuleWithFailureReason() + 2426 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\modules\modulemanager.cpp:371] UE4Editor_Projects!FModuleDescriptor::LoadModulesForPhase() + 784 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\projects\private\moduledescriptor.cpp:350] UE4Editor_Projects!FPluginManager::LoadModulesForEnabledPlugins() + 753 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\projects\private\pluginmanager.cpp:424] UE4Editor!FEngineLoop::LoadStartupModules() + 483 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launchengineloop.cpp:1856] UE4Editor!FEngineLoop::PreInit() + 11141 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launchengineloop.cpp:1400] UE4Editor!GuardedMain() + 251 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:110] UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202] UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 06:43 PM in Bug Reports

avatar image

KosmoPixel
1 1 3

avatar image AndrewHurley Mar 09 '15 at 09:07 PM

Hey Amanov,

When you say building banks using the FMOD plugin, you do mean through the actual FMOD Studio correct?

Could you provide me with your system specifications?

Could you also possibly provide me with some reproducible steps to get the crash to occur in a new blank project?

These steps would include how you are creating your Banks within the Studio plugin, as well as how you are associated the directory within the project.

Thank you,

Andrew Hurley

avatar image KosmoPixel Mar 09 '15 at 11:49 PM

Hey Andrew, thanks for responding.

My specs are: win 7 64-bit, SP1, i5 CPU M480 @2.67GHz, 6.0GB RAM, ATI Mobility Radeon HD 5650

Yes, I have built some banks in the Fmod Studio. I will write in a little more detail for other users.

Create a project, and launch FMOD Studio, in preferences>builds make sure that build destination is set to UE4 project folder>Content>FMOD. In Fmod go to preferences and in the output settings, set the audio to Stereo (or what you are working on), and in the UE4, you can check that by going into UE4>Edit>Project Preferences>Fmod and set it also to Stereo. After creating a folder with an audio event in Fmod, save project and press build.

In that instance Fmod creates .bank extensions in the UE4 project folder/Content/FMOD/Desktop

And then UE4 crashes, tried building and then opening the editor - still the same result. All destinations seem to be set correctly on both ends.

Kind Regads

Amanov

avatar image AndrewHurley Mar 10 '15 at 03:49 PM

Hey Amanov,

Thank you for the provided steps for reproducing this crash. I am new to FMOD so I am sure other users will appreciate the directions as well.

I will do my best to reproduce the issue on my end so we can get find a solution. I will keep you updated as to my progress.

Cheers,

Andrew Hurley

avatar image LnBAnimation Mar 11 '15 at 11:00 PM

I am experiencing the exact same problem on a Win8.1 i7 Nvidia 970 machine with 16GB RAM

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Amanov,

I may have good news for you! I had the same crash so I talked to the FMOD developers and they found the source of this bug.

It seems that the current version of FMOD Studio (1.05.13) has a bug which confuses the UE4 plugin of fmod and makes it crash UE4. They will fix it in the next FMOD Studio release in a couple of weeks. But if you don't want to wait, you may as well use FMOD Studio 1.05.12 which works fine (Note: You just need to "downgrade" your FMOD Studio application, NOT the UE4 plugin).

more ▼

answered Mar 16 '15 at 11:06 PM

avatar image

Kyoril
173 14 20 168

avatar image AndrewHurley Mar 17 '15 at 05:35 PM

Hey Dalon,

Thank you for taking the time to look into this issue and update this post. We always appreciate users going out of their way to help others, and from the looks of this bug, we could have spent a good while attempting to find the source of the error on our end.

If anyone is experiencing this issue and manages to work around the crash using Dalon's suggestion please let me know.

Thanks again Dalon :)

Regards,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question