x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Failing to build demo on iOS

Looks like I might be switching mid-project from Unity to UDK. The $225 a month I'm facing at Unity to develop for mobile is making me seriously consider switching to Unreal. So sorry but I'm a total noob at the moment. I need to ramp up in about a week and start porting.

My first attempt at anything in UDK is to just build the table and chairs demo with the floating cone above it from here:

https://docs.unrealengine.com/latest/INT/Programming/QuickStart/index.html?utm_source=uelauncher&utm_medium=software&utm_campaign=learntab

But when I try to launch it on my iPhone 6+ it fails. I'm sure I'm just missing something stupid but it's failing to build and launch on the device and after a couple hours playing and searching here I have to ask for help.

I have verified in Project Settings > Platform Settings > iOS that I have green/valid team * provisioning profiles and a valid development certificate.

In the product launcher it fails on Deploying content for iOS. I attached the project launch log. It seems to build ok but fails when trying to copy to the device:

mono: Unhandled Exception:

mono: System.IO.IOException: AFCFileRefOpen failed with error 7

log file

Also, it's probably unrelated. But the UE4 interface in my mac is offset from the mouse. So when I click anything it's as if I clicked below it, about the height of the menu bar. Is this normal or just something weird going on in my install?

Product Version: Not Selected
Tags:
projectlauncher.log (259.9 kB)
more ▼

asked Mar 10 '15 at 08:09 AM in Packaging & Deployment

avatar image

badweasel
6 1 3 2

avatar image Ravlek STAFF Mar 10 '15 at 01:26 PM

Hi,

The AFCFileRefOpen failed with error 7 is a known issue. It's only happening for a small percentage of people and unfortunately not here at Epic so we've been having trouble tracking down the problem. I have some more logging information coming in the next point release, but that won't be until next week. Do you have a PC? If so, can you try the editor and Launch On on the PC? So far everyone who has this error doesn't have access to a PC, so we've been unable to see if it Mac only or affects both (which would imply something different about the device itself).

As for the menu offset, again something we've heard about from other users, but we haven't been able to reproduce it. What is it you set up? Multiple monitors of differing resolutions? What Mac OS?

-Pete

avatar image Ravlek STAFF Mar 10 '15 at 01:29 PM

Actually, I just looked at your log again, you have the second even more rare double attempt to deploy the IPA error. The last person to get this updated their install and it went away. Are you on 4.7.2?

-Pete

avatar image badweasel Mar 10 '15 at 08:02 PM

Wow.. I won the lottery! Twice?

I don't have a PC. I do have VMWare. I'd rather not go there because it's a can of worms. But I can if you need me to.

I am on 4.7.2. I just installed it yesterday and started trying to learn it. The window offset problem went away with a quit and restart of the editor. But the launch problem persists even after a reboot.

Version

Should I delete and reinstall? Advice appreciated as I'm trying to get ramped up as quickly as possible. Thanks!

My mac is a 3.5 i7 Late 2013 iMac 27. 10.10 only 8 gig ram and I have the GTX780M. I'm actually ordering a 5k iMac later today.

avatar image Ravlek STAFF Mar 10 '15 at 08:18 PM

No don't worry about it. I have a potential fix for this particular issue, but it won't be in 4.7.3 as I want to make sure it doesn't break something else. And since we can't reproduce it, I am kind of taking stab in the dark. Do you have a second device? For some people, it has worked on one device and not a second device.

-Pete

avatar image badweasel Mar 10 '15 at 08:25 PM

Like I said, I'm ordering a new iMac later today but it'll take a few days to get here. I'll try reinstalling.

avatar image badweasel Mar 10 '15 at 08:03 PM

Anything I can do to help you track down the problem?

avatar image badweasel Mar 10 '15 at 09:44 PM

I used the launcher to uninstall 4.7.2. Then deleted the launcher and reinstalled it from the .dmg. Then reinstalled 4.7.2 from the launcher. It still won't install on the phone. Then I tried launching on the mac and that one does build ok. Then back on the phone again and same thing. Attached is my log in case maybe the reinstall solved one of the two problems.

new log

My next attempt will be to create a totally new project from scratch and see if that will install. Are there any complete iOS test projects that are known to work?

avatar image badweasel Mar 10 '15 at 10:17 PM

I created a blank project and tried to launch that on the iPhone and got the same error. So it must have something to do with my install. The curious thing is that an app does install on my phone. When I run it I get a message. What does it mean?

weird message

img_3459.jpg (55.7 kB)
avatar image badweasel Mar 11 '15 at 12:50 AM

Ok.. So I updated all the software on my iMac. OS to 10.10.2, Xcode to 6.2. Same thing when I try to launch. Also tried on another device. An iPhone 6. Same thing. Same error messages. It appears to build the app ok and it even installs something on the phone. But then it fails. And when I run the app I get the above message.

OH.. and now the Editor is also crashing a lot. I sent in that crash report along with a link to this post.

So now what? You're saying that there won't be a fix in 4.7.3. Can someone at Epic please email me? I'd even try a beta build. But I can't wait weeks or months for a solution.

avatar image Ravlek STAFF Mar 11 '15 at 03:05 AM

Lets try to get you my potential fix tomorrow. Either through PMs on the forums or some other way. Even if it doesn't fix it, it should give me more information.

The reason why it is not running is the executable is there but none of the content, so it fails trying to load the game data.

-Pete

avatar image badweasel Mar 11 '15 at 05:58 AM

That sounds great. Already better service than Unity. I couldn't figure out how to PM on here. My email address is michael at badweasel dot com. Email me directly if you can. Thanks.

avatar image Ravlek STAFF Mar 11 '15 at 02:06 PM

Ok, do you have a forums.unrealengine.com account? If so, we can use private messaging there. If not, I will use the e-mail above, but would prefer PM on the forums.

-Pete

avatar image badweasel Mar 11 '15 at 04:52 PM

Sorry of course. My username is the same, badweasel. I messaged you from there. Thanks.

avatar image badweasel Mar 12 '15 at 12:26 AM

New log from temp build: build log

avatar image Ravlek STAFF Mar 12 '15 at 12:40 AM

Ok, I just put a new dll in the same location I sent you earlier. Could you put that in the directory specified and try again?

Based on the log, you tripped my check to verify we could create the PublicStagin directory. That hasn't been firing on my machine (PC), but I haven't tested it on mac. The new dll will test for the existence of the directory and continue on in either case and we'll see if the other fix resolves the double IPA install.

-Pete

avatar image badweasel Mar 12 '15 at 02:19 AM

Failed again. This time:

mono: CreateDirectory (/PublicStaging) failed mono: mono: Unhandled Exception: mono: System.IO.IOException: AFCFileRefOpen (/PublicStaging/UnrealTest.ipa) failed with error 7

Build Log

Another "by the way"... probably doesn't matter but my Unreal Projects save folder is in ~ instead of ~/documents. And eventually it will be on an external drive.

avatar image badweasel Mar 12 '15 at 02:20 AM

Thanks for all the personal service by the way. REALLY selling me on UDK over Unity. Now to get it to compile so I can start tweaking the look as rendered on the phone.

avatar image Ravlek STAFF Mar 12 '15 at 02:41 AM

Ok, I am not 100% sure, but this seems to imply that the PublicStaging directory doesn't exist on your device and we can't create it. That seems a bit odd, so I suspect my Exists function is not working correctly. I'll need to do some research about this and make sure that it is working (won't happen until tomorrow at this point).

However, I'm assuming you have pushed an app to the device in the past, correct? If not, maybe we need to have you deploy a single app of any kind either through iTunes or from Xcode. If so, then my guess is the directory does exist and my Exists function is not correct. That would then imply file (/PublicStaging/UnrealTest.ipa) is not getting encoded properly in the Mobile Framework (error 7) which is also odd as it printed ou to the log fine.

btw, you now have the other issue people have seen, so it looks like the double ipa and file ref error 7 may be related. At least this progress :)

-Pete

avatar image Ravlek STAFF Mar 12 '15 at 02:48 AM

Also, could you see if you can get the log from the device? You can usually view this from the Xcode Devices window. Try to get a portion of the log from when it is attempting to deploy, That may give us some more information.

-Pete

avatar image Ravlek STAFF Mar 12 '15 at 03:18 AM

Actually, I have another dll for you to try. Same location, rinse and repeat. I have tested this one on PC and Mac and it definitely finds directories properly, so let's see if it solves your deploy issues.

-Pete

avatar image badweasel Mar 12 '15 at 06:11 AM

Yes I am a full time app developer. I have apps on this device that were loaded from Xcode directly, and also a couple from Unity. Although, this is the first device I've had where it's constantly asking me "trust this computer" and I say yes. Usually what happens is that if Xcode is seeing the device and the play button in Xcode shows the phone as a target I'm good. If not I have to reboot everything and then it works. That usually only happens once a week or so.

Ok great. That dll worked. Here are all the new logs. I saved both the UE4 log and the iPhone console log from the device..

Launch Log iPhone Console

There are a few things I don't understand still though. First, when I installed the app it took what seemed like forever for the splash screen to go away and the demo to come up. Then I wasn't sure how to exit out of it from UE4, there wasn't a stop button so I hit cancel. For example in Xcode there is a play button which turns in to a stop button. Once the app is loaded it's loaded. Stopping force quits it but then it's on the phone. Anyway, now if I run the app on the device I get that error message again about a server. How do I install it so it's fully installed? Why is there a server at all?

Second, it's not retina. It's very low resolution. Looks good otherwise with soft shadows and some bloom on the lights. It's just a demo so maybe I have it set wrong somewhere. But why isn't the default setting on the phone to use the full resolution of the phone?

Thanks again for all your help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Mar 24 '16 at 03:17 PM by Samantha Sutton for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks!


0 answers: sort voted first

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question