x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

CameraActor doesn't render in Matinee movie?

Hi!

I'm trying to render out a movie in Unreal Engine 4 using Matinee, but no matter what I do when hit "Movie", the perspective it renders from is the default viewport location, and not the CameraActor I've placed out, despite creating a cameragroup.

What am I doing wrong?

Product Version: Not Selected
Tags:
more ▼

asked Mar 26 '14 at 02:44 PM in Using UE4

avatar image

Coyotemation
6 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

You also need to create a Director Group in the Matinee.

https://docs.unrealengine.com/latest/INT/Engine/Matinee/UserGuide/index.html#workingwithgroupsandtracks

Once you create the director track, select the first frame of the animation, hit enter and it will let you pick the camera you'd like to view from.

more ▼

answered Mar 26 '14 at 02:48 PM

avatar image

Jacky
16.8k 671 167 676

avatar image Coyotemation Mar 26 '14 at 02:57 PM

Ah! Thank you! I tried doing that but I must've messed up the first time around. Tried again and it works! Thank you!

avatar image mindblowz Jan 25 '16 at 02:06 PM

i did all that is said here and i still get render from a camera that i dont have. https://www.youtube.com/watch?v=N7CYnqOJpA0 I do see my animation on matinee but when i render it out i get some other cameras view to render. I checked it on director track everything looks fine but still couldnt get it to work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hmmm... Same problem here, Tried several times. Can not get it to render from the camera view.

more ▼

answered May 25 '15 at 05:28 AM

avatar image

Richard Culver
41 1 4 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Same problem. Always defaults back to third person camera view- at the player start. And just updated UE 4.11.0.

more ▼

answered Jun 13 '18 at 12:33 AM

avatar image

ShiraService
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I did get this sorted eventually. Forget what I did though. But I do know it works. I think it has to do with a setting in render panel. At any rate I went on to render a lot of stuff. So I know it works.

One thing I do know I started doing - for perhaps another reason - was to remove the player start. As I was doing a cinematic I did not need it.

Unreal is not installed on my computer right now so I can't go and check what I did.

more ▼

answered Jun 13 '18 at 02:54 AM

avatar image

Richard Culver
41 1 4 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello All,

This issue was giving me some trouble. Solved it.

Select your Matinee Actor in World Outliner, scroll down to details panel and check the box labeled "Play on Level Load."

When you go to capture the video its loading the level and needs to know this.

more ▼

answered Apr 08 '19 at 07:35 PM

avatar image

nathan_SVR2080
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question