x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does the mouse become extra sensitive when dragging around inside blueprints?

If I hold down right click and drag across the blueprints grid window, my cursor travels the distance in a small fraction of the mouse movement which is normally required. It's like when I drag the grid around, my mouse sensitivity is very high. I have also noticed that the default camera rotation sensitivity in the viewport (2) feels very sensitive, and I have to go to the properties for each project and set the sensitivity to .05 to make it feel correct. Does UE4 not play well with high DPI mice? Currently my DPI is about 5k.

I have noticed that camera rotation sensitivity in the UE3 viewport is also much more sensitive than it should be.

My PC is Xenon Workstation with 12GB ram.

I'm using a Logitech G600.

Product Version: Not Selected
Tags:
more ▼

asked Mar 26 '14 at 02:48 PM in Using UE4

avatar image

JHeeter
21 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

When interacting with the viewport or the grid panel the cursor actually switches to a software cursor and reads the high precision data directly from your input device (aka mouse). This means that the input will feel different, generally faster, then when not interacting with these widgets. This is because it circumvents the OS mouse ballistics which slow the mouse down and produce "easing" effects depending on the speed you are moving.

This gives you 100% precision and allows us to perform endless scroll/pan type behavior, but has the negative side effect of generally slightly adjusting the cursor speed.

If you can adjust the speed of your mouse using it's drivers instead of relying on Windows mouse ballistics you should get a more consistent movement speed.

aka. open up the fancy mouse software you hopefully have installed and adjust the sensitivity there instead of in the normal Windows dialog. Sometimes you can adjust the sensitivity on the mouse hardware itself which should also do the trick.

more ▼

answered Mar 27 '14 at 06:23 PM

avatar image

Sarge STAFF
627 14 5 36

avatar image JHeeter Mar 27 '14 at 08:37 PM

Ok, thanks for the insight into how the editor handles this input. I have mouse acceleration disabled in my logitech software and also in windows. The logitech software only has DPI settings, the only mouse speed settings I see are the default windows ones. There must be some kind of a multiplier that could be adjusted to tweak how the mouse operates during this software cursor mode? Changing the camera sensitivity in the editor properties seems to be a good solution to fix the issue in the viewport. I feel like there should be a similar setting to adjust the mousing speed when navigating blueprints. The difference between mouse sensitivity is very apparent with my current hardware setup.

avatar image cgiteach Aug 06 '15 at 08:32 AM

The only solution I've got in so far is to use different mouse profiles where I use a low dpi one when working with UE4

avatar image cgiteach Aug 06 '15 at 08:24 AM

Has there been any update on this situation. I'm Sorry but this is an unacceptable behavior because it's inconsistent. I'm using a gaming Redragon mouse and I'm controlling everything from the mouse software. When I say UE4 behavior is inconsistent I mean that when I scroll over the mouse over the interface or do click and drag in material editor it has one speed but when I pan or click and drag in the viewport, or pretty much anything that involves some form of navigation the speed is much higher, in my case. I used to have a different mouse previously and never had this issue, but I would suggest giving the user "100% precision" ALL the time while working inside UE4 if you care so much for it, so as I, and everyone else with this problem, can setup the mouse properties to change while operating inside the UE4, or make this behavior optional.

Thanks, George

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried adjusting the camera move speed slider in the upper right corner of the viewport?

I have a high dpi mouse which I keep usually running around 3k-4.5k and have not had issues except when the camera speed is ramped up.

more ▼

answered Mar 27 '14 at 03:29 PM

avatar image

DJMidKnight
1.2k 50 24 51

avatar image JHeeter Mar 27 '14 at 05:55 PM

Actually I need to adjust the camera rotation, not translation. Also, this does not change the speed that the blueprint grid dragging works.

Have you noticed any sensitivity increase in blueprints when you drag the grid?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm still wondering if there will be some option to tweak the sensitivity inside the blueprints editor?

more ▼

answered Apr 03 '14 at 07:25 PM

avatar image

JHeeter
21 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question