Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android: Failed to open description file

Hi, i have problem with shipping packing for android. if the game sends and downloads from Google Play game crash and report error: Failed to open description file "../../../Mygame/Mygame.uproject". but if i install the game from Install_mygame_Shipping-armv7-es2 game operates normally.

can u help me please?

Product Version: Not Selected
more ▼

asked Mar 10 '15 at 09:12 PM in Packaging & Deployment

avatar image

46 3 4 5

avatar image okuhleevil Mar 12 '15 at 04:10 PM

if the game is run when LAUNCH in engine game operates normally. all is OK ---->deleted from phone ---->packing dev and shipp ---->Install_Mygame_Shipping-armv7-es2 ---->game is OK ---->send to google play ---->deleted from phone ----> instal from google play, game is OK, but if i try it instal at another phone or my phone reset to factory data game CRASH at start with message: Failed to open description file "../../../Mygame/Mygame.uproject"

this message is in UE4CommandLine.txt

the game is finished for the last 2 months and I can not go, really need help.... please

avatar image Sky3 Apr 09 '15 at 04:30 PM

HI, I m stuck with the same issue. All is fine locally but as soon as I export my project to google playstore, I cannot launch it . With this error Failed to open description file "../../../Mygame/Mygame.uproject". So I am wondering if this really coming from the Android shipping set up or the build itself.

What did you use as ANDROID package : ALL, ATC, DXT, ETC1, ETC2, PVRTC ?

I could not figure how to fix it for now so I also join my Unreal parameters.

alt text

alt text

avatar image okuhleevil Apr 11 '15 at 05:42 PM

hi, ETC1 is recomended. Did u send obb file? try change store version 9 to 11111

avatar image okuhleevil Mar 13 '15 at 06:44 PM

blank project do same error.

avatar image BaderThanBad Mar 17 '15 at 01:03 PM

Did you figure out what was causing it?

avatar image BaderThanBad Mar 17 '15 at 05:16 PM

link text, my question with the same issue.

avatar image okuhleevil Mar 17 '15 at 10:37 PM

Hi, Thanks for the advice, but it still does not work. My mistake was change some data in buld.xml. ^^ after reinstal win, engine + sdk i have problem>>>

[javac] Note: Some input files use or override a deprecated API. [javac] Note: Recompile with -Xlint:deprecation for details. [proguard] You should check if you need to specify additional program jars. [proguard] Warning: can't write resource [META-INF/MANIFEST.MF] (Duplicate zip entry [classes.jar:META-INF/MANIFEST.MF]) [proguard] Warning: can't write resource [META-INF/MANIFEST.MF] (Duplicate zip entry [vrlib.jar:META-INF/MANIFEST.MF]) [proguard] Warning: can't write resource [META-INF/MANIFEST.MF] (Duplicate zip entry [android-support-v4.jar:META-INF/MANIFEST.MF]) BUILD FAILED MainFrameActions: Packaging (Android (ETC1)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:1139: The following error occurred while executing this line: MainFrameActions: Packaging (Android (ETC1)): C:\NVPACK\android-sdk-windows\tools\ant\build.xml:1151: Value for 'keystore' is not valid. It must resolve to a single path

I tried to use 3 keystore, any idea?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

That is a different problem. It probably has to do with the configuration for your keystore. Make sure it is placed in the proper location (YourProject/Build/Android/), that the keystore name is correct in project settings (from 4.7 it overrides or does not use the earlier setup of signing config and manifest, everything is in project settings->android). Key alias and password should also be correct. Do not use "" in the settings even if you have spaces.

more ▼

answered Mar 18 '15 at 08:40 AM

avatar image

664 21 18 177

avatar image okuhleevil Apr 01 '15 at 04:52 PM

thanks for help, :) try to play it ! :D https://play.google.com/store/apps/details?id=com.epicgames.redheadsheep

108 levels

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question