x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Exynos GearVR Support

I'm running a rooted Note4 with Android Lollipop 5.0.1 on an Exynos GearVR phone. I can't get Unreal 4.7.2 (binary build, haven't tried building from source.) to work for the GearVR. GearVR applications from the Oculus store works great. I can build Unity games for the GearVR just fine.

The issue I'm getting is on the C++ first person template it seems to render each eye correctly then it stops rendering. No headtracking, and if you fire the gun using the GearVR touchpad it doesn't render in game. You can hear the sound of the gun firing. I'm able to do a non GearVR android build, the touch controllers appear and I can run around fine in the level, so UE4 is definitely capable of rendering to this phone for a normal android game.

I've tried following all the suggestions in this thread: https://forums.unrealengine.com/showthread.php?60371-Epic-s-low-priority-on-GearVR-and-VR-in-general-makes-me-sad

I have a oculussig file correctly setup (it works fine doing Unity), and followed all the steps to get GearVR working (plugin enabled, scalable3d mobile content, no starter pack, configured for android properly, remembered to check Configure the AndroidManifest for deployment to Gear VR = true, etc.

Does anyone have any other ideas? How long would Exynos support take?

Link to the firmware I'm using for my rooted Exynos note 4: http://forum.xda-developers.com/note-4/general/n910h-lollipop-touchwiz-stock-t3029783

Thanks!

Randy

Product Version: Not Selected
Tags:
more ▼

asked Mar 11 '15 at 07:59 PM in VR

avatar image

Rjmig88
21 1 4 7

avatar image Rjmig88 Mar 12 '15 at 01:26 AM

If I take off the headset and put it back on it resumes rendering for 2-3 seconds and lets me head track before the render thread freezes.

avatar image 이미지메이드 Mar 23 '15 at 08:52 AM

I'm the same situation......

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Exynos GearVR support is now official in the latest 5.0.1 lollipop firmwares. If this has not been released in your region yet or you used the early 5.0.1 Polish firmware in February then you will need to update to a newer 5.0.1. any of them with a build date around mid-march or later are working! :)

You can get the latest official firmware for your device from here: www.sammobile.com/firmwares/

Just grab a different region if yours is not a 5.0.1 build from mid-march yet ;)

UE4 rendering fine then :)

more ▼

answered Apr 16 '15 at 01:03 PM

avatar image

aussieburger
1.5k 43 175 74

avatar image hitchcott Apr 19 '15 at 12:43 PM

Good to know. Is there any reason for it not to support KitKat? All other VR apps work fine. In the meantime I'll just wait for lollipop.

On my N910U on 4.4.4 I'm getting this rendered even though I'm wearing the GearVR:

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thank you! Upgrading my firmware to that release lets me run UE4 on Exynos.

more ▼

answered Apr 27 '15 at 05:57 PM

avatar image

Rjmig88
21 1 4 7

avatar image DaYuShen Apr 20 '16 at 03:40 AM

Hello Rimig88, i am gear vr developer for ue4. I'm the same situation,how to solve this problem?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question