x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Failed to load font data warning on startup

I recently downloaded and compiled UE4 for Linux, everything went smoothly, all dependencies installed (as far as I know, etc). When I go to launch the editor from inside the Engine/Binaries/Linux directory, I get the following warning messages (I provided the warnings and full startup log in an external link to avoid clutter of the page):

+ warning messages

+ full startup log

I'm not sure what most of these errors are, and if they are even an issue, but there are a few that are causing me problems so far. These are the failed to load font data errors:

 [2015.03.12-01.19.59:243][ 0]LogSlate:Warning: Failed to load font data from '../../../Engine/Content/Slate/Fonts/Roboto-Italic.ttf'
 [2015.03.12-01.20.03:342][ 0]LogStreaming:Warning: Failed to read file '../../../Engine/Content/Editor/Slate//GameProjectDialog/Tab_Background.png' error.

and (after other logs)

 [2015.03.12-01.20.28:196][ 0]LogSlate:Warning: Failed to load font data from '../../../Engine/Content/Editor/Slate/Fonts/Roboto-Regular.ttf'
 [2015.03.12-01.20.28:208][ 0]LogSlate:Warning: Failed to load font data from '../../../Engine/Content/Editor/Slate/Fonts/Roboto-Bold.ttf'

My engine still starts up and loads the window after these warnings, but as you can see from the image below, the characters are replaced with square placeholders, because, as the warnings said, the font data could not be loaded. Also, the window can not be moved or dragged around, but the buttons at the top still work.

UE4 editor no font

An ls of the Engine/Content/Editor/Slate/Fonts gives me this, confirming that the fonts that were reported missing are in fact missing:

 DroidSansMono.ttf
 FontAwesome.ttf
 Google_Android_License.txt
 Roboto-BlackItalic.ttf
 Roboto-Black.ttf
 Roboto-BoldCondensedItalic.ttf
 Roboto-BoldCondensed.ttf
 Roboto-Italic.ttf

And an ls of Engine/Content/Editor/Slate/GameProjectDialog gives me this:

 basic_code_thumbnail.png
 blank_project_preview.png
 blank_project_thumbnail.png
 default_game_thumbnail_128x.png
 default_game_thumbnail_192x.png
 default_game_thumbnail.png
 feature_blueprint_32x.png
 feature_blueprint.png
 feature_border.png
 feature_code_32x.png
 feature_code.png
 filepath_group_indicator.png
 IncludeStarterContent.png
 NoStarterContent.png
 Tab_Active.png
 tab_background.png
 Tab_Inactive.png

The error for this directory says Tab_Background.png does not exist, which is true, because it is in lower case. I renamed it to match the error and now there is no warning for that resource, also the window is now draggable.

As for the font errors, I am not sure how to approach this. I suppose I could find the font files online and move them into those directories, but I don't want to mess anything up. Anyone else come across this problem and solve it? I am curious as to why the font files weren't included. I downloaded straight from the Git repo.

Product Version: Not Selected
Tags:
ue4-crash.png (925.9 kB)
more ▼

asked Mar 12 '15 at 01:57 AM in Linux

samrapaport gravatar image

samrapaport
0 1 2 3

(comments are locked)
10|2000 characters needed characters left

The question has been closed Mar 24 '15 at 02:21 PM by amigo for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Hi,

Missing fonts is generally a benign problem as we haven't seen any issues with it. You can download those missing fonts and add them yourself.

Tab_Background.png issue was corrected in the epic/master (actually I was the one who sent a PR).

The issue you are having with the Editor, as per the image you posted, has already been answered here on the AH:

https://answers.unrealengine.com/questions/117323/editor-rendering-problems.html https://answers.unrealengine.com/questions/161055/font-problem-with-ue4editor.html

Lastly, I suggest running our community branch available in my repo at 3dluvr/4.7-linux, as it contains fixes which greatly improve the experience that are not available in epic/4.7

Once 4.8 is released that won't be necessary, but for the time being, for Linux, 3dluvr/4.7-linux is the best bet.

more ▼

answered Mar 12 '15 at 12:35 PM

amigo gravatar image

amigo ♦
1k 51 28 87

samrapaport gravatar image samrapaport Mar 12 '15 at 02:21 PM

thanks for you help, I will check out those resources

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question