x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint "Print String" not outputting to screen

I don't know what I did, it's just not showing up on the screen. But it's showing on the output log.

It was working a few minutes ago, I didn't change the HUD class or anything... I'm completely puzzled.

alt text

Product Version: Not Selected
Tags:
untitled.jpg (225.1 kB)
more ▼

asked Mar 26 '14 at 07:40 PM in Bug Reports

avatar image

Ixiguis
1.2k 57 61 253

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

8 answers: sort voted first

Hi everyone,

Thank you jubanka for the information. I was able to finally reproduce this with the Gameplay Debug mode and have entered a bug report, UE-14330 to be assessed by the development staff. If you press ' two times when you restart PIE it seems to reset the Debug mode and allow you to continue to see your print strings on screen. This is the only workaround I have currently available.

more ▼

answered Apr 23 '15 at 07:02 PM

avatar image Ixiguis Sep 05 '15 at 04:48 PM

This is still happening occasionally in 4.9. :(

Activating and deactivating the Gameplay Debug is not working for me.

I am sure the Print String is getting hit, it's displaying on the output log. It just won't display on screen.

Restarting the editor is the only fix so far.

Edit: like the other people having this issue, my default (and only) keyboard layout is also non-English (it's Portuguese - Brazil ABNT2).

And this also happens occasionally on students computers at the school I teach.

Also I can't find a reliable way to reproduce this. It seems very random.

avatar image Adam Davis STAFF Sep 08 '15 at 06:51 PM

Is there anything in particular that occurs before or anything that is done before this starts occurring?

avatar image Dzuelu Mar 18 '17 at 11:31 PM

I've just had this bug happen to me in 4.15.0. I'm not sure what caused it but I was working in an AIController when it happened, not sure that helps though.

avatar image A.SISODIYA Mar 21 '17 at 03:49 PM

Dzuelu -- I was also working on AI controller when this happened to me Seems like it's a bug

avatar image Thomas G ♦♦ STAFF Mar 23 '17 at 06:15 PM

Hello Dzuelu, Your issue could be different in nature to the issue on this thread, could you make a new thread for your issue?

avatar image miracle7 Apr 21 '17 at 05:10 AM

Also happening to me in 4.15.1 when working with AI stuff :(

avatar image Hyperloop Apr 27 '17 at 08:17 PM

I just got this bug, also working with AI stuff in 4.15. restarting did not fix.

avatar image Glitchdove Apr 29 '17 at 04:40 AM

Same, oddly enough. When I was working with AI. For some reason can't bring it back up no matter what I do.

avatar image Thomas G ♦♦ STAFF May 01 '17 at 05:30 PM

Hello AgentesinRebus,

Could you create a new thread for your issue? While your issue is producing the same result as this post, the underlying cause may be different.

Thank you!

avatar image jimd667 May 23 '17 at 06:51 PM

Just got this bug as well working in an AI Controller using version 4.15.1, added my vote to the bug report:

https://issues.unrealengine.com/issue/UE-38273

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having this same issue for a while now and just stumbled across a way to get it to show. I turned on the FPS inside the editor (Ctrl+Shift+H) and the print screen then works. If i turn it off it then stop working again. So I presume it is a bug where the FPS print turns off the print screen as well. I'm also using 4.9.

more ▼

answered Sep 30 '15 at 02:46 PM

avatar image

Tocs
93 8 11 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Got this bug today on 4.13.2

Yesterday was working fine, today I just opened the editor and no print to screen is working.

more ▼

answered Nov 04 '16 at 03:10 PM

avatar image

Trcioo
475 25 8 30

avatar image sinspaw Nov 04 '16 at 05:01 PM

I second this. Going through the same with 4.13.2 . Print screen just disappeared out of nowhere, along with the possibility of debugging stuff :l

avatar image Adam Davis STAFF Nov 04 '16 at 05:45 PM

Hi sinspaw,

I was able to reproduce this on my end and have entered a bug report for it here. You can track the report's status as the issue is reviewed by our development staff.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I Solved this problem in Window>Reset Layout...

more ▼

answered Jul 05 '17 at 04:59 PM

avatar image

Luiz Kowalski
11 1

avatar image IlllIl Feb 18 '18 at 03:03 PM

thanks, that did it for me as well in 4.18.3

avatar image rincom Jul 30 '18 at 09:44 AM

Thanks! Reset Layout is the way!

avatar image Davision May 24 '19 at 10:46 AM

That did it only to have it broken again after I used Execute Console command: "Screenshot" in my blueprint. So maybe that is the source of the bug

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Howdy!

By chance do you ever destroy the BasePawn actor which holds this Event Tick?

-W

more ▼

answered Mar 26 '14 at 09:06 PM

avatar image

DizzyWes ♦♦ STAFF
5k 145 64 206

avatar image Ixiguis Mar 26 '14 at 09:22 PM

Nope.

I added Print String to other blueprints as well (even Tick on the level blueprint) -- it's never printing on screen.

avatar image DizzyWes ♦♦ STAFF Mar 26 '14 at 09:26 PM

Can you post a full image of your Blueprint so that we can take a look at what's going on?

avatar image Ixiguis Mar 26 '14 at 10:41 PM

Hmm, it's working now. I'm not sure what solved it.

I did attempt to restart the editor before and that didn't solve the problem. So I tried to change the build config to Development Editor and it worked. Then I went back to DebugGame Editor and it's working now too. :o

Thanks for your time though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ever since 4.6 I'm exeriencing that issue too.. it just comes and goes as it pleases... usualy restarting the editor solves it.. (though sometimes It needs 2 or 3 restarts in a row to work...) Currently in 4.7.5 (where that bug became way more recurrent)

more ▼

answered Apr 14 '15 at 04:51 PM

avatar image

Eyez
11 1 2 2

avatar image Adam Davis STAFF Apr 14 '15 at 06:30 PM

I haven't been able to reproduce this on my end. Do you have any specific information that would assist me in recreating this bug?

avatar image Eyez Apr 14 '15 at 07:25 PM

Hi! actually.. it's a pretty random bug. it happens on my personal computer as well as in many of the machines in the school I teach, and it happens randomly amongst my projects...

Usually restarting the editor solves it, but sometimes just by changing my system's language/keyboard language settings and leaving my PC Idle for some time also solves it.. (My keyboard is currently somewhat broken, I've considered if my keyboard isn't auto-pressing some random keys that could toggle that behaviour on/off.... but the same bug happens on many of the machines in the school, so... no Luck there..

avatar image Adam Davis STAFF Apr 15 '15 at 02:55 PM

Does this only occur when your keyboard is in a language other than English? What other language is your keyboard in? Have you adjusted the editor's localization settings?

avatar image Eyez Apr 15 '15 at 06:11 PM

Hi. actually that only happens when my keyboard is set to English - US (the keyboard config with the tilde right bellow esc key). My other languaes are Portuguese - ABNT and Japanese with 3 setups. but the issue only happens while I'm in english.

I've tried to reproduce that bug by shutting and restarting the editor with other languages set in, and also tried changing the localization, but since it's a pretty rare/random bug, I couldnt reprduce it enought to get any conclusions...

My localization settings is set to enlish, un-specified region. But at the school some are in portuguese and others in english..

avatar image Adam Davis STAFF Apr 16 '15 at 03:00 PM

Is it the same at the school? Do the Portuguese setups produce the error or is it still limited to the English PCs? I'm still unable to reproduce this on my end.

avatar image Eyez Apr 16 '15 at 03:52 PM

I'll run some better tests there tonight, but I'm not sure about when that error happens in there since it had never happened to me there, only to my students... I'm also unable to reproduce it whenever I please, it's pretty rare.. I actually see that bug comming in because I'm currently mostly developing some assets for my team t use via BP instead of the usual Visual Studio, So I begun working with print strings a lot... and on average I run UE4 on my PC about 8 hours a day, 6 - 7 days a week... and for the past few months I'm mainly working on Development through BP... so print string comes in hand 90% of that time... and yet, there were only about 10 - 20 times that happened.. maybe 2 or 3 times on 4.6, the rest on 4.7

I'll reply again after some tests at the school.

avatar image Adam Davis STAFF Apr 21 '15 at 03:02 PM

Hi Eyez,

Have you been able to test this at the school?

avatar image jubanka Apr 23 '15 at 06:35 PM

If I may interject, I can reproduce this in PIE by bringing up the gameplay debugging tool (' (apostrophe key)), then stopping PIE (Esc) [i.e. quitting PIE with the tool on]. On subsequent PIE, log is not shown on screen. As mentioned, quitting the editor with logging in this state requires a couple of editor restarts to restore. Sometimes, bringing up and hiding the gameplay debugging tool restores printing as well.

avatar image Eyez Apr 24 '15 at 04:41 PM

Hi! sorry for the delay!

I did run a lot of tests on the school but I couldn't reproduce it enought by "random means" (I.E. asking the student to dabble with it, and trying various setups), untill... well, Untill I saw a student closing the window with the ' menu open and right after that it lost the print to screen functionality.

As Jubanka also stated, and I did tried it a couple times, it seems pretty consistent now.... but in all of the machines I could only get it to work while on english keyboards (but mainly because I can't bring the console up with ABNT keyboard structure)

avatar image haimat Jul 05 '15 at 04:34 PM

I am using 4.8 and experiencing the same bug. Actually, it's two bugs it seems. First, sometimes debug output is not printed to screen, but it is printed to log/console. I haven't found any reason to why this happens. Usually a editor restart or two fixes the problem. Also I cannot open the GDT at all, maybe because I am working with a German keybord, and we need to hit SHIFT+' to get the apostrophe key. Any ideas?

avatar image Adam Davis STAFF Jul 07 '15 at 02:50 PM

Hi haimat,

This has been fixed internally and is slated for the 4.9 version of the engine.

avatar image haimat Jul 07 '15 at 03:02 PM

Thanks for the reply! But which bug do you mean, access to GDT or PrintString?

avatar image Adam Davis STAFF Jul 07 '15 at 03:21 PM

The print string bug (UE-14330). Are German keyboards typically AZERTY? If so, there is a bug report already in for specific keybindings not working with AZERTY keyboards, specifically the ù, £, §, ^, _, ', or ². This bug has been backlogged but if this is the case I can increase the community interest, which while not a guarantee may help to bring more attention to the bug in question.

avatar image haimat Jul 07 '15 at 03:24 PM

We have QWERTZ keyboard layouts. As said, to access ' (apostrophe) I need SHIFT+'. What bugs me: I cannot access GDT at all during gameplay, so that has a high severity for me! I don't even know of any workaround to access GDT during gameplay, only simulation :-(

avatar image Adam Davis STAFF Jul 07 '15 at 03:32 PM

Have you checked the keybindings in your Editor Preferences menus? You should be able to reset the keybinding to access this there. There is a bug report in for keybindings on QWERTZ keyboards as well, UE-15466. You should be able to reset the keybinding to another key that does work until this is addressed, though as with the AZERTY keyboard bug report this has been listed as backlogged. I'm going to up the community interest on it to better reflect the number of developers this is currently affecting.

avatar image haimat Jul 08 '15 at 06:46 PM

Thanks for your feedback, Adam. Your idea of changing the keybinding for GDT sounds like a nice idea, but unfortunately I cannot find that specific setting in the editor preferences (only a lot of other keybindings, but not for GDT). Could you please be so kind and guide me into the right direction? Thanks!

avatar image Adam Davis STAFF Jul 08 '15 at 08:45 PM

Hi haimat,

You are correct. I had a look through the keybindings and couldn't find a listing either. However, I did a bit of digging and found this:

https://docs.unrealengine.com/latest/INT/Gameplay/Tools/GameplayDebugger/index.html

Specifically, you can enter the console command "EnableGDT" to turn on GDT while playing your game. While it is a bit more cumbersome for now, I tested it and this does work so it should be a viable workaround until the QWERTZ keyboard binding bug is addressed.

avatar image haimat Jul 09 '15 at 08:56 PM

Hi Adam, thanks for the link. But does that really work for you? I have two issues with that approach. 1) No detail information is shown. It seem EnableGDT does just that, enabling the overlay. But where is the actual AI data? I only get the top info line telling me to use numpad keys for various options. 2) How to switch from one AI controller to another? By default one should use ' key, but what if that key isn't working?

avatar image Adam Davis STAFF Jul 09 '15 at 08:59 PM

Hey haimat,

It did work for me, though I didn't check with more than one AI so unfortunately I don't have that information on hand. I'll try to get back around to this tomorrow to see if I can try to get it to switch between AI in the GDT, if I figure it out I'll post here with the additional information.

avatar image haimat Jul 09 '15 at 09:14 PM

I appreciate your feedback very much! But I am wondering, what have you done exactly in order to get that to work? I focus with my in-game (3rd person player) camera on an AI-controlled character that uses a behavior tree. Then I entered EnableGDT in the console, and the basic GDT "menu" appears on the top of the screen. Telling me what keys to press (like apostrophe and numpad keys). However, nothing else is shown at all, as if no character has been seletcted. When I open the GDT in simulation mode though and select and actor, then much more information is shown. Could you please elaborate on that? Thanks!

avatar image Adam Davis STAFF Jul 13 '15 at 07:55 PM

Hi haimat,

I see what you mean. I have been able to reproduce this error and have entered a bug report, UE-18548 to be assessed by the development staff. Unfortunately I don't have any other viable workarounds at this point in time given the QWERTZ keyboard bug other than to utilize a QWERTY keyboard setup so you can use the ' key.

avatar image haimat Jul 13 '15 at 08:52 PM

Well, I am thankful for your reply. But frankly, that is not an option for me, we are bound to our local keyboards here... Since there is no workaround here, this is a very severe bug for me. What can I do in order to give it a higher priority on your end? For me currently that feature is not available at all :(

avatar image Adam Davis STAFF Jul 14 '15 at 03:55 PM

At present all I can do is bump the community interest when additional developers report the same error. This isn't a guarantee that it will get higher priority, but it does help to show that multiple developers are affected by the same bug.

avatar image haimat Jul 14 '15 at 07:10 PM

I really do appreciate your feedback and support. Still, I am quite sorry to hear there is no other option, as I really need that feature and can't use it right now. I hope you do support non US-developers as well!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Guys, it's simple. I solved my problem just by selecting the blueprint on the scene, then in the details panel, under input, changing "Auto Receive Input" to player 0.

Hope it helps you! o/

more ▼

answered Jun 09 '16 at 02:01 AM

avatar image

DanTxal
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Vocês estão arrastando o ator para a tela do jogo?

Are you putting the actor in the screen editor game?

more ▼

answered Oct 14 '17 at 01:59 PM

avatar image

rafaellcustodio
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question