x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Stuck on root node when running behavior tree.

Here's a screenshot of what I mean: alt text

The root node of the behavior tree is the only one running. Is there a specific reason for this? This same behavior tree sequence worked in 4.6, so I'm wondering if anything changed in 4.7 to have caused it...

Product Version: Not Selected
Tags:
stuckonroot.png (122.9 kB)
more ▼

asked Mar 13 '15 at 09:58 PM in Blueprint Scripting

avatar image

jechli
145 22 26 84

avatar image najir Jul 14 '15 at 08:33 PM

I have the same issue, no idea whats causing it. Followed the AI tutorial on the unreal docs to get some basic ai in and it wont run just stay at the Root node.

avatar image MieszkoZ STAFF Jul 15 '15 at 09:51 AM

The reason for this behavior is behavior tree component not being able to find a task it can run. Try adding a "fallback" wait task and you'll notice that one gets run. I suggest using visual logger for debugging this issue.

avatar image najir Jul 15 '15 at 11:14 PM

Alright thanks for the help :P

avatar image Mattison May 11 '16 at 03:28 AM

Hey! I'm having this same issue, but I'm just trying to get my AI Character to follow me. I did the vislog thing and Found some things that were questionable but don't know how to fix them...

Any help would be greatly appreciated!!!

vislog.png (162.0 kB)
bt.png (126.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Ran into this problem myself in version 4.16.1, I'm finally learning how to pop some AI into my concept project and opted to start with the basic tutorial. This was one of the few posts I found where someone ran into the same problem I did, though it seems like it was kind of left without any resolutions. Here's what I figured out for my situation:

  • Set the "Get All Actors of Class" node to have the same class as the object using the AI (since this will be used in the Actors to Ignore pin for the Multisphere Trace).

  • Make sure the multisphere trace radius is set to a value greater than 0.0 (I didn't spot that it was set to 1500.0 in the node picture, so my AI was scanning a radius of nothing).

  • The "Line Trace by Channel" node must have the trace channel as "Camera" rather than "Visibility" or else the object that it's checking for just comes back as "None."

Using the Visual Logger, breakpoints, and also just setting variables to output their values to the log during play helped me stumble through this one, so those are my recommendations for anyone who has different problems getting that tutorial up and running.

more ▼

answered Jun 06 '17 at 06:25 PM

avatar image

Mephestys
26 2 2

avatar image LocoTaco6 May 22 '18 at 07:57 AM

Thx for saving me hours of searching for the problem. I looked over the "Camera" rather than "Visibility" part so that was my problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The only thing that crosses my mind is that all the tasks fail and BT is unable to "stay" in any task. I've also noticed that one of your "leaf" selectors doesn't have any child tasks - I wonder if that's messing up the BT code.. Regardless, could you record a vis log and send it our way (or investigate it on your own - who knows, you might find something interesting! :))

(to summon vislog UI just run console command vislog, or look around in the menus - I think it's somewhere there :D)

Cheers,

--mieszko

more ▼

answered Mar 16 '15 at 02:42 PM

avatar image

MieszkoZ STAFF
7.3k 223 57 412

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My problem was in the AgroCheck blueprint that i copied from the tutorial, the Get All Actors of Class node had no class set :p

Hope this helps someone!

more ▼

answered May 16 '16 at 07:54 PM

avatar image

goncasmage
897 12 14 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So I thought I would let people know what the solution was that I found. It was incredibly easy to miss and i rewent through the entire thing twice.

After hours of going through and break pointing everything. The output log was giving warning, invalid object type. I found out my DesiredObjectTypes in the agrocheck wasn't set. I didn't see this little bit in the instructions, but there needs to be a variable added to that of type pawn. I compiled it, and the ai ran at me and scared me. Hope this helps anyone struggling like I did.

[1]: /storage/temp/270227-ue4aicapture.png

ue4aicapture.png (99.2 kB)
more ▼

answered Mar 04 '19 at 08:09 AM

avatar image

totallysane
3 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question