x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.2] "profilegpu" does not work on Android ES31+AEP

the "profilegpu" command causes the follow error on Android ES31+AEP :

Fatal error: [File:G:\uesrc\UnrealEngine\Engine\Source\Runtime\OpenGLDrv\Private\OpenGLDevice.cpp] [Line: 305] D/UE4 ( 8126): [API][Error][High][1282] GL_INVALID_OPERATION error generated. Cannot begin query on an active query object.

reproable with any map. Tested on Shield Tablet with OTA2.2

Product Version: Not Selected
Tags:
more ▼

asked Mar 14 '15 at 12:16 PM in Bug Reports

avatar image

bethor
31 1 8

avatar image [Epic] Gribbs ♦♦ STAFF Mar 14 '15 at 07:36 PM

Howdy bethor,

Thank you for reporting this issue. I have just attempted a quick repro of this issue internally and have been unsuccessful so far. Here are the steps that i took:

1) Deployed a template project to a Shield Tablet on 2.2.1 2) Once deployed, I opened the console command in the level and entered 'profilegpu' 3) I was unable to see any errors on the device.

Would there be any steps that I would be missing? Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image bethor Mar 15 '15 at 04:31 AM

Hello Sean,

That is strange. Just in case I tried making a clean sync and build on a different pc, and see the issue there too.

Some possible areas of mismatch I can think of:

  • Are you building from the release branch (not master)?

  • Are you using a Development build?

  • Are you entering the "profilegpu" command directly on the device, after bringing the console up with a 4 finger tap?

  • Are you checking for errors in logcat (there is no dialog box)

  • Does your shield tablet version details match the following:

alt text

I've also put a test apk built on my machine here:

https://www.dropbox.com/s/ty0i0ixxdihj7e6/profilegpurepro0315.zip?dl=0

If you can try this, it should tell us if the mismatch is on the build itself or the device's behavior.

Thanks for looking into this.

avatar image bethor Mar 16 '15 at 01:04 PM

Sean, I cannot reproduce the issue on the master branch, so I suppose I just need to wait for the 4.8 release. Feel free to close this issue, thanks!

avatar image Henry Read Jul 12 '18 at 06:42 AM

I faced the similar problem, but I received no crash log. I was using the UE4.19.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Howdy bethor,

Glad to hear that this issue has been resolved for you in the Master branch of UE4. If you run across this issue in a future build, be sure to reopen this issue so that I may be able to further investigate.

Also, just a reminder that the Master branch is not a stable build of UE4. Be cautious when developing a project in that build. I would recommend opening a copy of your project so that you will have a back up if anything does go wrong.

Thanks and have a great day!

more ▼

answered Mar 16 '15 at 01:30 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 76

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question