x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Health bar doesn't work in 4.7.2?

I have followed your tutorial on Creating the Inventory and Action Menus, I have also followed 3 other tutorials that do the same thing slightly differently..

All i frigging want is a health bar, 6hrs and still no health bar.

I have the HUD Showing up fine, The health bar, energy bar and mood bar.. I event followed the tutorial exact with the pickups just in case that's the reason i couldn't just deconstruct it from the examples.

The health bar just doesn't show it's value? I mean i set it as green, If i move the slider i can see it works fine, but hit play and nothing its just grey.. I was getting some Accessed none errror but after pulling my whole project apart many many times to try fix this small issue I no longer get that error.. However i have followed the tutorials over and over!.. If it helps, I have started my project off the twinstick shooter example.

This should be simple, I have spent all day searching for this issue. someone help please? Is this a 4.7.2 bug?

As you can see in pic one i have the bind setup to retrieve the health (I have tried using player controller instead of player character, also have tried creating a reference to mycahracter then getting the health value both do not work)

In mycharacter blueprint you can see that i am calling the hud! what else am i missing? incase i forgot to screenshot something else, Obviously like i said i have followed your tutorials to the T so if i forgot to screenshot something my bad, but you can assume it's exactly as it is in the tutorial.alt text

alt text

**Oh and i have alreadyb loaded up the example in another instance and compared everything, It seems everything is the same and yet it works in the downloaded example but not in mine.! I have watched so many frigging videos and tried this over and over

Product Version: Not Selected
Tags:
healthbar 1.png (250.6 kB)
healthbar 2.png (78.7 kB)
more ▼

asked Mar 15 '15 at 09:51 AM in Blueprint Scripting

avatar image

MikeDog
8 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Well I finally solved it myself. I will post it here as most people do not post when they fix it.

However My issues was that mycharacters Parent class was Pawn (not sure why) and for some reason this stops the bars getting the information but does not give you any indication of this.. Please try to fix this maybe Unreal :P

All working now.

more ▼

answered Mar 16 '15 at 02:27 PM

avatar image

MikeDog
8 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

There may be multiple causes. If you upload your project on dropbox (or at least the myCharacter and the HUD blueprint) I'll tell you where the problem is.

more ▼

answered Mar 15 '15 at 11:40 AM

avatar image

Iohoilpotere
696 23 13 28

avatar image MikeDog Mar 15 '15 at 02:03 PM

So sorry for delay, I have placed my mycharacter and gameHud files in a public dropbox for you to look at.

Thanks heaps.

(Might need to give the link a minute my dropbox was a bit behind..)

https://www.dropbox.com/sh/utpjq40h13aiyu3/AAA5KWNVsJXbQ0Hdr7TKJps4a?dl=0

EDIT - I also tried to use this as my bind to percent... Score is a float stored on mycharacter - http://gyazo.com/046d612ef0dcb6428c9e19162beefcc2

avatar image Iohoilpotere Mar 15 '15 at 02:09 PM

Actually I can't see any files. I think you gived me the overview link.

EDIT: The error is 404

avatar image MikeDog Mar 15 '15 at 02:12 PM

My dropbox is still uploading :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question