x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Perforce check-out option disabled in editor

When attempting to check-out assets within the editor when saving, the option to check-out and object is grey / disabled.

Within the check-out window selected files can only be made writable.

I can still manually check out those files within the Perforce client.

I've followed every guide for setting up Perforce for UE4 and am still unable to check out files from the editor.

Product Version: Not Selected
Tags:
more ▼

asked Mar 15 '15 at 06:34 PM in Using UE4

avatar image

JonTerp
10 1 4 6

avatar image Azarus Mar 15 '15 at 08:05 PM

Because someone else is already checked out the files. They have to check in, so others can work on the files.

avatar image JonTerp Mar 15 '15 at 08:11 PM

I'm the only one using the Perforce server. The files are not checked out before hand.

avatar image Azarus Mar 16 '15 at 01:29 AM

Then that someone is you. Maybe submit your changes / check in the files? Or give us more info, logs, concrete error? etc...

avatar image Tom Sarkanen STAFF Mar 18 '15 at 11:39 AM

There are a few reasons that I know of why that button can be greyed out:

  1. The assets are checked out by someone else, or yourself in a different workspace.

  2. The assets are not at the head revision.

  3. The assets are already checked out in this workspace.

  4. The assets are not under source control, or are being ignored for source control purposes.

  5. The editor is not connected to the server.

  6. Source control integration is disabled.

avatar image JonTerp Mar 18 '15 at 08:44 PM

Thanks for the reply Tom,

I've checked everything you mentioned and still get the grey box in the prompt that appears when saving changes to assets in the editor.

I can go into the Perforce client afterwards and check-out the file just fine. The prompts in question don't appear once the assets is properly checked out.

Could it be a server settings that I missed? I followed the steps in the documentation article on Perforce.

Note that I tried this on another computer with a clean install and had the same problems.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This turned out to be a corrupt Perforce database causing the issue. This is resolved now.

more ▼

answered Mar 22 '15 at 02:20 AM

avatar image

JonTerp
10 1 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question