x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm Agent Connection Stuck on Build

Hello, I'll start by saying I have already searched around several times trying to resolve this bug myself without having to ask for help, but so far no luck finding any fixes on this. Basically every time I attempt to build the lighting on the level, it gets stuck at 100% and freezes. Maybe I just missed a step somewhere on how to set this up? This is on 4.7.2 alt text

Product Version: Not Selected
Tags:
screenshot.png (992.0 kB)
more ▼

asked Mar 16 '15 at 02:56 PM in Using UE4

avatar image

Catakard
1 1 2 3

avatar image masterwigglestin Mar 21 '16 at 05:29 AM

I have this same problem but in 4.10.4. I have 16GB of Ram, a GTX 970, and a 6 core I7 so it isn't my computer. I am running windows 10 if that is helpful information, and I have totally reinstalling the engine but that didn't help.

avatar image Tim Hobson ♦♦ STAFF Mar 21 '16 at 02:55 PM

@masterwigglestin

Can you please make a new post in the Rendering section of AnswerHub. Include your Swarm Log with it set to Super Verbose in the Swarm Agent Settings tab.

Make sure to include a DxDiag for your system.

Also you may want to check out the Swarm Agent Troubleshooting Guide I wrote a while back to run through some of the more common troubleshooting issues with Swarm Agent.

It's also helpful to reproduce any issues in a blank project with a new scene.

Thank you!

Tim

avatar image djsokaris Jun 21 '16 at 03:34 PM

Hi all,

Just to follow this thread, it happened to me exactly the same thing with both UE 4.10 and 4.12, I really didn't know what was causing this issue. I read the logs in the SwarnCache folder located for my case here : C:\Program Files (x86)\Epic Games\4.12\Engine\Binaries\DotNET\SwarmCache\Logs.

Reading this log (which made no sense at all the first time I read it), after a lot of search, tries, fails, I found one very important line : System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

By googling it, I found this web page http://www.sitefinity.com/developer-network/knowledge-base/details/this-implementation-is-not-part-of-the-windows-platform-fips-validated-cryptographic-algorithms-exception , that explained to Go to Start > Control Panel > Administrative tools > Local Security Policy. The Group Policy dialog appears. Under the "Local Policies" heading, select "Security Options" and look for the entry, "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing." If this entry is enabled, disable it. Open the registry editor and browse the following path. Make sure this registry subkey is set to 1: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\fipsalgorithmpolicy

Which I've done and straight after this it worked again! Hope it can help people who have been stuck with this thing!

Thanks

Geoff

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hi Catakard,

This is common for lightmass and swarm agent when it is wrapping up. The light build will finish at 100%, but it may take a while longer for the lightmap textures to process and be applied.

If you've given it a little bit of time, more than likely depends on your system specs. Try waiting 10 minutes or so.

If it's still stuck and not doing anything you can try some/all of the following:

  • Open Swarm Agent > Menu > Cache > Click Clean and then Validate

  • Navigate to this folder and delete it's contents while the editor is closed: C:\Users[Your Computer Name]\AppData\Local\UnrealEngine

  • Make sure you don't have multiple Swarm Agents open in your taskbar tray

These would be the areas to check first. If the error is still occurring can you try building lighting for one of the template projects, like the first or third person template?

Let me know.

more ▼

answered Mar 17 '15 at 10:20 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

avatar image Catakard Mar 18 '15 at 05:21 PM

I let it go for an hour and still nothing. Tried everything you listed and no results there either.

I have 8GB of ram. Using Nvidia GTX 465 on Windows 7 Ult

Let me know what info I can get to you to help solve this problem.

avatar image Tim Hobson ♦♦ STAFF Mar 18 '15 at 07:23 PM

Is it only in this project that lighting will not build? Have you tried a template project to see if things build in there? If so, then we can probably narrow it down to something project specific and go from there.

avatar image Catakard Mar 19 '15 at 01:24 PM

Its all projects, including template projects and blank projects with nothing in it. The build process just does not work, even when i set everything to minimal settings for fastest time

avatar image Tim Hobson ♦♦ STAFF Mar 19 '15 at 06:50 PM

If you open up Swarm Agent and take a look at the Log tab, what's being printed there when you try to build lighting?

Also, Try turning off your firewall and anti-virus to see if this will allow swarm agent to build. If that works you can just add an exception for swarm agent to allow it to work properly.

avatar image Catakard Mar 20 '15 at 04:40 PM

Ive already tried doing that before, but just to be safe I tried it again and still nothing. Firewall disabled and Antivirus off. The Swarm log is the same as whats in the picture above.

12:35:16 PM: Starting up SwarmAgent ... 12:35:16 PM: ... registering SwarmAgent with remoting service 12:35:16 PM: ... registering SwarmAgent network channels 12:35:16 PM: ... initializing SwarmAgent 12:35:16 PM: [ERROR] Local agent failed to initialize with an IPC channel! Falling back to TCP... 12:35:16 PM: [ERROR] Local agent failed to initialize with a TCP channel! Fatal error.

avatar image Tim Hobson ♦♦ STAFF May 11 '15 at 02:14 PM

Hi Catakard,

We've just released the preview releases of 4.8 Preview 1. Would you be able to grab that and see if you're still seeing problems building lighting? Can you try using a blank project with the default scene (scene with just the floor mesh, or you can add the starter content and use the scene that has the two chairs and table).

Let me know if lighting will build in this.

Thanks!

Tim

avatar image Catakard May 12 '15 at 10:06 PM

I ended up upgrading to Windows 8.1, which is certainly not the best solution, but it solved the problem. Everything works great now. I appreciate your help Tim. Its unfortunate we were not able to solve it.

avatar image Tim Hobson ♦♦ STAFF May 13 '15 at 12:26 AM

Agreed. I'm glad everything is working well for you now. There are a lot of variables that can cause Swarm to not work, and unfortunately we weren't able to figure it out for you in this instance.

Happy developing! :)

(comments are locked)
10|2000 characters needed characters left

Don't use lightmass it's custard. It will 'break' like this on a per project basis once this happens you are square out of luck

more ▼

answered Sep 01 '15 at 11:49 PM

avatar image

Chaoss
6 8 13 19

(comments are locked)
10|2000 characters needed characters left

Tim - the path to the folder with contents that should be deleted (step two in your answer) looks like a PC/Mac filesystem mashup. As I'm not entirely sure which folder you are after on the PC - I don't have a suggested replacement.

That said - I had the same Swarm Agent Connection stuck on 100%. The cause, in my case, was moving my local UE4 GitHub to a different hard drive. The fix was to terminate all SwarmAgents and update the CacheFolder in SwarmAgent.Options.xml

David

more ▼

answered Oct 19 '15 at 11:44 PM

avatar image

DavidRR
54 7 15 17

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question