x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Google Play services removes the leading zeros for .obb file

I am getting an error message when my project is uploaded and published in alpha for google play (.apk + .obb). The file downloaded matches the .apk and .obb size, but when downloaded through google play it refuses to play, while the same .apk and .obb, when deployed to the phone via the batch file, work perfectly.

The exact error message I am getting is "Failed to open descriptor file '../../../ProjectName/ProjectName.uproject'".

What am I missing? Using version 4.7.1 .

Product Version: Not Selected
Tags:
more ▼

asked Mar 16 '15 at 02:53 PM in Packaging & Deployment

avatar image

BaderThanBad
664 21 18 177

avatar image BaderThanBad Mar 17 '15 at 11:00 AM

I noticed that the .bat files installs to folders inside the root of the phone while the appstore downloads it to Android/data and Android/obb. I tried downloading the TappyChicken from the playstore and it does indeed manage to extract itself to the root from the Android/obb and leaves it empty. I also saw an installing after the tappychicken download completed. Is that what I am missing? How would I go about doing this step.

avatar image BaderThanBad Mar 17 '15 at 01:14 PM

I Built TappyChicken and I get exact same error. It works fine running from .bat file, but when uploaded to alpha on google play store and installed from there exact same error. Even upgraded to 4.7.2 and still same thing. Any help would be much appreciated.

avatar image wittlief ♦♦ STAFF Mar 17 '15 at 04:37 PM

Hi BaderThanBad,

We are in fact looking into your issue. I am checking with the Android dev, and it is possible your issue may be related to a problem we're investigating involving obb location and the Google Play store. So hang tight a little longer, and I will report back with anything he finds. Thanks very much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello! when publishing on Android I have same error "Failed to open descriptor.."
My app-game is based on Tappy Chicken. I understood where you found the problem about the 00001.com....obb file, but I didn't see the way to do anything about it while publishing again.

While waiting for the fixed UE4.7.4 or 4.8 what can I do now? Google play developer site never mentions anything about .obb. Or am I wrong? I must be missing something.

Thank you in advance.

more ▼

answered Mar 30 '15 at 10:27 PM

avatar image

aabun
77 5 7 6

avatar image BaderThanBad Mar 31 '15 at 12:39 PM

In the options for android inside the project you are going to have to chose a 5 digit version until this is fixed, something like 10001.

avatar image aabun Mar 31 '15 at 03:43 PM

Ok, I finally understood how to do it, thank you BaderThanBad! You are Gooder Than Good! My updates are pending, and I hope this time my game will work in the Google play store in Androids..

avatar image aabun Apr 01 '15 at 05:00 PM

Unfortunately, even if with this change, 10001 version, I have same message Failed to open descriptor... Maybe my problem is in something else?

avatar image tefica May 02 '15 at 01:22 PM

I've changing my store version to 10002 (because my first was 00001) in UE 4.7.6 and it is working fine for me on Google Play (10001 should work too) : THX BaderThanBad !

10002 Gobb

10002.jpg (110.5 kB)
googleobb.jpg (69.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I think I found the issue (still waiting for google play to publish to confirm). In the engine's AndroidLaunch.cpp file (in the initialize function), it assumes that the obb file's name has 5 digits with leading zeros. Google Play services, when you upload the .obb, removes the leading zeros causing the discrepancy. I believe a temporary workaround would be to use a 5 digit (non leading zero) version number and was going to file a bug report after I have confirmed this. The apk is yet to be published so I cannot confirm anything but please pass along this info may it help.

more ▼

answered Mar 17 '15 at 05:06 PM

avatar image

BaderThanBad
664 21 18 177

avatar image wittlief ♦♦ STAFF Mar 17 '15 at 05:07 PM

Noted! Thanks for the info.

avatar image BaderThanBad Mar 17 '15 at 06:23 PM

I just confirmed this, managed to download TappyChicken from my google play alpha deployement and it works with a 5 digit version number.

avatar image wittlief ♦♦ STAFF Mar 17 '15 at 09:05 PM

Ok cool. I'm going to mark your answer as the good one, and close this out as resolved for this issue. If you see anything else funky we can re-open this or start a new AH thread. Thanks very much!

avatar image wittlief ♦♦ STAFF Mar 18 '15 at 01:49 PM

For anyone else who has this problem I am going to go ahead and affirm that I spoke to the Android dev, and he confirmed that it is in fact that Google has made (undocumented) changes in how the obb is named and the leading zeros are the problem. He has made changes to the pushed directory for obb files so that they match the new expected locations. This change should go into effect with 4.8, possibly earlier if we have another 4.7 hotfix. Thanks much for your help, BaderThanBad!

avatar image Darth_Gilbers May 25 '15 at 12:47 PM

You sir, are a genius. Was going mad trying to figure out what was causing this issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question