x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[4.7.3] Engine crashes on compile of one blueprint only if child of that blueprint is also opened in another tab

This is a strange bug. If I open one of my blueprints ("Building") and compile it, everything works. But if I have another blueprint opened in another tab and this other blueprint is a child of "Building" then the Engine crashes ~10 seconds after I hit compile of Building, before it's crashing it's just freezed.

I tried it now 4 times, it crashes every single time if the child blueprint is opened.

Here you have a Callstack and the log, I compiled "Building" two times, then I opened one child blueprint and tried to compile Building again.

Callstack

Log

I am using the latest 4.7 branch from github.

Product Version: Not Selected
Tags:
callstack.txt (9.0 kB)
strategy.log (60.1 kB)
more ▼

asked Mar 17 '15 at 04:08 AM in Bug Reports

avatar image

John Alcatraz
1.3k 58 139 126

avatar image Ben Halliday STAFF Mar 17 '15 at 04:05 PM

Hi John,

I wasn't able to reproduce this in the latest 4.7.3 (from today). Your log actually shows a successful compile of Building before the crash, so I'm guessing the crash is happening when the child tries to update.

Does this only happen with that one Parent BP, or does it occur with others? Does it occur with any children, or just one? If you create a new Actor BP and create a child, does the same crash occur?

avatar image John Alcatraz Mar 17 '15 at 04:58 PM

4.7.3 from today is actually the same as 4.7 branch from yesterday since the last commit was 2 days ago.

It actually only happens with one child ("CivilHouse"), not with all childs. I have noticed this bug only with "Building" and "CivilHouse", not with any other Parent/Child combinations. So if I create a new Actor BP and a child the crash of course does not occur.

avatar image Ben Halliday STAFF Mar 18 '15 at 04:36 PM

Hi John,

Thanks for those details. Since it's only happening with that Parent/Child combo, can you zip and attach those assets here so the developers can take a look? Thanks!

avatar image Ben Halliday STAFF Mar 18 '15 at 05:49 PM

Actually, I've asked for the project in your other post, so if you can get me that I'll use it to investigate both issues.

avatar image John Alcatraz Mar 18 '15 at 06:02 PM

Sure, here they are: link text

buildings.zip (315.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi John,

I was able to reproduce this in your project with the Building and CivilBuilding Blueprints. I've created a bug report for the issue (UE-12136), and I'll let you know as soon as I see any update on it.

more ▼

answered Mar 18 '15 at 11:07 PM

avatar image Ben Halliday STAFF Apr 14 '15 at 05:16 PM

Hi John,

Just wanted to give you an update that this has been fixed in our main internal build, and the fix should be included in the 4.8 release.

avatar image John Alcatraz May 06 '15 at 03:46 AM

Thanks! You can't imagine how often I accidentally had both of these blueprints opened and tried to compile one of them in the last weeks/months without thinking about this bug. Really nice to hear that it's fixed in 4.8.

avatar image Ben Halliday STAFF May 06 '15 at 03:10 PM

I understand that must have been frustrating. Please let us know if this behavior pops up again after 4.8 is released. I think we're doing a Preview shortly, so you'll be able to test it there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question