x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Substractive brush creates surfaces

Hello,

i have a little problem.

I try to cut a cylinder with a substractive box brush. When i hit build geometry, some surfaces appear at the edges of the substractive brush.

Does somebody have any idea? Rebulding and trying in new generated map doesnt work too

alt text

Product Version: Not Selected
Tags:
before cut.jpg (129.4 kB)
after cut.jpg (102.8 kB)
more ▼

asked Mar 17 '15 at 08:33 PM in Bug Reports

avatar image

LoveSofa
1 1 2

avatar image Alexander Paschall ♦♦ EPIC Mar 18 '15 at 06:54 PM

Hi LoveSofa,

I'm looking into this issue and have been getting different results. I am currently testing in 4.7.3 with two BSPs, one box, one cylinder. The box is subtractive and the cylinder is additive, the section cuts out, but I am not getting a square like that.

Could you tell me the exact dimensions of the objects and the number of sides the cylinder has? Which version of UE4 are you using? Also, does this only happen with those two shapes or do other brushes do this as well? Any additional information may help in the investigation.

Cheers!

avatar image LoveSofa Mar 18 '15 at 08:25 PM

Hello,

i tried to reproduce the case with different settings. I found out , that this problem occurs when the brushes get very big. When i use the same case with smaller brushes this problem does not occur. I dont know the exact dimension anymore but i can tell you that it always occured when the cylinder brush was bigger than 20.0 on y axis. It also occurs when i try to cut the cylinder with many small subtractive box brushes. But the problem still occured. So i think ts has something to do with the additive cylinder brush. Using the actual version of unreal tournament editor.

I just tried the case after the new update. I found out how to reproduce it. I build the brushes like in the pictures above. Then i marked both brushes and hit create static mash. Then this problem occurs (only with big brushes). From this point, the program seems to be buggy too when i just hit build geometry. When i hit build geometry before i create the static mesh the probem does not occur

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi LoveSofa,

Thank you for your report, I was able to reproduce this and have entered a bug report, UE-946 to be assessed by the development staff.

more ▼

answered Mar 18 '15 at 10:10 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question