x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.2] No affect MobileContentScaleFactor on Android device

Hey guys.

I found an issue for screen resolution on android device.

I'm trying to make my game playing on ACTUAL resolution for any device. so I set +CVars=r.MobileContentScaleFactor=0 in DefaultDeviceProfile.ini as following.

 [Android DeviceProfile]
 +CVars=r.MobileContentScaleFactor=0

because, if r.MobileContentFactor is 0, it can be set actual resolution on android device as following code AndroidWIndow.cpp

 // CSF is a multiplier to 1280x720
 static IConsoleVariable* CVar = IConsoleManager::Get().FindConsoleVariable(TEXT("r.MobileContentScaleFactor")); 
 float RequestedContentScaleFactor = CVar->GetFloat();

 // 0 means to use native size
 int32 Width, Height;
 if (RequestedContentScaleFactor == 0.0f)
 {
     Width = MaxWidth;
     Height = MaxHeight;
     UE_LOG(LogAndroid, Log, TEXT("Setting Width=%d and Height=%d (requested scale = 0 = auto)"), Width, Height);
 }

but, IT DIDN'T WORK.

so, I followed the log using logcat and found wrong sequence of initializing. (my device's resolution is 1920x1200) alt text

I think this is wrong sequence of initialization.

anyway I've solved this problem temporarily to set r.MobileContentScaleFactor value to DefaultEngine.ini.

 [/Script/Engine.RendererSettings]
 r.MobileContentScaleFactor=0

It works. but it is removed when I modify DefaultEngine.ini in Project Setting Window. so this is not comfortable way.

is there any solution except modifying DefaultEngine.ini?

Product Version: Not Selected
Tags:
log.png (24.6 kB)
more ▼

asked Mar 18 '15 at 12:56 AM in Bug Reports

avatar image

JakeChoe
26 2 3 6

avatar image [Epic] Gribbs ♦♦ STAFF Mar 18 '15 at 05:21 PM

Howdy JakeChoe,

Thank you for reporting this issue. I am going to need a bit more information before I begin investigating this issue. Would you be able to clarify if you are using the Source or Binary build of UE4? Also, would you be seeing the same error on 4.7.3?

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image JakeChoe Mar 19 '15 at 01:47 AM

I'm using both of Source and Binary build of UE4. and it is same on 4.7.3. (and same on both of source and binary)

Thank you!

and there is also same issue on r.MobileHDR setting.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 25 '15 at 05:38 PM

Howdy JakeChoe,

Just wanted to let you know that I have reached out to a fellow developer for a bit more information on this issue and will let you know when I get a response back.

Thanks for your patience!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Howdy JakeChoe,

Thank you for your patience. I have just ran a search in our Jira database and found that a Bug Report (UE-13406) has been written for r.MobileContentScaleFactor is not working on Android devices. It is marked as a critical bug and worked on being fixed for the 4.8 release of UE4. At this time, I am uncertain as to is it will make it for that release or when that release will be but I will be sure to keep you posted as I know more.

Thanks and have a great day!

more ▼

answered Apr 10 '15 at 05:13 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.9k 292 13 76

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question