x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Simple AI with Jump Links issues

Hi all,

I have a very simple AI on a side scroller template, in which i have 2 AI, one to follow my character, and another one to go to a specific location (target point).

This is the move to specific location BT: alt text

This is the following BT: alt text

And this is what happens, the first part of the video (move to target) seems that is working ok (but some times my minion waits one milisecond after the jump). The second one (follow) is doing some weird stuff, the first jump, it turns back and then turns again to me and the second jump is not doing nothing: https://youtu.be/0k7JwYTz9Ow

I'm stuck with this problems several weeks, I'll appreciate so much the help :D

Regards, David.

Product Version: Not Selected
Tags:
minionfollow.png (74.0 kB)
miniontobase.png (73.4 kB)
more ▼

asked Mar 18 '15 at 05:37 PM in Using UE4

avatar image

Davixe
184 18 20 33

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

There's a bunch of issues here :/

The easier one, the AI jumping off and then going back a bit - this is due to AI overshoting the landing location while jumping down. You can address that by making jump-down end locations closer to where AI would land while following it. A real, proper solution would be to implement a custom path following component that would take that into consideration and just switch to the next path segment after landing.

The AI getting stuck against the wall while following the player is an effect of bugs in "Move to actor" mechanics. Some have been fixed in 4.7.3, some wait for 4.7.4. All should be fine on the github version. If you tried that let me know if you still experience issues.

Cheers,

--mieszko

more ▼

answered Mar 19 '15 at 10:17 AM

avatar image

MieszkoZ STAFF
7.2k 223 56 407

avatar image Davixe Mar 25 '15 at 04:18 PM

Thx for the answers, I tried what you said,

First, I tried moving the jump-down end location, but seems that wasn't working, so i tried using "SetNextMoveSegment();" everytime my AI finds a jumpflag, but this solve this problem only in the 90% of the cases.

For the other issue, I'm using the git version with the release branch, I just did a pull, and this problem is still here, but just only a few times. I put some debugs on my custompath, and seems when my AI is following other actor is ignoring that jumpflags.

Both problems appears more frequently when my actor is moving close to the AI character.

Thx :D

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question