x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.3] Navmesh + instanced static mesh

I'm randomly generating a tiled map with instanced static meshes I made in Blender. First, the navmesh would not work at all, then I added a 'set world location' to the scene component root. Now, the navmesh is generating over the floor tiles which I did not make in Blender, I think the floor was from the starter content. I added collision in Blender by adding boxes with the UCX_ prefix and I double-checked that they imported correctly. All my meshes have the same collision settings in UE as the floor.

The row of tiles closest to the camera are ones I placed manually, there the navmesh is generating fine as you can see.

The random generator is basically the simple example from the first few minutes of the "Twitch training stream: Procedural room generation".

I can't figure out what I'm doing wrong or if this even should be in the bug reports section.

alt text

alt text

Product Version: Not Selected
Tags:
navmesh1.jpg (129.1 kB)
navmesh2.jpg (260.2 kB)
more ▼

asked Mar 18 '15 at 11:12 PM in Bug Reports

avatar image

Mindtrucks
26 1 4 5

avatar image Alexander Paschall ♦♦ EPIC Mar 19 '15 at 08:02 PM

Hi Mindtrucks,

Just a few quick questions to help with the investigation. Does this only happen with the one asset in particular or any Blender models with collision? If it is just this one, can you please share a copy of it with me to test? If you create the collision in UE4 instead of Blender, does that fix it? What collision settings are you using for your meshes? Any additional information may help as well.

Thanks!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Alexander. Somehow, the navmesh just started working today. I struggled with it for 2 days trying to figure it out, but now when I booted up UE4 it just magically worked, without me changing anything. I am even more confused.

However, one issue still remains. The EQS Test Pawn is still not drawing any debug info in the generated tiles. It does draw on the manually placed ones though. I tried restarting UE4 a couple times now but it did not help.

To answer your questions.. This is happening with the four different room meshes visible in the picture. I'm very new to all this so these are the only meshes I've made so far. I'll include a .blend file from one of them, they should all be pretty much identical. (It didn't allow me to attach the file so I uploaded it to speedyshare) link text

I tried creating the collision in UE4 now, but it didn't help with the EQS.

The collision preset is set to BlockAll, generate hit events is unchecked, generate overlap events is checked, 'character can step up on' is set to ECB Yes. Everything in the advanced collision tab is unchecked except 'can ever affect navigation'.

Thanks.

more ▼

answered Mar 19 '15 at 09:18 PM

avatar image

Mindtrucks
26 1 4 5

avatar image Mindtrucks Mar 19 '15 at 09:52 PM

Some further testing. I tried spawning in AIs, first they didnt move at all. Then I set a 3 second delay to the spawner so the navmesh has time to fully generate before the AIs are spawned in, and now they seem to work. So I'm gonna assume the EQS test pawn would also need a delay.. Seems like all my problems have fixed themselves. Strange how the navmesh just didn't want to work until today though.

avatar image Alexander Paschall ♦♦ EPIC Mar 20 '15 at 02:37 PM

I am very glad to hear that. I am going to convert this into an answer and mark it resolved. If this does occur again, please just comment to reopen the issue and I will be happy to further assist.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question