x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Extremely tiny imported meshes

I use agisoft photoscan for making my meshes. It's photogrammetry. Problem occurs when I import my meshes into UE 4 editor. They are so small that I need to scale them over 90000 times to make them look normal. Literally 50000-90000 times,depending on mesh. How can I make these meshes normal for UE 4?

Product Version: Not Selected
Tags:
more ▼

asked Mar 19 '15 at 02:47 PM in Rendering

avatar image

Fairlightish
18 4 7 9

avatar image particleman1010 Mar 19 '15 at 03:07 PM

UE4 uses centimeters as its base unit. I don't know much about agisoft's workflow and export options, but if it is capable of creating an FBX, you could try importing the FBX into a more standard software package (3dsmax/Maya) to convert scene units and increase the size. If you don't have either of those, I would recommend looking into the Agisoft documentation to see how to set base units to centimeters.

avatar image Fairlightish Mar 19 '15 at 06:38 PM

I imported my .obj to 3dsmax and exported to .fbx and scaling was set to centimeters instead "default" and it did nothing. Could you point me directly to solution? I can't do it. http://i.imgur.com/GuUB0Ny.jpg

avatar image particleman1010 Mar 19 '15 at 08:21 PM

In the Units Setup dialog box in 3dsmax there is a button called "System Unit Setup", everything else only affects what is displayed. FBX export basically just pays attention to the "System Unit Scale" setting. If you change this to centimeters, you should notice the display units in the max viewport changing drastically. After this you should be able to scale your object to its real world dimensions, and export without a problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I would first import them into some 3d editing software and optimise/resize it for ue4. that said, I think I heard someone mention you can also resize your stuff inside ASPS.

more ▼

answered Mar 19 '15 at 03:07 PM

avatar image

Luos
9.3k 286 65 330

avatar image Fairlightish Mar 19 '15 at 07:13 PM

So should I just change units to centimeters in 3dsmax? It did nothing.

avatar image AndrewHurley Mar 19 '15 at 08:50 PM

You should literally increase the size of your mesh using the scale tool in the 3D Modeling program you are using. Then re-export the .FBX file.

avatar image Fairlightish Mar 20 '15 at 07:23 PM

That led to another problem. Scaling object worked and it's normal size now but these arrows are very far from object so I can't precisely set his location. http://i.imgur.com/9mZ2T9S.jpg

avatar image particleman1010 Mar 20 '15 at 08:10 PM

Try centering the object's pivot point at 0,0,0 in the world coordinate system.

avatar image Fairlightish Mar 20 '15 at 08:30 PM

Sorry for stupid questions but how can I do this?

avatar image particleman1010 Mar 20 '15 at 08:35 PM

In 3dsmax, right click the "select and move" tool. This should bring up something called the "Move Transform Type-In", set all of the fields to 0.

Alternatively you could try moving the object close to the black X on the grid as well.

avatar image Fairlightish Mar 20 '15 at 08:47 PM

All values are set to 0. When I scale object, the object is moving away from these arrows. Could you check my model if you have a time? I would be infinitely grateful for you help. https://drive.google.com/file/d/0B39l96jiKAYsT3hIQ28wekw1RFk

Edit: Also I've made a short video to show my problem better. http://youtu.be/ZiRdQ8eZjds

avatar image particleman1010 Mar 21 '15 at 03:11 AM

It looks like the transforms are at the subobject level. try this:

  • right-click and convert to poly

  • enter sub object-vertex mode

  • ctrl+a to select all verts

  • use move transform type-in to zero out the x,y,z coordinates and center the object.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It looks like the transforms are at the subobject level. try this:

  • right-click and convert to poly

  • enter subobject-vertex mode

  • ctrl+a to select all verts

  • use move transform type-in to zero out the x,y,z coordinates and center the object.

more ▼

answered Mar 21 '15 at 03:11 AM

avatar image

particleman1010
11 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question