x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Screen Tearing In Editor

Is there any way to stop it? I've tried googling, checked the relevant config file and smoothframerate is set to true, tried d3d override as well but nothing seems to stop me getting bad screen tearing. Can anyone help?

Product Version: Not Selected
Tags:
more ▼

asked Mar 27 '14 at 12:24 PM in Bug Reports

avatar image

themachinist
1 1 2 4

avatar image themachinist Mar 27 '14 at 04:26 PM

Really sorry to bump but desperate for an answer :(

avatar image Ben Halliday STAFF Mar 27 '14 at 04:37 PM

Hey themachinist,

Can you tell us your machine specs, OS version, and attach your dxdiag, please?

Thanks!

Ben Halliday

avatar image themachinist Mar 27 '14 at 04:52 PM

Sure: Intel i5-2500 Quad Core @3.3GHz, 4GB RAM, AMD Radeon HD 6850, Windows 7 Home Premium 64-bit... I know the graphics card and RAM aren't quite up to scratch but I seem to be getting a good framerate from bringing some of the settings down. But the tearing persists! link text

seandxdiag.txt (22.5 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey themachinist,

You can force vsync on by running from a shortcut or commandline with -vsync. You can also see if limiting your FPS to 30 causes any change to this behavior, as described here: https://answers.unrealengine.com/questions/13389/limit-fps-to-30.html

Is the screen tearing occurring just in the editor, or does it happen in game, too? If in the editor, does the UI tear or is that just in the Viewport?

Ben Halliday

more ▼

answered Mar 27 '14 at 05:28 PM

avatar image themachinist Mar 27 '14 at 06:28 PM

Thanks for your help Ben. I'm afraid that neither seem to fix it. The screen tearing occurs in the viewport when I move around and also when I run the game in a separate window..

avatar image Steve Hardister ♦♦ STAFF Oct 03 '14 at 02:43 PM

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Screen tearing during Preview is caused by your limited video card hardware. You can minimize that by reducing the target hardware, like from Desktop to Tablet, also instead of selecting "Maximum Quality", try "Scalable 3D / 2D".

Then once you upgraded your video card, you can set it back to "Maximum Quality".

These settings can be selected during project creation, or if you already have a project, then go to "Edit" -> "Project Settings" -> "Target Hardware"

more ▼

answered Mar 02 '18 at 11:39 AM

avatar image

elmtreecomputers
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I know this is a really old question but for anyone trying to find an answer, the console command r.VsyncEditor 1 fixed the issue for me. If you set the other v-sync parameter it of course doesn't effect the editor.

more ▼

answered Jan 18 '19 at 08:07 AM

avatar image

ShadowKindGames
93 12 14 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question