x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How can I make my computer use NVIDIA GPU instead of Intel GPU?

Hi again,

I posted before due to the editor crashing whenever I try to start it: https://answers.unrealengine.com/questions/16431/ue4editor-cmdexe-has-crashed.html

Now I have found a solution to the crash, which is using a DLL from this thread: https://answers.unrealengine.com/questions/14856/ue4editor-cmdexe-crashed-after-launch-1.html

However now my problem is that the editor is horribly slow because it is using my Intel GPU instead of NVIDIA GPU. It is impossible for me to force UE4 to use my NVIDIA GPU instead of the Intel GPU.

I have set all the settings in the NVIDIA control panel for global settings as well as specific application settings for ue4editor.exe, ue4editor-cmd.exe, ue4game.exe. You can see so on these screenshots I made:

alt text

alt text

My computer specs are: Intel Core i7-2630QM CPU 8GB RAM NVIDIA GT555M Windows 7 64-bit

Unreal Engine 4 refuses to use my NVIDIA card even though I explicitely set it in the NVIDIA control panel.

I have never had this problem with any other program than Unreal Engine 4.

As proof that it is not using the NVIDIA GPU I have taken a screenshot of the NVIDIA helper application that shows GPU activity: http://images.allprog.nl/viewimage.php?img=8088_1395922601.png It should show the icon of each application that uses the NVIDIA GPU, but it only shows Visual Studio 2012

Product Version: Not Selected
Tags:
screen1.png (101.9 kB)
screen2.png (100.6 kB)
more ▼

asked Mar 27 '14 at 12:11 PM in Installation & Setup

avatar image

FakeTruth
8 2 4 6

avatar image FakeTruth Apr 25 '14 at 12:57 PM

Hi, I have updated to 4.1.0 and I still have the same problem that UE4 is not using my dedicated NVIDIA video card.

Perhaps you can use the code snippet provided in this PDF of NVIDIA http://developer.download.nvidia.com/devzone/devcenter/gamegraphics/files/OptimusRenderingPolicies.pdf

Just put this somewhere in a global scope in a c/cpp file and Optimus should recognize the program as a program that requires a dedicated video card: extern "C" { _declspec(dllexport) DWORD NvOptimusEnablement = 0x00000001; }

I have tried this in my own programs and it works. Of course these programs also run on my NVIDIA card when I tell them to through the control panel... so I don't know if it will work for UE4.

avatar image MrSolid Mar 01 '15 at 12:17 AM

I have the same problem now. I have a laptop with Intel integrated Graphics Card and GeForce 780M. I've been using Unreal 4 since summer and it was running smooth until now. Every project started running in 20 fps at best, new or old version. I checked and GF780M is not being used when Editor runs. I' ve set in nvidia control panel to use proper GPU on every executable from 4.7 and the launcher. I tried reinstalling both intel and nvidia drivers, and Unreal itself. And NOTHING. I recall two things that could cause that: the 4.7 or my recent scan with Combofix. Any ideas?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

7 answers: sort voted first

There's an answer marked as right, but the problem wasn't solved. Does Epic have a saying on this? It's really affecting the performance on a Kinect project at my company. We bought a very expensive Laptop to use at an event and Unreal performance is being crumpled for using the Intel Graphics HD!!

more ▼

answered Aug 20 '15 at 08:32 PM

avatar image

RVillani
1.1k 28 39 90

avatar image Tim Hobson ♦♦ STAFF Aug 24 '15 at 04:36 PM

Hi RVillani,

What type of laptop are you currently using? If you have an Nvidia card in the laptop you should be able to change this in a couple of ways.

1) Optimus technology. You should be able to specify the GPU that you would like to use.

2) Nvidia Geforce Control Panel. You should have an option to choose how you want the GPU to be used. Should be similar to this setup here: https://support.lenovo.com/us/en/documents/ht078706

avatar image RVillani Aug 26 '15 at 09:23 PM

I've set the NVidia Control Panel settings. They're all set for UE4Editor.exe as shown in the answers/comments above. Also, my BIOS doesn't have Optimus options. =(

This laptop setup is the Clevo W230sd, with a i7 (Intel Graphics HD 4600) and GTX 960M video card. And I'm using Windows 10.

I've tested the same project on my PC to make sure it wasn't a Win 10 issue. It runs flawlessly. Also, as a reference point, my older notebook has a i7 (no Intel HD Graphics) and a GTX 560M and it runs ok, at 35fps.

By checking the output log in the engine, it says the chosen card is the GTX 960M. But how come the performance is so poor (50fps), almost the same as the GTX 560M? It runs Mortal Kombat X bot not Unreal?!!

Thanks in advance for your time!

avatar image Tim Hobson ♦♦ STAFF Aug 28 '15 at 04:33 PM

Make sure that your Intel Integrated Graphics drivers are also up to date. I believe they are around version 15 now IIRC.

If you know that the GPU is actually being used this falls more into a performance question rather than a question for switching from integrated to card GPUs. This would be better served as asking as a separate question on the AnswerHub.

To narrow down any performance issues you can start by profiling the GPU and CPU for your games performance.

If you're not familiar withe process of profiling you can start by having a look at this Support Stream and our documentation linked below:

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Which video-card is your monitor plugged into? Are you using a laptop? I've heard about some kind of setup where the nvidia GPU outputs through the intel gpu's screen buffer, it's a way of saving laptop battery power, although I'm not familiar with it.

If you're on a desktop I'd suggest plugging your monitor into your nvidia card's output.

more ▼

answered Mar 30 '14 at 08:57 PM

avatar image

User-658380556
184 22 36 158

avatar image Paul Oliver Mar 30 '14 at 09:34 PM

I run UE4 on my laptop and have seen this problem before, but only if i didn't reboot between settings changes. Have you tried rebooting since you setup these settings?

also which driver version are you on?

avatar image FakeTruth Mar 30 '14 at 10:59 PM

Hi, I just rebooted and it is still not using the NVIDIA GPU. I am using driver version 335.23 - the latest at time of writing. According to the Intel site I am also using the latest (chipset) drivers from them. Intel graphics drivers are 9.17.10.3347. Video BIOS (whatever that is) is 2108.0. Thanks for the suggestions.

avatar image FakeTruth Mar 30 '14 at 10:55 PM

Thanks for your reply. I am using a laptop and indeed have the setup you described, it's called Optimus from NVIDIA. It is not possible to plug in a monitor directly to my NVIDIA GPU as everything has to go through the Intel GPU. I did try using an external monitor, but it did not have any effect. The Optimus technology is actually working fine for all other applications, only UE4 is having problems with it on my laptop...

avatar image Steve Allison STAFF Mar 31 '14 at 08:44 PM

Hey FakeTruth,

Can you let us know the model number of your laptop?

Thanks!

-Steve

avatar image FakeTruth Mar 31 '14 at 08:56 PM

The Laptop is a BTO 15P35. When I bought it they told me they use ASUS motherboards. CPU-Z confirms this by displaying Pegatron Corporation as the manifacturer, I read that Pegatron is a branch of ASUS. alt text

I have attached a CPU-Z report for more hardware info to this comment.link text

kevin-pc.txt (96.4 kB)
cpuz.png (30.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've actually seen this problem before but for the Source engine. The solution for that was to disable secure boot in the bios.

more ▼

answered Mar 31 '14 at 02:34 AM

avatar image

PalmliX
26 2 2

avatar image FakeTruth Mar 31 '14 at 08:48 PM

Thanks for the suggestion. I had a look in the BIOS but there is no such option. I looked around the internet a bit about "secure boot" and it seems to only apply to Windows 8 laptops. My laptop came with Windows 7 so I do not have such an option.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

hi i'm using a lenovo and i had the same problem but on the lenovo support webside there is a special installer for optimus (seperate from the nvidia driver)

link text

i have now a litte symbol in the notification area which tells me which software uses my gpu....

more ▼

answered Apr 01 '14 at 08:47 AM

avatar image

Dave4723
329 10 16 33

avatar image FakeTruth Apr 01 '14 at 10:09 AM

Hi Dave, Do you mean the symbol as in this screenshot? http://images.allprog.nl/viewimage.php?img=8088_1395922601.png

My BIOS is very barebones and there are hardly any settings available, there are no graphics settings and unfortunately nothing about Optimus :(

I will try reinstalling some drivers.

avatar image Dave4723 Apr 01 '14 at 12:24 PM

yes thats the symbol... i also saw that my ue editor was in the nvidia control panel 2 times... 1 from installing via installer and 1 from compiling from source... i also switched the option for vs2013 to gpu because if you run it from source it "spawns" the editor process....

do have this option in your bios?

alt text

avatar image FakeTruth Apr 01 '14 at 03:56 PM

No I don't have that option, my BIOS is really basic...

http://images.allprog.nl/viewimage.php?img=7471_1396367700.jpg

http://images.allprog.nl/viewimage.php?img=2393_1396367716.jpg

http://images.allprog.nl/viewimage.php?img=8743_1396367725.jpg

http://images.allprog.nl/viewimage.php?img=3466_1396367738.jpg

I am running UE4 from the installer, I do not have the source or VS2013. In the previous screenshot I just had VS2012 open for another project unrelated to UE4 :P

avatar image Dave4723 Apr 01 '14 at 04:37 PM

wow that is basic.... what happens when you use the editor.exe directly without the launcher?

and i found something... your bios is 206 this is 209

http://www.btodownloads.nl/index.php?dir=Notebooks%20%28Drivers%29/1.%20VORIGE%20MODELLEN%20-%20PREVIOUS%20MODELS/15P35%20-%20%28A25PA%29/BIOS/

maybe they implemented the display select option...

avatar image FakeTruth Apr 01 '14 at 06:24 PM

It makes no difference whether I start Unreal Engine\4.0\Engine\Binaries\Win64\UE4Editor.exe directly or through the launcher.

I also found that update, but I am hesitant to update because it is not without dangers and it might not fix my problems at all. I guess I'll try to update it although I had rather have UE4 be fixed because I suspect it's probably selecting the wrong graphics device to be used for DirectX somewhere.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

After running WildStar (a game) for the first time I noticed that it does not use my NVIDIA card either.

What WildStar and UE4 have in common is that they are both 64-bit programs. So I figured my NVIDIA Optimus implementation might not work properly for 64-bit programs.

To confirm this I have compiled my own 32 and 64 bit programs that use OpenGL and saw that the 32-bit program uses my NVIDIA card and the 64-bit program does not.

According to this, the problem might not be with UE4 but with my laptop...

more ▼

answered May 18 '14 at 11:24 AM

avatar image

FakeTruth
8 2 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yeah I made it run. I have a laptop using Nvidia Optimus. No matter what a set for r.GraphicsAdapter Unreal always choosed Intel HD 4600. I noticed in logs that it might be because there is in fact no output on GeForce graphic. All output goes through Intel so all devices are connected to it.

So I made a fake display connected to GeForce acording to this: http://www.helping-squad.com/fake-connect-a-monitor/

Now when there is an output on both adapters UE choosing GeForce finally!

Cheers

more ▼

answered Dec 01 '15 at 11:55 PM

avatar image

emtezet
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Im 4 years late but disable intel driver in device manager and this will force the PC to use the Nvidia Display Driver. Problem Solved.

more ▼

answered Dec 31 '18 at 07:16 PM

avatar image

Concavve
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question