x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Vehicle constantly shaking/juddering?

I have set up a vehicle by copying the wheeled vehicle template. Everything is working, but my vehicle has a constant shake, as though there is some physics problem occurring. I have set all suspension settings to zero, as my vehicle does not have suspension by design. I have also ensured that collisions are disabled between all objects in the physics asset. I have tried modifying the mass of all objects, with no change.

The only thing that has made a difference is scaling the root collision box to be very large (so large that it makes no sense in game, so it can't be used), and turning on suspension and giving it a min and max raise/fall height (but I need a vehicle without suspension).

Applying a small amount of suspension seemed to work initially, until I tried the game in Oculus Rift(for which I am developing this game), where the shaking became even worse (not sure how this can be, CPU performance affecting physics simulation quality?)

I have also tried changing the physics substep, with no difference. I have tried setting wheel long stiffness values to different values, and none seem to make a difference. I have spent many hours trying to solve this.

Friction values of the wheels are 3.0. If I increase this higher, the shaking increases. Long stiff for rear wheels is 200 currently, 10 for front (just for handling testing), but changing these values does not appear to change the shaking.

This is the physics asset: I have tried using many different primitives for collision meshes, and they all have the same result (unless the main body is sphere, in which case there is no judder, but the car rolls). alt text

Can anyone please help?

Product Version: Not Selected
Tags:
more ▼

asked Mar 19 '15 at 10:15 PM in Everything Else

avatar image

jos3ph
11 1 3 5

avatar image Jacky Mar 19 '15 at 10:19 PM

Is Substepping enabled in Project Settings > Physics > Framerate?

avatar image jos3ph Mar 19 '15 at 10:23 PM

Yes, with substep max delta time 0.016667, and max substeps 6. Changing these values also has no effect on the shaking.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

try playing around with the max depenetration velocity. It isn't a complete fix but it stabilized the collision overlap a little bit on my end.

more ▼

answered Sep 24 '15 at 11:47 PM

avatar image

RBrown
6 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question