x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot create c++ project under 4.7.3

Everytime I try to create a c++ project under the newly updated version 4.7.3 I run into the following error:

Failed to generate project files. Log output: Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="D:/Development/Unreal/MMOProject/MMOProject.uproject" -game -rocket -progress Discovering modules, targets and source code for game... Errors detected while compiling D:\Development\Unreal\MMOProject\Intermediate\Build\BuildRules\ProjectFileGeneratorModuleRules.dll: c:\Program Files\Epic Games\4.7\Engine\Source\Runtime\CEF3Utils\CEF3Utils.Build.cs(5,14) : error CS0101: The namespace '' already contains a definition for 'CEF3Utils' c:\Program Files\Epic Games\4.7\Engine\Source\Runtime\WebBrowser\WebBrowser.Build.cs(5,14) : error CS0101: The namespace '' already contains a definition for 'WebBrowser' UnrealBuildTool Exception: ERROR: UnrealBuildTool encountered an error while compiling source files

Creating a blueprint project went well but trying to add a custom c++ class using the editor always says that the class already exists.

Anyone having the same issue?

Product Version: Not Selected
Tags:
more ▼

asked Mar 19 '15 at 11:06 PM in C++ Programming

avatar image

Serphimera
6 1 3

avatar image Serphimera Mar 20 '15 at 02:18 PM

Thanks for your reply. Will try later and report if it fixed the issue.

avatar image Serphimera Mar 23 '15 at 10:59 AM

Rebuild from source fixed the issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I had exactly the same issue! Nb. That it does actually create the files, it just fails in the editor. I found that building the editor from source (ie. https://github.com/EpicGames/UnrealEngine) fixed it for me; the default one that you can just download seems to have this issue (4.7.3).

more ▼

answered Mar 20 '15 at 12:57 AM

avatar image

shadowmint
537 17 18 80

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question