x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Paper 2D Blueprint Thumbnail

I've been following this tutorial, but the thumbnails for my blueprints that use paper sprite components don't show up. I'm having this issue with PaperSpriteActor blueprints and PaperFlipbookActor blueprints.

I have real-time thumbnails enabled and I'm using version 4.7.3 of the engine.

Pictures: My setup Blueprint

Product Version: Not Selected
Tags:
more ▼

asked Mar 20 '15 at 05:30 AM in Bug Reports

avatar image

TimH
10 2 6 8

avatar image AndrewHurley Mar 20 '15 at 05:16 PM

Hey TimH,

Are you using a Mac or a PC?

If you are working on a PC, could you provide me with your 'dxdiag'?

If on a Mac, could you give me you system information?

Also, try removing the Box component and the 'Event Graph' information within this blueprint to see if your thumbnail gets correctly set.

Thank you,

Andrew Hurley

avatar image TimH Mar 20 '15 at 05:22 PM

I'm on PC. My dxdiag is attached. Removing the box component and event graph information didn't fix the issue.

dxdiag.txt (77.9 kB)
avatar image AndrewHurley Mar 20 '15 at 06:44 PM

Thank you for the requested information.

No problem. Next try going into the 'Window' menu and choose the 'Reset Layout' option.

If this does not work, try also opening a different 'Content Browser' window.

I have the exact same project on my computer here, and am not seeing the same outcome. Possibly due to the fact you are using Windows 8 instead of Windows 7, but that is a shot in the dark as far as suggestions for the source of the issue.

Cheers,

Andrew Hurley

avatar image TimH Mar 20 '15 at 06:59 PM

Resetting the layout and opening different content browser windows didn't fix the problem. Is there any additional information that I can provide you with to make diagnosing this problem easier, or is this a Windows 8 issue?

avatar image AndrewHurley Mar 20 '15 at 09:07 PM

You might want to try verifying your engine version through the launcher. You could also attempt to re-install 4.7.3 completely.

Let me know if these are valid solutions to your issue, or if you need some different suggestions.

Cheers,

Andrew Hurley

avatar image TimH Mar 20 '15 at 09:36 PM

Verifying didn't fix the issue. I'll try re-installing in a bit.

Update: re-installing didn't fix the issue either.

avatar image Roccinio Mar 20 '15 at 10:21 PM

I have reported this directly to Michael Noland through the paper2d forum more than a month ago. Could you please file it in case he forgot about it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey TimH,

Open the Blueprint in which the thumbnail is not being displayed correctly. Go into the Viewport and re-position the camera to a good angle (the default angle is for +X and so the sprites will be viewed along the thin side and invisible). After re-positioning the camera your thumbnails should update to match IIRC.

Let me know if this worked for you, or if you are still having trouble.

Regards,

Andrew Hurley

more ▼

answered Mar 23 '15 at 08:38 PM

avatar image Paradachshund Nov 19 '18 at 04:55 AM

I'm having a similar issue to the original issue in this thread. In my case, however, no thumbnail is being captured at all. It just retains the default white sphere icon. For trouble shooting I am using a blueprint I created from a PaperSprite which currently has no other components at all. I tried the viewport repositioning trick but nothing happens when I do it. In fact, every time I open the blueprint the viewport resets to the default position (default in this case is looking towards the visible side of the sprite, but at a slight angle. Any ideas? I'm running 4.20 on Windows 10.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question