x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Problems with subtracting

Hi, i'm new with Unreal Engine. Something weird it's happening when I try to substract in the editor. I'm using BSP and i'm trying to substract an sphere over a cone:

alt text

So, when I try to do it, and I put the sphere closer to the cone:

alt text

Something appears into the sphere. And when I finally substract it

alt text

I don't understand why. It substracts, but at the same time it adds thing that i never created inside the map.

Am I doing something wrong?

Product Version: Not Selected
Tags:
1bsp.jpg (265.7 kB)
2bsp.jpg (270.4 kB)
3bsp.jpg (287.6 kB)
more ▼

asked Mar 20 '15 at 02:34 PM in Bug Reports

avatar image

Guiditocr
1 1 2 4

avatar image Adam Davis STAFF Mar 20 '15 at 04:10 PM

what are the settings you have used in the details pane of both your additive cone and your subtractive sphere brushes?

avatar image Guiditocr Mar 20 '15 at 04:46 PM

Sphere

alt text

Cone

alt text

I reset them to default.

sphere.jpg (374.7 kB)
cone.jpg (375.7 kB)
avatar image Adam Davis STAFF Mar 20 '15 at 05:45 PM

Is this in the main UE4 Editor or is it in the UT Editor? There is a known issue in the UT editor that causes a similar effect to occur, however I cannot get this to reproduce in the 4.7.3 version of the main editor. Which version are you on?

avatar image Guiditocr Mar 20 '15 at 11:19 PM

UE4 Editor, 4.7.3 version. I only get this error when i try to subtract in the cone. I have a cube down and it doesn't give me any problems.

avatar image Adam Davis STAFF Mar 23 '15 at 07:45 PM

Unfortunately I haven't been able to reproduce this on my end. Here are the steps I am taking, are you doing anything differently than I am?

  1. Open Editor (any project)

  2. Create new additive brush (cone)

  3. Create new subtractive brush (sphere)

  4. Move sphere to collide with cone

I have tried various rotations, scales, and hard values set in the details pane, specifically the radius on the sphere and the number of sides on the cone.

avatar image Guiditocr Mar 24 '15 at 04:18 PM

Thank you for your help, Adam. I did what you say and i'm not having any problems when I try to reproduce this in another project. Maybe I did something wrong before, but I can't figure what.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

BSP's can be extremely finicky, but I'm happy to hear you are not experiencing this error again. If you do, please comment and let me know what steps you took that did create this and I'll be happy to try again. For now I will mark this as answered for tracking purposes.

more ▼

answered Mar 24 '15 at 05:32 PM

avatar image Guiditocr Mar 25 '15 at 04:37 PM

I add this; I solved it exporting everything to a new project. :D Thanks for your help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question