x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Sourcecontrol issues

Hi, im having issues when trying to add sourcecontrol (subversion) to my project. No matter what I change in the repository field it keeps trying to connect to the FIRST repository that I entered. I have tried new repository addresses but it doesn't fix anything. Even when restarting the launcher it keeps the same repository address. It seems to save the data that I entered is stuck to the project that I am working on, tried another project and the fields were empty.

I'm assuming this is a bug, if not, how do I fix it? Some sort of cache file that needs to be deleted? alt text

Product Version: Not Selected
Tags:
more ▼

asked Mar 20 '15 at 11:09 PM in Bug Reports

avatar image

GrafithZ
25 1 1 6

avatar image Richard Talbot-Watkins STAFF Mar 25 '15 at 11:12 AM

You could try deleting your source control settings at \Saved\Config\Windows\SourceControlSettings.ini. Let me know if that does the trick!

avatar image GrafithZ Mar 25 '15 at 02:50 PM

It seems to keep trying to connect to the same repository as before even when I delete the ini file and restart the project, as you can see in the error log: alt text

avatar image Richard Talbot-Watkins STAFF Mar 25 '15 at 07:36 PM

Could you also take a look in Engine\Saved\Config\CleanSourceConfigs\SourceControlSettings.ini and Engine\Saved\Config\Windows\SourceControlSettings.ini, and if you see your default details there, try deleting those files. I've attempted to reproduce this, but can't, so I wonder if there's something strange in your config there.

avatar image GrafithZ Mar 25 '15 at 08:18 PM

Still not working, I just deleted all the SourceControlSettings on my computer (didnt find any in the engine folders), even when not typing anything into the fields it tries to connect to the same old repository... Definitely seems very strange, and since Git just crashes when I try using that im not too sure what to do about this. All deleting those ini's do for me is remove everything I entered in the fields, so like a cache for saving whatever I entered there, not a cache to what im actually connecting to?

avatar image Richard Talbot-Watkins STAFF Mar 25 '15 at 10:26 PM

Thanks for the clarification.

Could you enable the Output Log and paste in a dump of what it outputs when attempting to connect please? There should be a little more information, in particular the actual commands being passed to SVN, so we can hopefully trace whether this is a problem with UE4 or with your SVN configuration.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks for the help Richard! Seems like the log revealed that it looks for the repository info in the working copy (SVN) instead of using the information that I provided in the dialog to connect to the repository, which seems a bit weird in my opinion. So I had to make a new SVN folder and copy the project over, then checkout the repository with the new repository URL, after I did that and opened the new working copy, it connected to the new repository URL. Here's the log that asked for SVN info: http://pastebin.com/nqwUE52u

more ▼

answered Mar 25 '15 at 11:43 PM

avatar image

GrafithZ
25 1 1 6

avatar image Richard Talbot-Watkins STAFF Mar 26 '15 at 08:38 AM

Certainly seems as if something is amiss there. Just to confirm, you had a different repository URL to https://felix_pc:8443/svn in the dialog box? I will enter an issue for this and we'll look into it. Glad you managed to find a solution for now!

avatar image Richard Talbot-Watkins STAFF Mar 26 '15 at 08:41 AM

Also, could you let us know which version you are currently on please?

avatar image GrafithZ Mar 26 '15 at 09:31 AM

Yes, I was entering in different repository URLs in the dialog but it kept connecting to it because tortoiseSVN had connected that working copy to https://felix_pc:8443/svn , I had to make a new working copy connected to my new repository URL. I am using 4.7.3.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question