x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AutomationTool was unable to run successfully After upgrade 4.7.3

Hi, Well, i know this is a popular issue, but the difference here is that everything was perfectly working in 4.7.2 version, but from the moment when i upgrade to 4.7.3 it stopped working, now i can´t even pack an empty template map to android, please i need help, i don´t know what to do, sorry for my english.

Thank you

Product Version: Not Selected
Tags:
more ▼

asked Mar 21 '15 at 09:49 PM in Packaging & Deployment

avatar image

Ruken
11 2 5

avatar image mxnko Mar 22 '15 at 07:39 PM

I am having the same problem packaging to windows. Everything was working in 4.7.2 now it fails to run, and I have no idea what to make of the cook logs.

avatar image Ruken Mar 22 '15 at 07:45 PM

Its really frustrating, i don't even know if a 4.7.4 would fix it, i already reinstalled UE4 And update Android SDK and still nothing, please someone tell what happened with this new version and how to fix it, pleaseeee, thank you

avatar image mxnko Mar 22 '15 at 08:29 PM

Yep, my testing process is stalled atm. No idea how to fix it short of debugging the editor.

avatar image wittlief ♦♦ STAFF Mar 24 '15 at 08:17 PM

Hi Ruken and mxnko,

We're gonna need a lot more info from both of you to try and figure this out. Please see this thread for what info is needed and how to find logs. Additionally, logcat logs would be very useful. Please attach them to this thread, posting in a comment makes the logs difficult to parse.

Both of you are unable to package anything? Can you try the Tappy Chicken project packaged for development with ETC1 and see if that fails, and if it does fail please include the output logs for that failure?

Thanks very much!

avatar image mxnko Mar 24 '15 at 08:20 PM

wittlief, Thank you, my problem is a bit different, i've resolved it. Below is link with logs and issue cause.

https://answers.unrealengine.com/questions/197892/packaging-game-fails-after-473-upgrade.html

I was able to package minimal template project.

avatar image wittlief ♦♦ STAFF Mar 24 '15 at 08:49 PM

Excellent, thanks for the heads up!

avatar image Ruken Mar 24 '15 at 09:54 PM

Hello, since when i try to pack TappyChicken for android ETC1 i got exactly same issue than with any project, i just gonna attach log file of tappy chicken. I never attached log files before so please excuse me if i did it wrong and tell me what is the name of the log file you need, Thank you :) I alredy try mxnko solution and still nothing. link text

alt text

uat_log.zip (40.8 kB)
sin título.jpg (224 B)
avatar image wittlief ♦♦ STAFF Mar 25 '15 at 06:43 PM

Hi Ruken,

I've found what is very likely causing your problems, it is this error: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat"

Here is one thread where someone has a similar problem, can you try his fix and see if that helps?

avatar image Ruken Mar 26 '15 at 03:52 PM

hello, first of all thank your for helping, it actually worked, now i can package tappy chicken and example maps with no problem at all, but for some reason i still getting the same faliure message with my main project, it looks like it didn´t recognize the solution you gave me, i attached the log file again and a screenshot of the sdk manager. Thank you :)

[1]: /storage/temp/36059-log.zip

log.zip (778.0 kB)
avatar image wittlief ♦♦ STAFF Mar 26 '15 at 06:47 PM

Hi Ruken,

I am glad that Tappy worked; that's a step in the right direction. Can you try deleting the intermediate folder for your project and trying again to package?

avatar image Ruken Mar 26 '15 at 09:16 PM

Hi, i already deleted intermediate folder and still same problem :(, i attached log file again.link text

log.zip (106.2 kB)
avatar image wittlief ♦♦ STAFF Mar 31 '15 at 09:25 PM

Hi Ruken,

I am very sorry it has taken this long for me to get back to you. Are you still seeing this issue? The 4.7.4 release should be out tomorrow and I hope sincerely that it solves some of the weird build/file deletion issues we've been seeing. If after the update you're still having the problem, can you send me a fresh log?

avatar image Ruken Mar 31 '15 at 09:30 PM

Off course, in that case i´ll wait until tomorrow and i´ll let you knows what happens, i hope the new release fix the issue.

avatar image wittlief ♦♦ STAFF Apr 02 '15 at 06:16 PM

Hi Ruken! This is just to let you know that the 4.7.4 update has been released (I jumped the gun telling you it would be yesterday, and I apologize.) Please have a look and see if your project is still failing. If so, I will escalate this to the Android dev to have a look and see if he has any advice.

Thanks very much!

avatar image Ruken Apr 03 '15 at 05:04 PM

Hello, i just try to pack my project but i still getting same error even after installing 4.7.4 version, here is the fresh LOG filelink text

uat_log.zip (107.1 kB)
avatar image wittlief ♦♦ STAFF Apr 06 '15 at 03:23 PM

ok, it's definitely this:

UEDeployAndroid.RunCommandLineProgramAndThrowOnError: Running: cmd.exe /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat" -quiet debug BuildCommand.Execute: BUILD FAILED

Apache Ant is the Java-based software tool for automating software build processes. It is included in TADP.

There's a couple of things you can try. Firstly (after backing up your project), try deleting: the DerivedDataCache folder in the Engine folder and then the Binaries, DerivedDataCache, Intermediate, and Saved folders in your project's folder before starting the editor, then restart your machine entirely. It will take a while to start the first time since it will need to recompile all the shaders.

If this does not work, you may need to uninstall and reinstall TADP. Feel free to use the most recent version of TADP (Release (4.0r1)) if you like. Just be sure during the setup process to make sure that you have SDK 19 and NDK checked when installing.

Good luck!

avatar image wittlief ♦♦ STAFF Apr 10 '15 at 07:11 PM

Hi Ruken,

Are you still seeing this issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Ruken,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Apr 13 '15 at 04:40 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question