Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Nav Link Proxy not setting custom NavArea Flag

Hey everyone,

I went through the tutorial on making an AI Jump and couldn't get the nav link proxy to set the flag correctly for some odd reason. I don't get any compile errors but when I debug out a message the


is never true when my AI walks into the Nav Link Proxy with the Nav Area on the Point Link set to NavArea_Jump.

I triple checked everything from the tutorial and cant see anything different then what I am doing.

I saw a warning saying that said


So then set the Navigation Mesh Build on Runtime option to true , got rid of that warning but then I see this warning when playing the game a bunch.

 "FRecastTileGenerator: Trying to use undefined area class while defining Off-Mesh links! (NavArea_Jump)"

Not quite sure what that means. Any help would be greatly appreciated , would love to get this working :)


Tutorial I used was from here. http://unreal-ai-tutorial.info/index.php/8-tutorial-cpp/3-making-ai-jump-as-part-of-path-following

using 4.7.2

Product Version: Not Selected
more ▼

asked Mar 22 '15 at 03:08 AM in Bug Reports

avatar image

103 9 10 16

avatar image yesNinja Mar 25 '15 at 02:44 AM

I got the NavArea_Jump to work but only in a Nav Modifier Volume , but the Nav Link Proxy still doesn't work. Leading me to think I either set the Nav Link Proxy up wrong but it seems correct. How does the Nav Link Proxy work in terms of overlapping the actor?

avatar image RayJohannessen Oct 02 '15 at 11:58 PM

That tutorial is gone now...what the heck? I followed the advice in this thread from MieszkoZ https://forums.unrealengine.com/showthread.php?3512-NavLink-and-making-AI-jump, and I'm getting the same thing you did.

So I guess I have to switch to Nav Modifier Volume??

Does anyone know if this is supposed to be working properly?

avatar image Swiftle Oct 30 '15 at 11:27 AM

Any updates on this? It works 50% of the time. Usually if I close the editor, rebuild my C++ code then go back to the Editor it works fine, but it's not a really great solution. Paging Mr. MieszkoZ :)

avatar image olee92 Nov 26 '15 at 05:40 PM

Same problem here! Debugging the code the AI controller logs always 0 for the area flags once it reaches the nav links! Even if I use one of the already existing links like obstacle or low-height!

avatar image OliverTheLove Nov 04 '16 at 04:08 PM

Did anyone solve this problem?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The problem happens with 4.10. I investigated it further and noticed that the bug actually only happens with hot reloading. Normally the custom NavArea class (old version) should be unregistered when hot reloading and re-registered after that. However somehow it first registers the new one and then unregisters the old one. This would make it necessary to restart the editor after compiling each time.

I managed to circumvent the problem for now by overriding FinishDestroy() in my custom NavArea class with the following - slightly changed - code.

 void UNavArea_Jump::FinishDestroy()
     if (HasAnyFlags(RF_ClassDefaultObject)
         && !GIsHotReload
 #endif // WITH_HOT_RELOAD
         UE_LOG(LogTemp, Error, TEXT("Did not unregister %s, because of bug in UE4"), *GetClass()->GetName());
         // UNavigationSystem::RequestAreaUnregistering(GetClass());

I reported this as a bug here

more ▼

answered Nov 27 '15 at 11:15 AM

avatar image

21 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried switching to 4.10? They fixed a bug where the nav mesh was being rebuilt all the time. As soon as I switched to 4.10 the bug disappeared.

more ▼

answered Nov 27 '15 at 03:54 AM

avatar image

114 20 26 32

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question