x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.3] Can't do animation in the Matinee Editor; Don't know what to do about it

I make a simple test matinee animation consisting of moving a block from side to side in one direction, for me to get familiar with the Matinee Editor. As I went on, I noticed that the static mesh wasn't doing anything, such as moving across the floor.

I realized the Matinee Editor, even though it correctly put keys in, wasn't able to move the static mesh around.

alt text

The static mesh is already set to Movable. And it has been added to the "Block" matinee group via "Add Selected Actor to Group" in the Matinee Editor.

alt text

I even set the level blueprint up so that it plays the animation upon Event Begin Play, yet the actor isn't moving.

alt text

I really don't want to say this is a bug, but being unfamiliar with the actual results and not expecting them to be like this, I really don't have any other understanding other than to say that this is a bug in the Unreal Engine 4.7.3. What should I do?

Thanks in advance.

Branch

inary, from Launcher ### Version 4.7.3

Product Version: Not Selected
Tags:
more ▼

asked Mar 22 '15 at 08:24 AM in Bug Reports

avatar image

asperatology
293 31 30 91

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I ran into this problem as well. My object is a blueprint, not C++ object, but it has a StaticMeshComponent child. I got the object moving via matinee by unchecking "simulate physics" in the StaticMeshComponent.

more ▼

answered Oct 24 '15 at 02:27 AM

avatar image

sharing
21 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi asperatology,

I tried what you are trying and it always seems to give me the proper result on my side. Here are the steps I use so maybe you can reproduce them or validate if you're not missing one

Create a new blank Blueprint project using 4.7.3 Take a Cube in Basic / cube and place it in the viewport Click Matinee / Add new Matinee in the main toolbar Select the cube in the viewport In Matinee, right click, add empty group In Matinee, right click on your new group and Add a movement track In Matinee, move the timeline and add a new key In the viewport, move your cube (you should see the yellow line appear)

And that's it, at that point If i save and start in in my level BP everything's fine or If I click the loop in the matinee editor, both ways show me my cube moving

Hope this helps

Let me know what are your results

Cheers,

  • Marc

more ▼

answered Mar 22 '15 at 06:37 PM

avatar image

MarcAndreG
710 27 12 40

avatar image asperatology Mar 22 '15 at 08:41 PM

I decided to redo this by using a static mesh created from scratch, and the result is affirmative. I was able to move around and animate the movement track.

However, I now realized it does not work with C++ objects with an Actor as root component and UStaticMeshComponent as child attached to root component. The matinee editor cannot animate C++ classes such as that.

Is that a bug?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question