x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is there no collision on my Flipbook?

  • 4.7

  • Windows: 8.1

I am making a Paper2D project at the moment and I might have found a bug with Event Hit when using a Flipbook.

Not Working

Now this doesn't work. It's a Flipbook Component.

Working

But this works, and that's a Sprite.

So I have a suspicion that it doesn't work for Flipbooks. Below is a video of the lowest picture setup working as intended:

https://www.youtube.com/watch?v=8IAWBtbsE6k

[EDIT]

After further inspection Hit and Overlap doesn't work for the Flipbook.

Product Version: Not Selected
Tags:
more ▼

asked Mar 22 '15 at 11:59 PM in Bug Reports

avatar image

OmniOwl
219 19 27 35

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Vipar,

I wasn't able to reproduce this in 4.7.3. Do you have collision set in your flipbook asset?

alt text

If so, can you show me the collision settings for your Blueprint which contains the flipbook component? Thanks!

more ▼

answered Mar 23 '15 at 08:42 PM

avatar image OmniOwl Mar 23 '15 at 09:21 PM

I guess that was the problem. Strange. It's set to collision per default on Sprites. Might have to change the default values on Flipbooks to be First Frame Collision as well?

avatar image Ben Halliday STAFF Mar 23 '15 at 09:40 PM

The default is set to No Collision because it's less expensive to use a standard collision box component in a Blueprint instead of using Flipbook collision, and it's generally better practice for performance not to use it if it's not necessary.

For reference, first Frame Collision will use the collision from the first frame of the flipbook, and Each Frame Collision will update the collision to match each Sprite used in the Flipbook. The latter is obviously expensive as it recreates the physics state every frame.

avatar image OmniOwl Mar 23 '15 at 10:52 PM

I see. Why is not using the Collision Box I gave it in the Sprite Making process?

avatar image Ben Halliday STAFF Mar 24 '15 at 12:36 PM

If you enable Collision Source in your Flipbook, it does use the collision from your Sprite. Depending on the setting, it will use the collision from the first Sprite in your Flipbook, or it will update to match the collision from each Sprite in the Flipbook.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question