x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Application Loader Error-90207

I am getting a weird error when I am trying to upload my iOs Shipping deployment to itunes connect using application loader 3.0.

ERROR ITMS-90207: "Invalid Bundle. The bundle at 'ProjectName.app/ProjectName.app' does not contain a bundle executable.

Other build's deployment to the phone from xcode and inside the engine work fine, so I have no idea what this is about. I used the archive utility to look inside the .ipa and it does seem like there is just a ProjectName.app file inside (no other folders or files). Any advice?

Product Version: Not Selected
Tags:
more ▼

asked Mar 23 '15 at 01:17 PM in Packaging & Deployment

avatar image

BaderThanBad
664 21 18 177

avatar image Ravlek STAFF Mar 23 '15 at 02:02 PM

Did you create the ipa utilizing File|Package in the editor? If so, could you provide the log? If not, could you try that :) If I can view the log from the build process, I might be able to figure out what went wrong.

-Pete

avatar image BaderThanBad Mar 23 '15 at 02:13 PM

Yeah I did, ill make another build and post the log. Would there be a more private way to send the logs to you?

avatar image Ravlek STAFF Mar 23 '15 at 02:15 PM

You can send via private messaging on the unreal engine forums if you like (psauer is username there as well).

-Pete

avatar image BaderThanBad Mar 23 '15 at 02:59 PM

Ok this is odd, I packaged and the only difference was that my phone was plugged in, now the application loader gives me a different error.

ERROR ITMS-90034: "Missing on invalid signature. the bundle '***' at bundle path 'Payload/ProjectName.app' is not signed using an apple submission certificate."

Im sending the log of the build momentarily.

avatar image BaderThanBad Mar 23 '15 at 03:12 PM

Please find attached the logs: (deleted), Couldn't find an attach button on the forums and the file was too big for some reason :).

avatar image BaderThanBad Mar 23 '15 at 03:52 PM

I did another build and tried again, i get the same original error that i posted.

avatar image Ravlek STAFF Mar 23 '15 at 05:30 PM

Ok, everything looks ok, so I am not sure why it is failing yet. Can you look in the project/Binaries/IOS/Payload/Game.app to see if that has been signed? It looks like it should have been, but maybe something is signing in the wrong directory.

-Pete

avatar image BaderThanBad Mar 24 '15 at 07:58 AM

The file you mentioned does not appear to be signed. It says no signature, info.plist=not bound and TeamIdentifier=not set. *.app: CSSMERR_TP_NOT_TRUSTED

avatar image BaderThanBad Mar 24 '15 at 08:57 AM

I managed to get it signed correctly when i looked up the error (it shows info with codesign -dv and codesign -v), and now it looks like that file is signed correctly, but it is still giving me the same original error "does not contain a bundle executable." when I try to upload it using application loader. I am not sure but the error message does not seem like a signing issue to me.

avatar image BaderThanBad Mar 24 '15 at 01:07 PM

Erm... I've been building and rebuilding and clearing previous files and certificates and other stuff and application loader uploaded the build, no idea why lol. It's working now I guess so thanks for the help :).

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

What?!? :) I was just about to respond that we seem to have an issue when you have all three architectures in the binary (armv7, armv7s, arm64) and that you really don't need armv7s in there as it doesn't provide that much of a speed up on devices that support it. Did you maybe uncheck that in the project settings?

-Pete

more ▼

answered Mar 24 '15 at 01:17 PM

avatar image

Ravlek STAFF
1.9k 4 6 34

avatar image BaderThanBad Mar 24 '15 at 01:22 PM

I don't think I had it checked in the first place (not sure though, i messed with a lot of settings to get it to work, might be a change in xcode). I can see the difference in both packages after I unzipped them that the one with the error did not have an executable but a nested .app file instead while the one that worked has an executable instead of the .app.

avatar image Ravlek STAFF Mar 24 '15 at 01:24 PM

Ok, that is really strange. Can you make a new sample project and see if you can reproduce the error from scratch? It sounds like you have hit something that is possibly an edge case, so I want to see if we can get it from a fresh project which you could then send us.

-Pete

avatar image BaderThanBad Mar 24 '15 at 01:39 PM

Yeah sure, I will try it out and post the results.

avatar image BaderThanBad Mar 24 '15 at 01:53 PM

I did not manage to recreate this issue with a fresh project. I assume it was some bad files or configs from earlier versions or deploys (this project was started pre 4.2 and we have converted every version of the way).

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question