x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird rendering problem.

It happens only from a certain distance, and as long as i getting more far away it escalates exponentially. alt text

This is just a bunch of blueprints that has a cube mesh in it. This is how the mesh looks like:

alt text

This game is an editor that allows you to build levels like minecraft, so this is why it has to be composed of multiple cubes. I know the horizontal lines can be fixed with playing with the shadows settings, but what about all that weird artifacts?

Product Version: Not Selected
Tags:
more ▼

asked Mar 24 '15 at 11:49 AM in Rendering

avatar image

Sahkan
224 10 19 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok i'v deleted the config folder so unreal will remake it in the default form, and it fixed the problem, and now i feel stupid :X I guess this thread will be useful for anyone who has that problem at least. Thanks for the help Tim Hobson and i'm sorry for wasting your time lol :P

more ▼

answered Apr 08 '15 at 06:12 AM

avatar image

Sahkan
224 10 19 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Sahkan,

I've tried recreating the issues you're reporting but have not had any luck. While I'm using the editor cube from the modes > Basic > Cube panel with an applied material. I've also not set this mesh in a blueprint either.

By looking at the horizontal lines that are present it would appear to be an artifact of adjusting the shadow bias or cascaded shadow maps in your directional light source. I see you mention that you can get rid of that issue, but not the triangles that are appearing.

Would you be willing to share how you've setup the BP so I can recreate on my end? Also, can you try switching the mesh out for one of the cubes in the starter content or the engine folder to see if this resolves the issue? We can rule out some things that way. Also doing a test to see if a meshes placed in the editor that are not in a blueprint could resolve the issue, again, depending on how things are setup.

Let me know.

more ▼

answered Mar 25 '15 at 03:17 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 879

avatar image Sahkan Mar 28 '15 at 09:11 AM

My computer have problems so it took a while for me to answer, this is a picture of an other computer with clean install of unreal engine 4.7.3, using the base cube that comes with the engine with no blueprint :

alt text

As you can see, the problem is a lot less noticeable, but still there. You need to fly far enough from the cubes and then you will try to see these little artifacts.

I just want it to look like a seamless floor.

capture.png (299.5 kB)
avatar image Sahkan Mar 28 '15 at 09:32 AM

More info: I've loaded the project into the computer i'm working on right now. As far as you get from the cubes the issue is escalating. alt text alt text alt text

This is how the blueprint's components view looks like: alt text Also tried it with some basic cube mesh that came with one of the project's examples and still the same results: alt text

1.png (1.3 MB)
21.png (780.1 kB)
3.png (447.3 kB)
blueprint.png (593.0 kB)
bp2.png (586.1 kB)
avatar image Sahkan Mar 28 '15 at 09:38 AM

All the tests above was tried in Epic quality and lowest quality with no shadows or any other effect.

avatar image Sahkan Apr 01 '15 at 04:34 PM

More updates ! I've replaced all the blueprints with the most basic static mesh cube that comes with the engine. as you can see from one of my previews comments on this thread, you can barely see the artifacts, however, they are still there. Also notice i'v used the default scale of the cube. Now i'v noticed that the bigger the mesh the bigger the artifacts.

Pictures:

built in engine cube scale 1: alt text

built in engine cube scale 5: alt text

built in engine cube scale 20: alt text

This is probably because i can see the cubes even when i'm farther away from them.

You can even see the previews smaller cube groups in the background on the third image ( scale 20 ) and how full of artifacts they are.

It seems like as long as you getting more far away from objects the accuracy of the shape of them is lowering.

This happens in 2 different computers and i'm sure this is something with the engine. is there a way to increase that distance so the objects will remain accurate from farther distances as well ?

1.png (227.7 kB)
5.png (68.2 kB)
20.png (84.6 kB)
avatar image Tim Hobson ♦♦ STAFF Apr 07 '15 at 05:39 PM

Hi Sahkan,

I've still not been able to reproduce this issue on my end.

I've setup several rows of the basic cube and even scaled them as you've indicated from your test.

Here are my results: alt text

Would you be willing to share a blank project this can be replicated in? If you only use the basic cube (with plane white material) from the modes panel in the top left you can just attach a map and I can see if I can see the same results. A project would be better if you can replicate because then I can see if it's something in there.

It'd also be good to know what your lighting settings are set to, your world settings, and anything that is not set to default. All of my settings are default and I'm not able to replicate. Even adjusting the settings to see if something randomly appears has not worked.

Let me know.

Tim

cubelayout.png (389.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question