x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Problems with working build for Android and Gear VR

Im taking a different approach to this topic since theres soooo many things seemingly wrong with building for Android, and a lot of the answers im finding say these issues were fixed back in march last year or the question is being closed without any resolution.

ok so

I am sure that all SDKs are set up correctly, BECAUSE Tappy Chicken builds to my phone and packages perfectly in an instant. I have checked all the settings and my other super basic test projects have been set up the same to the best of my knowledge and to what the documentation and others are saying to do for example:

  1. Package name has [PROJECT] at the end instead of writing something else there, (Which if this is a true requirement, its bolocks, not sure if this helps but was one tip.)

  2. All SDKs filled in correctly and without spaces in file path.(like i said earlier this has to be done correctly on my part because Tappy Chicken built no problems to the Device and runs no problem. Everything in the SDK is installed correctly i am familiar with Android dev from Unity projects and its not usually a problem)

  3. Configure For android button. (this is easy takes a second)

  4. Setting default server game mode to something other than "None".(This was a pain to find, its in a drop down menu in "maps and game modes").

  5. Package for ETC1 if you dont know what your device supports. (Done this too.)

Ok so i have tried building from binary editor and also the source from Github through Visual studio too which was another different nightmare all together.

Both fail. The only thing that works is Tappy Chicken.

The only thing i Noticed different in the Android set up was that it was configured for Google play services and all its details was filled out for distribution to the Store. I disregarded this for common sense reasons, thats not my objective at this time. IS THIS A REQUIREMENT TO BUILD? just curious

What else are we missing here?

Can someone at EPIC please go home and build a consumer version of the engine and try this please? its something so simple but so many devs are having issues with.

The common issue is Package failure with a Project other than TAPPY CHICKEN, usually something about automation tool or something else.

Im trying to get a build onto Oculus Gear VR, but i cant even get a standard android build to work first.

PLEASE HELP GUYS.

Also the engine FREEZES UP if i leave the build log up for more than 10 seconds so i cant read the dam thing without crashing the EDITOR ahhhhhhhhhhhhh the humanity. frustration x 99999999999

I am using the lastest engine 4.7.3

Product Version: Not Selected
Tags:
more ▼

asked Mar 25 '15 at 12:35 AM in Packaging & Deployment

avatar image

SteveKouts
56 6 7 9

avatar image Chris Babcock STAFF Mar 25 '15 at 05:18 PM

First, 4.7.3 does not require the package name ending match the project name any more. Also, Google Play is optional and not required.

Is this a Blueprint or C++ based project? Can you package a project built from any of the templates?

I really need to see the log to help. There should be a log in the project save/logs folder with the name [PROJECT].log. I have not seen any freezes and have tried the released 4.7.3 without any issues.

avatar image SteveKouts Mar 26 '15 at 04:55 AM

Thanks for your reply. Ive tried both C++ and Blueprint based projects. But I am trying to build for Oculus Gear VR and I read that Gear VR will only work with a C++ Source build(is that true??); so for this example lets say its a C++ build. And yes im trying to package the default racing example project with all the correct settings for android and the sdk. I will post the logs later tonight when Im at home. also as i stated i have successfully packaged and ran the TAPPY CHICKEN example project to my galaxy note 4 and even packaged for the oculus VR with that project; it DIDNT run on the oculus but thats another story and problem all together as to why it was a black screen. BUT ive tried my own prototype projects with the same settings as tappy chicken, and ive tried other example starter projects and they dont package.

thanks

avatar image SteveKouts Mar 26 '15 at 03:04 PM

Ok ive manage to package some how today the only thing i did different is configure the google play services in a desperate attempt to find a solution. low and behold today i fired up the engine and packaged for android. IT WORKED!

BUT now i have another problem when installing to the device it failed to install properly and the app didnt run on the deviceim attaching cook log and error from install command line.link text

cook.txt (175.6 kB)
avatar image Chris Babcock STAFF Mar 26 '15 at 04:38 PM

Odd. It should not be necessary to configure google play services. It is possible previous data was left over from earlier attempts to package and turning on google play services forced an overwrite of stale state.

The runandroidfail.txt errors are not fatal; it tries to remove any previously installed files from the device and this is harmless if they aren't there. I didn't see the result from the push of the obb file, though. If this fails, the data needed by the engine is not present and the application will fail to start.

Running a development build on the device and capturing the logcat is the best way to tell what is happening. Run "adb logcat -c" to first clear the log, then "adb logcat -s UE4" to see only UE4 log messages and start your app.

avatar image SteveKouts Mar 27 '15 at 11:28 PM

ok here is the logcat i am packaging now the source build i had a few problems with missing .so and then rebuilt the game the project in VS. anyway heres the logcat from the game on the device and its not running just crashes after a few seconds. link text

logcat.txt (46.0 kB)
avatar image Chris Babcock STAFF Mar 28 '15 at 05:28 AM

Looking at the log you have a Kindle Fire HD 7" tablet. We don't fully support Kindles yet. Try turning off Mobile HDR in the rendering project settings. Also, you need to use a Note 4 with GearVR.

avatar image SteveKouts Mar 28 '15 at 05:39 AM

Yes im aware of the Gear VR devices. That was just a normal android build. Im using a different android device now Galaxy S2. once again the build crashes but i have the logcat errors. Basically the Engine content isnt being found for some reason heres the Logcat and thanks for your help im really stuck on this, theres no other answers out there about this.

avatar image SteveKouts Mar 28 '15 at 05:40 AM
avatar image SteveKouts Mar 28 '15 at 08:14 AM

OK i have managed to mess around with things and get a build working on my Galaxy S2 and my note 4. So yay me!

The new hurdle is Gear VR. it packages but when it comes time to plug the device into the Gear VR when prompted i get an "EXAMPLE has stopped unexpectedly and OK" and thats it, it doesnt run. If you could help with that would be awesome thanks. This is literally my last hurdle.

avatar image wittlief ♦♦ STAFF Apr 02 '15 at 05:01 PM

Hi SteveKouts,

Luckily, we very recently had a Twitch stream on the UE channel that addresses GearVR setup and answers a number of user questions. Please have a look at this stream, so you can double check your personal setup.

Further, here is a GearVR thread on the Oculus forums that clarifies and addresses some of the issues users are seeing. I hope this helps!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jul 08 '16 at 09:00 PM by Samantha Sutton for the following reason:

The question is answered, right answer was accepted


2 answers: sort voted first

Thanks i have resolved my issues and got it all running a few days ago thanks for the help. Yes i saw that dev stream on youtube yesterday after i had already resolved my issues. Basically there was alot of things that needed to be configured correctly to get it running which wasnt in the stream either. I will be making my own tutorial for you tube soon to help go through the entire process and talk about some troubleshooting things to that people may be getting snagged on.

more ▼

answered Apr 03 '15 at 08:25 AM

avatar image

SteveKouts
56 6 7 9

avatar image wittlief ♦♦ STAFF Apr 03 '15 at 03:10 PM

That would be very helpful. I'm going to close this thread out with your comment as the answer. Thanks very much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have resolved this and have a working build for Android and Gear VR. Basically i got the build working for Android first. Some Tips for anyone else having porblems.

  1. Install the NVPACK with Android SDK and NDK on the C: drive. This might seem obvious but i have a SSD that fills up all the time and tried installing the SDKs to my D: and had many problems, uninstalling completely and re installing everything to the C: i think cleared up some problems.

  2. Make sure all build tools are installed and APIs inside the SDK manager. Include the USB drivers too.

  3. Obvious but make sure developer mode is enabled on device. And ADB is enabled and USB debugging.

  4. For Gear VR development you need to run the Source version of UE4 from Github, its not that dificult to set up and get going.

  5. So now you have the Source engine Run the editor with Start Debugging from Visual Studio 2013 which you need to install. You can get the express version.

  6. Once the editor opens up you can; CONTRARY TO WHAT SOME PEOPLE THINK, you can start an example blueprint project that you intend to build with Android and Gear VR. Once the project is opened you can add some C++ code to the project, i usually just make a class called TestClass because it can be deleted later YOU DONT NEED TO CODE IN C++ TO GET THIS WORKING. So once you make the TestClass the project will be converted to C++ project in visual studio. Right click the project name to the right and Build. should take a couple seconds.

  7. Now this is something that i got stuck on, and you may need to do to fix your project to build for android. The files that you get from Github for me were missing a folder with android file UE4Game-armv7-es2.so which should be at C:\Users\User\Documents\GitHub\UnrealEngine\Engine\Binaries\Android BUT! This folder for me didnt exist and neither did the .so file. SO TO GENERATE IT i did this. In VISUAL STUDIO 2013 change your SOLUTION CONFIGURATIONS to DEVELOPMENT and change your SOLUTION PLATFORM to ANDROID. then build the solution. You will get many errors BUT it WILL generate that god dam .so file FUCK YEAH AMAZING! sorry but was big moment for me lol.

  8. Do clean and rebuild of the Engine after that make sure you have everything being built.

  9. You should now be able to build and debug your game project.

  10. Configure the typical android settings and tick the plugin for Gear VR and also Configure to build for Gear VR in Android settings under Platforms in Project settings.

  11. Make sure Mobile HDR is OFF in rendering as i ahev had it crash when enabled.

OK

So now how to get the camera headtracking the Head Mounted Display (HMD)?????? Simple stuff but no one says shit about it.

  1. Create a Player camera Manager blueprint, i called it VRPlayerCameraManager. In the new PlayerCameraManager Look for HMD Orientation setting and TICK that fucker!

  2. Create new Player Controller i called it VRPlayerController, now in that add the VRPlayerCameraManager to the Player Camera Manager class at the top of the class defaults.

  3. Then Go to your GAME MODE and plug in your new VRPlayerController.

  4. test it out in editor all should look normal.

  5. Now run a build for android, IF you dont know which to build for just build for ETC1 which will work with most if not all android devices, the Note 4 for GEAR VR uses ETC2. Also a tip once building to the device and the app is running you can hold 4 fingers on to the screen to get the command line for mobile to pop up it will also tell you what build type your device is also. BTW ETC1 ETC2 etc is related to how textures and materials are compressed and rendered.

  6. One last thing to check if you have problems is that Your TARGET HARDWARE in Project settings are set to Scalable 3D/2D and Mobile/Tablet. I will make a video explaining everything from start to finish. I skipped a few things here but thats because they are explained in the documenation i mostly went over stuff that isnt in the docs that you should be aware of.

cheers Goodluck!

more ▼

answered Apr 03 '15 at 10:55 AM

avatar image

SteveKouts
56 6 7 9

avatar image dr.purple Jan 01 '16 at 03:41 AM

Thanks so much for this! Quick question about getting the head tracking to work - Do you have to have gear VR in order for the head tracking to work even if the Samsung phone is set to developer mode?

I can packing my project for android (ec2) no problem and I can load it up on my Samsung 6s, but if I move around, the character doesn't look around at all.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question