x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

why can't delete the c++ class from content browser?

hi guys,im new to unreal ,and recently i find a problem that when i want to delete a c++ class added by "Add Code to Project" from the content browser, i just find the "delete" option in grey color, so how can i fix it?? thanks in advanced

Product Version: Not Selected
Tags:
more ▼

asked Mar 25 '15 at 02:16 AM in Using UE4

GinSoneWin gravatar image

GinSoneWin
11 1 2 1

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Yeah its the .obj file made by VS that is making it appear in the UE. After you have removed the .h and cpp from your VS project, 'Build > Clean Solution' in VS to get rid of it.

more ▼

answered Jun 13 '15 at 03:26 AM

Ariegos gravatar image

Ariegos
21 1 6

(comments are locked)
10|2000 characters needed characters left

As far as I know, to delete a c++ class find the folder that it is stored in on your computer and delete the file manually, then delete it from the solutions explorer in your IDE. When you restart Unreal it will reload your classes into the editor the c++ file you deleted should be gone.

more ▼

answered Mar 25 '15 at 03:52 AM

LifelessChimera gravatar image

LifelessChimera
18 1 7

GinSoneWin gravatar image GinSoneWin Mar 25 '15 at 04:14 AM

but since in content browser has a "delete" option , it should be able to delete it from content browser directly so that i dont have to do these step...but i dont know why the "delete" option is in grey =_=!

LifelessChimera gravatar image LifelessChimera Mar 25 '15 at 04:17 AM

Yeah, I know what you mean xD. I ran into this problem a couple days ago and the best answer I could find was the one I gave you. Maybe someone has a better solution.

GinSoneWin gravatar image GinSoneWin Mar 25 '15 at 04:19 AM

anyway ~ thanks a lot :)

Puschie gravatar image Puschie Apr 30 '15 at 03:32 PM

It doesnt work ( for me ) - the Unreal Editor do not delete the compiled files and block the used names.

finlaybob gravatar image finlaybob Jul 28 '15 at 09:12 PM

+1 for this. This is the only solution that worked for me too. Thanks.

(comments are locked)
10|2000 characters needed characters left

The true is, Delete from windows explorer, and find your .uproject file , right click, choose "Generate Visual Studio project files"

more ▼

answered Jan 15 '16 at 06:20 AM

Hongbin gravatar image

Hongbin
6 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question