x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Simulate physics on Skeletal Mesh teleport to origin

Hello, I'm trying to set simulate physics on a skeletal mesh to do a ragdoll of my character at death. But when the physics is simulated the mesh is teleported to origin. Also the ragdoll go crazy while it works perfectly in the PhysicsAsset. alt text

alt text

alt text

Product Version: Not Selected
Tags:
more ▼

asked Mar 25 '15 at 10:09 AM in Bug Reports

avatar image

Bozarre_
26 5 6 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Thomson,

How are you setting the character to rag doll in the viewport? If you're doing anything via the event graph in your BP it would be helpful to see that. Once you've posted that I can look see if I can reproduce this with the bi-pedal character that I have. Unfortunately, I do not have a quadru-ped, so hopefully there will be a similar situation that I can see on my end.

Thanks!

Tim

more ▼

answered Mar 25 '15 at 02:44 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image Bozarre_ Mar 25 '15 at 06:53 PM

Hi Tim,

I tried the two following settings :

  • "set simulate physics" directly in the details panel of the skeletal mesh in the viewport.

  • In Graph : "set simulate physics" on the "Begin Play" event. And "set world position" does nothing.

For both I tried with "Block All" and "Ragdoll" Collision presets.

The weird thing is that I also have an other project on 4.4 with the same settings (not the same skeletal mesh) and the physics works.

avatar image Tim Hobson ♦♦ STAFF Mar 25 '15 at 08:34 PM

Hi Thomson,

Got it. This is actually a bug that has already been reported by me a little while back with UE-11266. I've gone ahead and added this post to the report.

Once a solution has been reached I will update the post here with any relevant information.

thanks for your patience while this is being looked into.

avatar image RyroNZ Apr 07 '15 at 11:49 AM

I thinks, just noting that I am also experiancing the same issue.

avatar image DamirH May 07 '15 at 02:16 PM

Got the same issue, any update on this?

avatar image Tim Hobson ♦♦ STAFF May 07 '15 at 02:56 PM

No update at this time. The issue has been assigned to a developer to look into.

Once there is an update I'll pass along any information.

avatar image Penfound Jun 26 '17 at 12:16 PM

Any updates yet, please?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Is your Skeletal Mesh scale set to 1,1,1, because I've seen problems with scaled meshes.

In 4.18, the root of the mesh during simulate physics gets set to world coordinate of its actor relative offset. Which seems very wrong.

more ▼

answered Mar 16 '18 at 07:18 PM

avatar image

BenVlodgi
2.2k 39 17 52

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

may be related to this: https://answers.unrealengine.com/questions/228817/set-simulate-physics-changes-position.html

this issue occured only when I enabled a lock position prior to actually simulating the physics. the intended goal was to set the system up to only allow z-movement during ragdoll, and then trigger ragdoll when needed, but setting contraints prior to the simulation trigger caused issues.

more ▼

answered May 29 '18 at 07:37 PM

avatar image

paradoc
1.2k 49 31 87

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question