x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Thermal Post Process Shader

Hello there, I've been looking into getting a Thermal Vision mode Post Process Shader to work, I've been slowly learning about Post Process Materials and Shaders, and I have also found a couple of posts on the forums to help get started. However the effect achieved so far is still off from the effect I would like.

Here is the blueprint of the main shader.

Now I've tried various things like cranking the output of the shader, because typically that works with normal materials making them glow, but it doesn't seem to work here. I have also tried plugging some scene and pixel depth nodes into places to see what results I get, but to no avail.

I would really appreciate some pointers in the right direction, even the slightest tips can help.

The secondary material applied to objects to give them that thermal glow is just a fresnal node basically.

The results are quite nice however I would like it to be less sharp. It also has the issue of appearing strangely through other meshes, I am sure this is because of the custom depth being used.

I am aiming for more of a blurry look not unlike the image below which another person has done, but refuses to provide any assistance or pointers in the right direction. As you can see in their version, they have a really nice blurry look to them, and the characters fade into the blue-purple colour, and everything seems to be rendering in that purple colour, but also the characters behind the walls appear less intense and more blurry, So obviously they are working the shader based on depth from the player as well as some form of occlusion to reduce the intensity of the effect.

Also here is a picture of Splinter Cell Blacklist which has another nice effect of which it seems to incorporate some sorta scene depth and apply the blue colour on that it also has a less intense blur to the point that the normal material detail of the character can still be made out.

Thank you kindly for helping.

Product Version: Not Selected
Tags:
thermapic3.png (206.0 kB)
thermalpic.png (44.7 kB)
therm.png (161.2 kB)
234231.png (595.3 kB)
12415.png (23.2 kB)
more ▼

asked Mar 25 '15 at 04:02 PM in Rendering

avatar image

Recker
51 10 12 17

avatar image Recker Mar 26 '15 at 04:47 AM

I've managed to get the depth fade colour to work properly through some experimentation.

I changed what was plugged into the B slot of the last Lerp node, what I have there now is this:

I am still looking for some help with the blurring of objects, is it possible to duplucate whats being rendered and blur and overlay it?

124355.png (14.9 kB)
111111.png (132.7 kB)
avatar image Recker Apr 15 '15 at 10:28 AM

I am still seeking help with this, thanks.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Since this is a post process effetc, you could just use the Depth of Field to achieve the blur. Turn it on whenever you switch your goggles on.

I would try to do the following with the DoF: -Set it to gaussian. -Set every other value to 0 except for Far Blur Size, use that one to tweak the blur (0 - 4).

Good luck!

more ▼

answered Mar 27 '15 at 11:11 AM

avatar image

Roel
2.4k 67 41 141

avatar image Recker Mar 27 '15 at 11:42 AM

I have tried that, but it didn't seem to work, when I took the thermal vision shader out of the blendables of the characters camera, the Depth of Field effect work, the effect also seems to disable antialiasing, and glows that materials will have due to a cranked up emmisive output.

I am unsure of how to go about fixing this.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question