x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android can't package inside .apk

Product Version: Not Selected
Tags:
more ▼

asked Mar 26 '15 at 05:14 AM in Bug Reports

avatar image

damody
51 6 10 13

avatar image [Epic] Gribbs ♦♦ STAFF Mar 26 '15 at 06:39 PM

Howdy damody,

Thank you for reporting this issue. I am going to need a bit more information before I begin investigating this issue. Would you be using a binary build or a source build of UE4? Also, Have you been able to package your project in any previous build of UE4?

Can you test and see if you get the same error in a blank template project?

I have tried to open the link that you have provided for the project but have been unable to download. Would you be able to share a zip file of the project via Dropbox or Google Drive?

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image damody Mar 29 '15 at 05:45 PM

I try the 4.7.4 all will fail.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 30 '15 at 01:55 PM

Hey Damody,

Thank you for sharing your project. I have downloaded both projects and have seen no errors with either. I tested both builds just to be sure, and ran into no error messages. Would you be able to share Android version and model number of you Galaxy S5?

Also, Be careful with the 4.7.4 build of UE4. That is not a released build so it may still have issues associated with the build. Unreleased builds can be unstable.

Thanks!

avatar image damody Mar 30 '15 at 03:58 PM

I use Android 5.0, SM-G900I, but I try HTC M8 Android 4.4.4 also has another error like picture

![alt text][1]

https://mega.co.nz/#!iI8nQB7Q!S_9iGursNLwy07AVwtgoo48oV-X6weTMQ-mp974Z80E

I upload my project, because I can't know which part is wrong.

I update to 4.7.4 because I need fix some bug In my project like

https://answers.unrealengine.com/questions/199988/add-widget-component-cant-save-status.html [1]: /storage/temp/36596-screenshot_2015-03-30-23-08-35.png

avatar image [Epic] Gribbs ♦♦ STAFF Apr 03 '15 at 02:25 PM

Howdy damody,

Sorry to get back to you so late. We have released the official 4.7.4 version of UE4 to the public and wanted to check in with you and see if you have tried your project on that version? The version that you have previously was a promoted build and not the release 4.7.4 version.

Be sure to let me know if the error is still occurring so I can further investigate.

Thanks!

avatar image damody Apr 03 '15 at 04:19 PM

still occurring, CDO constructor Failed I try ETC2 is ok, but ATC Failed.

avatar image wittlief ♦♦ STAFF Apr 03 '15 at 06:37 PM

ok good. Can you attach logs for both the one that succeeded and the one that failed?

avatar image damody Apr 04 '15 at 02:30 AM
avg_atc.log (49.2 kB)
avg_etc2.log (20.5 kB)
avatar image wittlief ♦♦ STAFF Apr 06 '15 at 03:16 PM

Ok, were both these attempts for packaging the same project? The ATC log looks like it's unable to find many assets and materials that are used in the project. Have you recently deleted parts of your project? I don't see the same 'Unable to find/Can't find file/Failed to load' errors in the ETC2 log.

avatar image damody Apr 06 '15 at 04:57 PM

Yes, I packaging use same project same content. you can download from https://mega.co.nz/#!iI8nQB7Q!S_9iGursNLwy07AVwtgoo48oV-X6weTMQ-mp974Z80E

avatar image wittlief ♦♦ STAFF Apr 07 '15 at 02:01 PM

Hi damody,

Have you double checked all of the limitations on Mobile Game Development to make sure you aren't using any assets that won't work for mobile? Have you tried double checking your project to make sure that the assets referenced in the many 'unable to find' errors are no longer associated with your project?

Lastly, CDO errors are not easy for us to diagnose because they could be related to many problems. However, in this thread a dev walked another user through his problem which involved a bad path name. Please have a look at these and see if it relates to your issue.

avatar image damody Apr 07 '15 at 05:34 PM

Howdy wittlief, I double checked today, it fine. And I found if I use package obb inside .apk, it will crash in . it's crash log. link text

If package use default setting, it's fine no problem.

alt text

but when I use Launch, It's always not found something.

alt text

avatar image wittlief ♦♦ STAFF Apr 09 '15 at 05:00 PM

Hi damody,

I just tried to reproduce this using Tappy Chicken packaged with the obb inside the apk option and it did not crash. I used the Galaxy Note 3 which is a somewhat older device than your SM-G900I. Have you checked that there's not a driver conflict? We have noticed that sometimes the drivers for the Asia-specific devices (like the SM-G900I) have problems with the editor. Can you get the latest drivers for your device and see if that helps?

If you're still seeing the device crash, can you include a fresh logcat attached to this thread? The previous one seems to cut off before it gets to an error, though that could be the point at which it crashed. Feel free to include both the UE4 filter and the unfiltered logs.

Can you also try again to add the error that you were getting on the HTC M8?

Thanks very much!

avatar image damody Apr 09 '15 at 08:10 PM

Hi wittlief,

I try HTC M8 inside the apk option and it did not crash. but lanuch still crash.

My HTC M8 haven't Root, I don't know where can get log. I just copy create apk log from computer.

[link text][1] [1]: /storage/temp/38258-avg+launch.txt

avg launch.txt (375.2 kB)
avatar image damody Apr 10 '15 at 12:54 PM
avatar image wittlief ♦♦ STAFF Apr 10 '15 at 07:30 PM

Ok, go ahead and check that thread for the instructions I gave him, and see if it helps.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

We know 4.7.4 "Package" to android is ok. "Lanuch" to android is failed. Lanuch problem please see this thread: https://answers.unrealengine.com/questions/206066/android-crash-on-launch-failed-to-find-roboto-font.html

more ▼

answered Apr 11 '15 at 08:25 PM

avatar image

damody
51 6 10 13

(comments are locked)
10|2000 characters needed characters left

alt text

Got BANNED in Windows 10 to package Android after build

more ▼

answered Sep 04 '16 at 03:57 PM

avatar image

PennySchloss2019
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question