x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Node Connection disappears

Hi everyone!

I think I found a bug, in my project I cant quite figure out. Each time I start or restart the Editor a single Connection between nodes disappears. Kinda like in this post: https://answers.unrealengine.com/questions/123934/undefined.html

alt text

The tricky part is, that the problem first appeared, when I was experimenting with widget components. Befor that everything worked fine and i didn't work on the affected BP for quite some time. I remember a bug, dont know in wich version it appeared though, where u got an unresolved compiler error in a random BP, when using event dispatchers in an UMG widget. Could there be a relation? I'm working on 4.7.3

Product Version: Not Selected
Tags:
more ▼

asked Mar 26 '15 at 02:04 PM in Bug Reports

avatar image

Max Heiermann
98 7 12 15

avatar image Ben Halliday STAFF Mar 26 '15 at 02:49 PM

Hi Max,

Does this only happen with the one wire, and does it happen every time you restart? Are you able to reproduce this in a new project, or does it only happen your current project? If you're able to provide consistent reproduction steps for us, that would be super helpful. If you can't, would you mind uploading your project (or a test project if you can repro in a new project) somewhere and getting me a download link? Thanks!

You also mention a bug with an unresolved compiler error when using an event dispatcher in a UMG widget. Is that what you're experiencing? If you remove the widget with the event dispatcher, does this wire disconnection issue stop occurring? I wasn't able to find any information regarding that bug in our system or an AnswerHub post about it, so I'm sorta flying blind on that one at the moment.

avatar image Max Heiermann Mar 26 '15 at 03:29 PM

Hello Ben,

I was searching for that older bug and unfortunately I'm not able find anything about it anymore, however I found some posts, that might be related:

https://answers.unrealengine.com/questions/64260/compile-error-when-opening-project.html

https://answers.unrealengine.com/questions/37693/blueprint-compile-error-on-project-open.html

The Problem there seemes to be the cast, so im gonna try to find a workaround for my GameState cast very quick. Still that was not a problem, before using widget components.... very strange.

Btw its always that one wire, even when I collaps the whole block into a function, the problem occurs inside that function.

Greetings -Max

avatar image Max Heiermann Mar 26 '15 at 04:00 PM

Ok found a workaround, now it works. Still strange bug though. Sorry I couldn't provide you with information to that bug I was experiencing some time ago, but it was the same symptoms as in the posts above and appeared only when using an event dispatcher inside a widgetBP.... In this case removing the GameState cast solved it for me, but this bug still doesn't seem very rational to me.

Thanks for your time anyway. Hope I could help a bit with this report. I'll stay tuned for this issue, hope it can be tracked down somehow for other engine versions to come :)

Greetings -Max

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found some similar posts, where a Cast was the problem, found a workaround, now it works.

Seems like it did have nothing to do with the widget component after all.

more ▼

answered Mar 26 '15 at 04:06 PM

avatar image

Max Heiermann
98 7 12 15

avatar image Ben Halliday STAFF Mar 26 '15 at 05:21 PM

Glad you got it working! Can you show us the link to the post that had the workaround? Thanks!

avatar image Max Heiermann Mar 26 '15 at 06:33 PM

Its those 2 up there:

https://answers.unrealengine.com/questions/64260/compile-error-when-opening-project.html

https://answers.unrealengine.com/questions/37693/blueprint-compile-error-on-project-open.html

Each uses a different approach. I found my own. Since I only needed to get a value from the options in my character, I was able to revert the access, meaning i push the value from the options into my character instead of pulling it in the character, what required to do the cast.

Hope this helps!

-Max

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question