x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't add interface to Blueprint

After I had deleted my interface from a blueprintclass, I can't add it again.

The interface is still visible in the "Add interface window" but when click it, nothing happens.

Does anyone have an idea how I can fix that?

Product Version: Not Selected
Tags:
more ▼

asked Mar 26 '15 at 07:31 PM in Bug Reports

avatar image

Hensen89
11 1 3 3

avatar image Ben Halliday STAFF Mar 26 '15 at 09:04 PM

Hi Hensen89,

I wasn't able to reproduce this in 4.7.3. Does this happen in a new project, or only your current project. Are you able to reproduce this problem in a new Blueprint with a new Blueprint Interface? Can you list the steps you take to see this happen? Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Old thread, but may help someone....issue is most often that you have a function name in your actor that has the same name as an interface function name. If that happens, then you will get no error, warning or anything...but the interface will simply not be included in your class when you select it from the drop down.

There should be an error but there isn't.

more ▼

answered Nov 03 '16 at 06:22 PM

avatar image

gbrill
131 5 8 14

avatar image Wallenstein Apr 11 '17 at 09:18 AM

Also, after you delete the colliding function in the BP you need to recompile before you can add the interface

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Hensen89,

We haven't heard back from you in a while, so I'm resolving this post for tracking purposes. If you're still experiencing this issue, please feel free to reply with the information requested above and we will renew our investigation. Thanks!

more ▼

answered Mar 30 '15 at 09:42 PM

avatar image Hensen89 Apr 01 '15 at 08:45 PM

Hi Ben,

I had to reconstruct the Blueprint and now it works. I never had the problem again.

Thanks for your help and excuse my late answer,

avatar image timetravel May 29 '15 at 02:35 AM

I know this is an old topic, but I stumbled on it while trying to figure out the same issue I had. My solution was to manually delete the functions that the interface implements before re-adding the interface to your blueprint.

avatar image HanoGames Jul 24 '16 at 08:40 AM

I had the same problem (4.12.5), at first I was able to add an Interface to my BP, then I've deleted it accidentally, and in the following I wasn't able to add it again (just nothing happened when I clicked on it).

"timetravel"s trick with manually deleting the functions in the interface worked :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is definitely a bug that should be reported. Easy fix is to just duplicate your blueprint and the interface will add. Delete the original BP and rename the new one.

more ▼

answered May 28 '18 at 12:33 AM

avatar image

JTXPbrah
86 5 7 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question