x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightning Build Failed. Swarm Failed to Kick off

I looked around the forums at other posts and could not find the right solution.

This problem happened when update 4.7 came and I created a 4.7 version of the project I was working on (my project used to be in 4.6). Ever since then, I have been getting the same error.

I saw a solution on another post that I should find meshes with duplicate names and change them. However I have a lot of different meshes with the same names, does that mean I have to change the names of all these meshes?

Product Version: Not Selected
Tags:
more ▼

asked Mar 27 '15 at 02:09 PM in Rendering

avatar image

Valachio
21 2 6 8

avatar image ILLESTRADER Mar 29 '16 at 09:18 PM

Hey guys, I tried loads of these solutions. Replacing meshes and materials that had duplicate names. Checking hard drive space. Disabling firewall and anti virus software...

In the end I was trying deleting assets one by one and while checking to see if I could do a light build. I eventually found one that SEEMED to be causing the error. But once I reloaded the original level (without making ANY changes or deleting anything)... it worked fine. I'm no closer to understanding why the swarm was failing to kick off, but it seems like if you screw around with your level enough it just decides to work :-/

avatar image Talismansa Jun 20 '16 at 10:36 PM

This is what fixed it for me. More specifically, I used the following steps:

  1. Delete the first 20% of assets

  2. Try and start a build.

  3. If Swarm doesn't kick off, delete another 20% of assets.

  4. If Swarm successfully starts, then cancel and shut down UE4 without saving anything.

  5. re-open the project, and build. Swarm should work.

avatar image rants15 Mar 29 '17 at 01:01 PM

It seems to be the easiest way, anyway it worked :) Thank you!

avatar image Symon231 Aug 09 '17 at 10:20 AM

It worked for me :-) Thanks man

avatar image Sorvirix May 07 '18 at 01:29 PM

Thanks! That is works)

avatar image Džemal Apr 19 '16 at 01:17 PM

My solution on that problem was deleting some Point Lights..And problem solved for me ;)

avatar image Tim Hobson ♦♦ STAFF Apr 19 '16 at 02:25 PM

At this point last year I didn't have this Wiki setup yet, but it may be useful for troubleshooting most Swarm Agent issues:

https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

12 answers: sort voted first

SOLVED:

1) Open UE4.sln

2) Build UnrealLightmass

more ▼

answered May 22 '16 at 10:30 AM

avatar image

newbprofi
1.1k 119 144 378

avatar image Balthazzar May 30 '16 at 05:41 PM

This worked for me! thank you very much!

avatar image zibin Apr 05 '17 at 06:39 PM

Wheres that sln file tho?

avatar image Zaggoth Apr 26 '17 at 03:41 PM

If you are using a custom engine build, it will be in your engine install folder.

avatar image vikhik Jun 01 '16 at 08:26 AM

This has also worked for me, thanks!

avatar image 6gg Studios Jun 28 '16 at 01:15 PM

This was a huge help, I was checking every damn asset in a 40+ gig project, if you have this problem, definitely do that ^ works...

avatar image grislebeard Aug 31 '16 at 06:37 AM

If you're on a Mac build the UnrealLightmass target in the Xcode project

avatar image Broc923 Oct 21 '16 at 06:07 AM

This worked for me. I was starting to get annoyed.

avatar image piurafunk Dec 20 '16 at 07:09 AM

Wish i could upvote this, this saved me a big headache. Did not want to go through all my assets to see what could be the problem.

avatar image paradoc Feb 25 '17 at 04:01 PM

this solution worked for me with ue4 4.15 source

avatar image Razrfeng May 27 '17 at 08:01 AM

So... what if we dont have ue4.sln? I did a search of every file on my PC relating to UE and have not found it, manually or through the search function.

avatar image SyedAman Aug 05 '18 at 10:28 AM

This is for source build. If you're using UE4 straight out of GitHub, this is your solution. This does not apply to Epic Games Launcer, I don't think so.

I simply went to my source build directory, and opened the solution. You can read about how to generate the solution file in the UE4 github README:

https://github.com/EpicGames/UnrealEngine

avatar image Dazzle Inc. Aug 08 '17 at 09:03 AM

Worked for me with ue4.14! thanks

avatar image Thoeme Mar 22 '19 at 12:37 PM

Worked for me as well. Thanks a lot

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

What worked for me was deleting the data cache: C:\Users######l\AppData\Local\UnrealEngine\Common\DerivedDataCache

more ▼

answered Jan 22 '16 at 11:30 AM

avatar image

Tanguy Dewavrin
44 4 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey guys! I had this error message and found out the error message was because my C: drive had only 100MB of memory left!

more ▼

answered May 13 '15 at 08:18 PM

avatar image

Rashedal
6 1 2 3

avatar image Lord Pol Jan 24 '19 at 07:57 PM

Worked here in 4.21. Thanks!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had this problem as well and would like to add something:

I imported a few static meshes that for some reason didn't automatically add their materials, one mesh had two Material Elements but I left one of them empty since it didn't appear to do anything. And that was what caused the problem, as soon as I added a material to the second Material Element for the Static mesh then light built just fine.

alt text

I hope this helps someone!

buildlight1.jpg (229.2 kB)
more ▼

answered Mar 26 '16 at 10:56 AM

avatar image

Fred82
83 3 4 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Swarm Agent has a log which spits out an error when you get the "failed to kick off" message in the Editor.

Swarm Agent log

The error is that a file in the Swarm cache being used by another process. Leaving procmon running while starting the build, this is the complete list of processes accessing the file in question:

Procmon

As you can see, only UE4 itself is accessing the file, not even Windows Defender is causing trouble. Could it be that two threads are trying to create the same file, colliding with each other and keeping Swarm from kicking off?

Sometimes I managed to fix the error by just deleting everything, quitting without saving, and reloading, but not always. The error is very random, and often after hours of trying to track down the object in question using the methods above, it turns out to be an object that baked just fine before.

swarm.jpg (41.9 kB)
procmon.jpg (45.1 kB)
more ▼

answered Oct 27 '16 at 12:08 PM

avatar image

Lhorkan
23 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Valachio,

Apologies for the delay in getting to this one.

There are a couple of reasons that Swarm Failed to kick off.

Some of the more common ones are that the firewall or antivirus may be blocking it from starting properly. You can disable these and then try to build lighting to see if that works.

The other is that there may be multiple swarm agents opened in your take bar (next to your computer clock in the bottom right). When swarm agent is initialized there will be a orange and black S icon that appears. Close any your see here and then try to build lighting.

If none of that works, can you try building lighting in a new template project like the first person or third person templates? This can rule out if it's a project specific problem or swarm agent issue possibly.

Thank you!

Tim

more ▼

answered Apr 09 '15 at 08:48 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image Valachio Apr 09 '15 at 10:26 PM

No problem, I'm just glad someone responded haha. I tried both of the methods and neither worked. Yes I can build lighting on other existing/new projects. Someone suggested that duplicate meshes may be the problem on another thread (dev666rej):

link text

I went ahead and renamed all the meshes that had the same names and still had the same error.

avatar image Valachio Apr 13 '15 at 03:20 AM

Hello again Tim. The problem persists for me, is there any other solution.

I can build lighting on any other level in the project, just not on the main level.

avatar image Tim Hobson ♦♦ STAFF Apr 15 '15 at 05:20 PM

So it's only this particular map that is causing swarm agent to not build lighting and all other maps build lighting correctly?

If that's the case, it may just be a corrupted map that needs to be replaced. You can go to File > Export > save a .t3d file > Create a new map > File > Import > and select the .t3d file you just created.

This will place any objects in the scene that were in the other map.

This may be an option to get around the map not building lighting.

avatar image Valachio Apr 15 '15 at 10:17 PM

Still the same error. Jesus... I think I tried this earlier when I copied all assets on the original map into a different map.

Perhaps there is a specific asset/material in the level that is restricting swarm from kicking off? I already tried an earlier method where I renamed all the assets in my content browser that has the same names.

avatar image Tim Hobson ♦♦ STAFF Apr 16 '15 at 06:42 PM

I've heard that this had been an issue before with some (Dev666(?) I think), but I've not ever personally encountered this issue with materials or assets that stop the light build.

At this point, would you be willing to share the project or the map that is causing issue and I can try to build on my end and see what's going on? You can share privately via a PM on the forums if you're willing.

It's odd that this is only affecting a single map though and not all of them though.

avatar image Valachio Apr 19 '15 at 03:23 PM

Yes, I think I mentioned Dev666's post earlier. I don't think that he had the same problem as I did though. I finally managed to fix the problem by deleting some assets and putting them back into the level. Odd way of fixing it but it did the trick. Thanks for your time!

avatar image Tim Hobson ♦♦ STAFF Apr 20 '15 at 01:38 PM

Thanks for letting me know.

If you don't mind answering a couple of other questions for me:

  • How did you find the asset that was causing the issue? Delete, build lights, repeat? Was this the process you used to see if it was a mesh causing the issue?

  • Deleting and re-adding this asset fixed your issue completely or was the asset completely unusable with Swarm Agent?

Thanks!

Tim

avatar image Valachio Apr 20 '15 at 04:00 PM

Yes I deleted a whole section of the map, built lighting, and it worked. Oddly enough, after I restarted the project without saving in order to recover the section of the map I deleted, I built the lighting again without deleting any meshes and it built just fine.

So apparently there was no corrupt mesh that was preventing lighting from building. Just an error with a mesh on the map, which fixed itself after temporarily deleting it.

avatar image Tim Hobson ♦♦ STAFF Apr 20 '15 at 04:17 PM

interesting. This is something I've never encountered myself.

Let me know if it comes back and causes any other issues.

Thanks for getting back to me. :)

avatar image newbprofi May 22 '16 at 09:43 AM

4.11.2

Have the same problem. For all projects, even for new projects. Cannot rebuild lights because of this error.

avatar image newbprofi May 22 '16 at 10:30 AM

SOLVED: 1) Open UE4.sln 2) Build UnrealLightmass

avatar image Hunted73 Dec 26 '17 at 01:15 AM

Did you keep the project open or do you close the program and then do Build UnrealLightmass or do you pick ReBuild UnrealLightmass?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Swarm will also not work with with source code version of the engine, so if you pulled the source from git and compiled the engine you will either need to use your own solution, or bake the lighting in the launcher engine and then somehow import it over.

more ▼

answered Oct 14 '15 at 04:24 AM

avatar image

Chaoss
6 8 13 19

avatar image newbprofi May 22 '16 at 10:19 AM

so are u saying that code compiled engine is totally useless?

avatar image Balthazzar May 30 '16 at 05:43 PM

It's not. newbprofi said it in a comment - as long as you build UnrealLightmass from your UE4.sln it's gonna work. Had the same problem but that fixed it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I I had this problem as well and would like to say my solution was some POINT LIGHT delete..some of them i delete and build lightning with no problem ;)

more ▼

answered Apr 19 '16 at 02:04 PM

avatar image

Džemal
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In my case, it was because a Sphere Reflection Capture was referenced in the level BP !!!

more ▼

answered May 08 '16 at 02:02 PM

avatar image

FaustyWalk
31 3 4 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So far deleting the data cache hasn't worked for me. This one level I have has done this twice to me now. Very Annoying. What I did to fix it reasonably quickly was use Shift + click to drag and select half the assets in my level using the Outliner list and copy them and then delete them (without saving of course). Then rebuild the lightmass. If it builds you know its an object in the deleted half of the level. Press Ctrl V to paste the half back. Then copy and delete half of the half you first deleted to continue to narrow it down by process of elimination. Hopefully I an easier process can be found soon.

more ▼

answered May 22 '16 at 11:33 PM

avatar image

Trandana
52 5 5 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you have built UE from source code, you will need to manually copy a DLL file or two. If I remember right its the embree.dll and tbb.dll files. You will have to copy them to your compiled UE location \Engine\Binaries\Win64

I just copy them from my UT Editor (launcher installed) location to my development location and this will all ways fix it.

more ▼

answered Apr 28 '17 at 05:39 AM

avatar image

Snake.Pliskin
0 1 5 5

avatar image Betazero Aug 26 '17 at 07:46 PM

This may work for some but I changed the name of my project and now it builds. Weird but hey

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

THIS WORKED FOR ME:

If you're using 4.10 or later you will need to have the VS2015 dependencies installed. You can download the Visual Studio Dependencies from Microsoft's website:

VS2013: http://www.microsoft.com/en-us/download/details.aspx?id=40784 VS2015: https://www.microsoft.com/en-us/download/details.aspx?id=48145

more ▼

answered Apr 21 '18 at 12:43 PM

avatar image

Almajority
6 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question