x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot create C++ Projekt 4.7.3

When I try to create a New Project I am getting the following log output:

Failed to generate project files. Log output: Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/marko_000/Documents/Unreal Projects/ÜbungCplusplus2/ÜbungCplusplus2.uproject" -game -rocket -progress UnrealBuildTool Exception: UnrealBuildTool.IniParsingException: Trying to parse key/value pair that doesn't belong to any section in C:\Users\marko_000\Documents\Unreal Projects\?bungCplusplus2\Config\DefaultEngine.ini, line 1: ??? bei UnrealBuildTool.ConfigCacheIni.ParseIniFile(String Filename) bei UnrealBuildTool.ConfigCacheIni.Init(UnrealTargetPlatform Platform, String BaseIniName, String ProjectDirectory, String EngineDirectory) bei UnrealBuildTool.HTML5SDKInfo.EnsureConfigCacheIsReady() bei UnrealBuildTool.HTML5SDKInfo.EmscriptenSDKPath() bei UnrealBuildTool.HTML5Platform.HasRequiredManualSDKInternal() bei UnrealBuildTool.UEBuildPlatform.ManageAndValidateSDK() bei UnrealBuildTool.UnrealBuildTool.RegisterAllUBTClasses(Boolean bSkipBuildPlatforms) bei UnrealBuildTool.UnrealBuildTool.Main(String[] Arguments)

Any suggestions how I can solve this problem?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Mar 27 '15 at 09:10 PM in Using UE4

avatar image

Dizzney
21 2

avatar image wittlief ♦♦ STAFF Mar 30 '15 at 02:41 PM

Hi Dizzney,

It looks like you've set up to create an HTML5 project, have you followed all the instructions for setup here in the HTML5 documentation? And you're not seeing similar errors in attempting to make a blueprints project?

avatar image wittlief ♦♦ STAFF Mar 30 '15 at 02:50 PM

Hi Dizzney,

Can you attach to this thread your DefaultEngine.ini files. Or if you like you can send to me via PM on the forums, wittlief is the name there too. Thanks very much!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Wittlief, sorry, I forgot to add: Later that day when I got this error I tried to reinstall my Visual Studio-Version (I am currently running Ultimate 2013) and now it works. It's pretty peculiar but it was obviously a Visual Studio problem. When I am creating any project-type (C++ or Blueprint) the UE4-Editor and Visual Studio are running just fine and I can build the project in Visual Studio as well without any problems.

I didn't have any errors when making a blueprint project.

So I don't really know where the error came from.

Thanks for the fast reply!

Greetings

more ▼

answered Mar 30 '15 at 03:34 PM

avatar image

Dizzney
21 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question