x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

flickering mesh

hi,

when i play my game some meshes are flickering more like it go invisible and back visible how to fix that?

Thanks in advance,

Product Version: Not Selected
Tags:
more ▼

asked Mar 28 '15 at 12:58 AM in Rendering

avatar image

quintendc
185 44 59 82

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Select your mesh. Or if it's a component in a BP select that. Go to the details panel and look for the render tab. Find the "bounds" setting. Turn it up a bit. :)

Hope that works! Good luck!

more ▼

answered Mar 28 '15 at 02:25 AM

avatar image

AttemptD
1k 166 164 355

avatar image quintendc Mar 28 '15 at 03:41 PM

thanks it works

avatar image ryan3dguru Sep 23 '18 at 11:29 PM

Thank you so much ive been going down the zfighting road and was glad to see it had nothing to do with that. I had changed nearclip plane, didn't work, I changed models thickness that did nothing. bounds worked perfectly. you rock.

avatar image iekomedia 6 days ago

For something like my scene thats real world scale and default value is one, what value should I try? I go as high as 10 and I don't see a change in the flicker.

alt text

avatar image iekomedia 6 days ago

I got some fair results by disabling dynamic shadows on all the machines, but i lose all shadows all together. hope this works out during build lighting since i'm using static lights

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Been looking for a solution for some time on this. Setting a higher bounds value works great:) //\/\

more ▼

answered Jun 04 '18 at 04:26 AM

avatar image

MarcusDee
6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try to delete all collider on your physic skeleton

more ▼

answered May 19 '19 at 06:43 PM

avatar image

Samuel Brunner
6 1 2

avatar image Borkleby Jul 04 '19 at 12:59 AM

Instead of deleting all physics bodies, I found that aligning them properly did the trick. This flickering occurred for me when I there was scaling involved in the mesh animation, and the physics bodies were not the correct size.

Turning up the higher bounds will work... however: the bounds determine when an object should stop being rendered while off screen (aka culling). If that bounds is too big, it will always be visible, but may cause a heavier strain on your graphics performance, especially if you have many objects with high bounds.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question