x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] "Find Session" Search Fails

I was testing out multiplayer with another developer on our team. He was hosting the game. For some reason when I try to find available games to join I get "Search failed". When I run the game, the steam overlay works great, and the "steam_appid.txt" is successfully created in the folder with the '.exe'. I packaged my game using the "Development" configuration. I am using Engine version 4.7.3. Our hosting, searching and joining method works when we use the "OnlineSubsystemNull" but now with steam it is giving us problems. Below is my DefaultEngine.ini

 [/Script/Engine.GameEngine]
 !NetDriverDefinitions=ClearArray
 +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")
 
 [OnlineSubsystem]
 DefaultPlatformService=Steam
 PollingIntervalInMs=20
 
 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480
 GameServerQueryPort=27015
 bRelaunchInSteam=false
 GameVersion=1.0.0.0
 bVACEnabled=1
 bAllowP2PPacketRelay=true
 P2PConnectionTimeout=90
 
 [/Script/OnlineSubsystemSteam.SteamNetDriver]
 NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"

Here is a screen shot of my networking:

This is how I create the session. I know this is working since a fail on "sessions create" quits the game. alt text

Sorry in advance if this is annoying, I split the pic into two pic to make it easier to read. But this is the process I use to "find sessions" and populate my game list. FYI I used the "Multiplayer ShootOut" game from Unreal as a refence. alt text

alt text

This is what it looks like when it fails:

alt text

My suspicion was that Steam doesn't let you test these features with the developer id 480. But I saw in another post that it should work even with the 480 app id. Does anyone have any insight into this issue?

Product Version: Not Selected
Tags:
more ▼

asked Mar 28 '15 at 07:05 PM in Packaging & Deployment

avatar image

Janyx
492 67 65 212

avatar image Janyx Mar 29 '15 at 06:16 AM

I tried re-installing the engine but that didn't seem to help. Still working on it.

avatar image The Cheese Dragon May 21 '15 at 02:18 PM

Im trying to make a multiplayer game, I have created it out from the multiplayer shootout example and it all works perfectly when I run two instances on my own computer, packaged or in editor but when I tried with a friend over the internet the Find Games menu didn't show my friend when he was hosting and the same when we tried the other way around, it came up with "no sessions found" every time.

I have forwarded port 7777 but my friend has not.

I have not tried using the steam SDK yet so this could be the problem? If I use the Steam SDK I would have to be green lite for steam to actually make it work so to speak? Just wondering because its a lot of money to get a game green lite, at least it is when you don't know for sure if you are going to make any money from it.

Would using the Steam SDK allow players to avoid port forwarding?

Thanks

avatar image Janyx May 21 '15 at 02:39 PM

Yes, using Steam SDK will fix this problem. I am not sure if this is 100% correct but this is how I think about. You need a place where all the hosted games can be "broadcasted", that what steam will do. When you host a game it will go up on the steam servers. When people search for available games the SDK will take them to the steam servers to see if there are any games. Without this "middleman" the game client won't know where to look to find games. I believe it just looks locally, which is why it works when you test it by yourself. You could potentially create your own server to host broadcasted games but it's more trouble than it's worth. Hope this helps explain things.

avatar image The Cheese Dragon May 21 '15 at 03:12 PM

excellent, thanks, Would using the steam sdk avoid players having to do port forwarding on their computers to host it too?

I have just followed the steps for getting it to use the steam sdk now but when I packaged the project I got this error Failed to load session and when searching for games in the Find Games menu I get Failed to find sessions.

I did not update the steam sdk that UE4 already has, I don't know if this would be the problem.

I also exported it as a shipping build, do I have to use development for this?

cant think of any other causes yet

avatar image Janyx May 21 '15 at 03:23 PM

Ya so when you use Steam SDK you don't have to do port forwarding so it's super nice and makes it easier to share the game allowing others to play.

I remember getting this error as well. Try 2 things:

First make sure the Steam SDK version is the version the engine is expecting. I got a lot of problems trying to change the version the engine was expecting so I downloaded the older SDK to match the default version the engine is expecting.

Second I use the development packaging configuration. It still allows you to send them game to others for play tests. I am not 100% sure but there may be an issue with trying to to use the shipping configuration without a Steamworks ID.

Give that a try and let me know.

avatar image The Cheese Dragon May 21 '15 at 03:36 PM

the version that is in the UE4 steamworks folder seems to b the same as in the steamworks build.cs file, is there somewhere else I need to check?

avatar image Janyx May 21 '15 at 03:41 PM

Did you download or build the engine? I am not by my computer but I can give you more details later. Try using the development packaging first and see if that fixes it.

avatar image The Cheese Dragon May 21 '15 at 04:00 PM

downloaded it through the launcher

I got an error this time I tried to build the game, attached is the build log, I don't know if you understand that sort of thing, I cant interpret much of it

error.txt (11.0 kB)
avatar image The Cheese Dragon May 21 '15 at 04:03 PM

oh hang on I think ive found what caused that, I took the // of a bit that I wasn't meant to in the build.cs

avatar image The Cheese Dragon May 21 '15 at 04:08 PM

well it has exported now but its still not working... same error "Failed to find sessions." I could send you the project but its 3.4 GB so it would take for ever to upload

avatar image Janyx May 21 '15 at 04:14 PM

If you put your project up on github I will take a look at it.

avatar image The Cheese Dragon May 21 '15 at 04:21 PM

ill give it a go but never worked out how to use github, where would I find the upload button?

Flipin hell why cant it be in English, repository's gits and command lines... urm I'm lost.

avatar image Janyx May 21 '15 at 04:44 PM

I did a quick tutorial about this:

https://m.youtube.com/watch?v=HjZSYiOgTOM

I would do it this way:

  1. Go to github.com sign up and sign in

  2. Then you'll want to create a new repository

  3. Then clone that repository on to your local machine

  4. Then copy and paste a few of you project folders over into the cloned repository (I would do less than 1 GB at a time since pushes bigger than that get a little more complicated).

  5. Then push those files up.

  6. Repeated steps 4 and 5 until all your files are up into the repository.

avatar image The Cheese Dragon May 21 '15 at 06:48 PM

I got to stage 4 but could not push, it said no configured push destination.. I tried following its suggested steppes (git remote client add) but I must have given it the wrong information or something, or do I put your name and url after remote client add?

avatar image Janyx May 21 '15 at 06:57 PM

If you are using the Shell aka using the command li e then do it this way. Navigate to where you want the repository to be using "cd {file path}". Then do "git clone {url of github repository page}". Then add your file to the cloned folder, you can just drag and drop. Then do "git add ." Then "git commit -m 'some message'" finally "git push".

If you did all that and it is still giving that error. You can do " git push {url of github repository page}"

avatar image The Cheese Dragon May 21 '15 at 07:15 PM

first push is going up, I think its working, I did a hybrid of using git shell and the other bit I think.

avatar image The Cheese Dragon May 21 '15 at 08:08 PM

first push is up here, I notice now that your defaultEngine.ini file is different to my one, I left my'n how the multiplayer demo was, should I copy your version instead?

here is the repository so far https://github.com/JazzCousins/DragonGame

avatar image Janyx May 21 '15 at 08:21 PM

I just took a look at your defaultEngine.ini and it looks fine. I'll try and figure out the problem tonight

avatar image The Cheese Dragon May 21 '15 at 08:28 PM

worth me uploading the source file or any others?

avatar image Janyx May 21 '15 at 11:50 PM

Honestly I would, source files are very small and won't be super fast

avatar image The Cheese Dragon May 21 '15 at 11:57 PM

I have put everything except the saved folder and intermediate, 47% done, should have thought just to do the config and source first since they are the most useful... oh well

this is getting ridiculously narrow, sorry for asking sooooooooooooo many questions!

avatar image Janyx May 22 '15 at 12:42 AM

Hahaha no worries. I will clone your project and try to get it working for you.

avatar image The Cheese Dragon May 22 '15 at 10:17 AM

Thanks, its all up now except the intermediate folder and saved folder, are these important? they are 1.5 GB each so I'm reluctant to do them unless I have to!

avatar image The Cheese Dragon May 22 '15 at 08:04 PM

Ah I think I might have fixed it, the steam overlay comes up now, I will have to try with a friend now to see if it is actually working, ill let you know how it goes.

I forgotten to add the line of code to the target.cs..... stupid mistake, I don't know for sure yet if its the only one. I did notice some warnings about steam as it was packaging so this might not be the end of it....

It doesn't let me join myself with the game up twice on the same computer now, I'm taking that as a good sign since that's what you mentioned happening, although it is slightly annoying.

avatar image Janyx May 22 '15 at 08:09 PM

Awesome, keep me updated. I am out of town for a wedding so I haven't been able to spend much time looking at it. I'll be home tomorrow and give it a look if you haven't figured it out by then.

avatar image The Cheese Dragon May 23 '15 at 12:33 AM

I tried it, apparently the steam overlay made the game crash if he opened it in the main menu for some reason but we managed to join each other and the overlay did not crash once we were on the other map.

Ill call that a success, I think

It has some replication problems though at the moment and you cant really fight each other at the moment the gameplay is too clunky but I can fix that

here is a video of the game, (hadn't got the multiplayer working when I did the vid) https://www.youtube.com/watch?v=A9qvf4j0k7Y

avatar image Skumtron May 24 '15 at 04:16 PM

If you are using sessions then that doesn't work over internet since the sessions are found within LAN(that's why you tick the LAN box).

You have two options: 1. Get Steamworks SDK running, it's not that hard and you don't need to be Greenlit to work with it. 2. Go with direct IP connection route: Let the client enter IP address and then use it in Execute Console Command blueprint node.

avatar image The Cheese Dragon Oct 10 '15 at 11:23 PM

Im back again, turns out its only working intermittently, most the time when me and some friends tried searching while one of us hosted we all got "no sessions found" however we would sometimes also get "search failed" or sometimes it even found the sessions but gave me the "failed to join session" error, after some spamming of the join button we were sometimes able to join though, any idea what would cause this erratic behavior?

If it would help I could upload the project I'm working on for someone to have a look at, I am using the launcher version of the engine and a blueprint project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jul 01 '16 at 03:40 PM by Samantha Sutton for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks!


2 answers: sort voted first

I was able to get it working! Apparently you can't search for sessions, using the steam subsystem, while currently hosting a session. This isn't ideal for what I wanted but I will start another post for figuring a way around that.

more ▼

answered Mar 30 '15 at 01:50 AM

avatar image

Janyx
492 67 65 212

avatar image Serellyn Jun 10 '15 at 10:02 AM

Hey, I'm trying to host and find/join sessions like you and the MultiplayerShootout example. But I have a problem with finding the sessions. You say here that you can't search for sessions while hosting it, but when I build the Multiplayer Shootout example I can host and find the session. And it's also using Steam right?

The problem in my case is, I get a lot of 'failures' in 'Find sessions'. Then I noticed something you and the example both have, and that's the 'Bad cast node'. Where did you find that one, how can I call it and what is it?

Sorry for those questions but your problem is closest to mine as I've found.

avatar image Kochab Jul 22 '15 at 04:46 PM

A bad cast node happens when you copy and paste a Cast node that isn't aware of the object it's trying to cast. I believe it was just an oversight in the Multiplayer Shootout example that someone didn't delete it. Notice there is also a dangling "get controlled pawn" node that is also not doing anything in the first screen shot.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'd like to add, there's a bug in one of your blueprints. I found the tutorial that set up this Steam/LAN connectivity and what not, and have it set up on my machine. In your Server List widget (image 2/4) right before Find Sessions, the code attempts to get sessions based on your toggled option for LAN versus Steam. [Get Game Instance] > [Cast To Node Error]. This should be casting to the "GI_MP_Steam" or your state-manager. As it is, you're ALWAYS trying to scan Steam games, which may be part of your issue, as the test app_id may be used by other developers, and under variant amounts of network loads.

Found this post because I can't find any Steam sessions, and the LAN sessions are coming up with null names, 0/0 players, and 9999 ping. Upon trying to join, I get a Join Session Failure message.

more ▼

answered Oct 30 '15 at 04:52 AM

avatar image

FoxLovesYou
6 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question