x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

All android builds crash

Hiya,

I've tried building many different builds to test on my android device but always get the same results...as soon as the application launches on the device it immediately crashes.

Today I managed to see the following in the log:

LogFileServer:Display: Read ../../../Engine/Content/MobileResources/HUD/VirtualJoystick_Background.uasset, 263065 bytes LogSockets:Error: Unable to read full header

Any ideas?

Thanks

Paul

Product Version: Not Selected
Tags:
more ▼

asked Mar 29 '15 at 03:00 AM in Packaging & Deployment

avatar image

Paulhaydock1982
131 2 4 21

avatar image wittlief ♦♦ STAFF Apr 03 '15 at 07:33 PM

Hi Paulhaydock1982,

Are you still seeing this crash? Are you using the binary or source version of the editor? Can you attach the entire output logs for your failure as a txt file to this thread, if you are still seeing failures? Thanks very much!

avatar image Paulhaydock1982 Apr 04 '15 at 06:35 AM

link text

Hiya,

Thank you for the reply. I'm still experiencing problems and to date haven't been able to run anything on a mobile device. I'm using the binary version of the editor and have attached the logs I was able to find, generate.

Thanks

Paul

projectlauncher.log (291.5 kB)
avatar image wittlief ♦♦ STAFF Apr 06 '15 at 02:27 PM

Ok, looking at your output logs, it states that the build was successful. Can you tell me at what point you are seeing the crash? I'm also not seeing the error you linked above now in your output logs.

Have you ever been able to successfully package for Android?

Secondly, and this may be unrelated, but are you also using Android Studio IDE?

avatar image Paulhaydock1982 Apr 04 '15 at 06:36 AM
log.txt (36.6 kB)
avatar image Paulhaydock1982 Apr 07 '15 at 10:25 AM

Hey,

I'm sorry...so here's some further information...

Firstly, I've never been able to run an android application I've built on three different phones. The application installs fine and it launches, but i immediately get "unfortunately, app name has stopped."

Secondly, I installed the android dev tools that came with the unreal engine.

Finally, I'm not sure how to capture the logs, but if I go to the Project Launcher and launch through there a dos window pops up and this is were I'm seeing the error I first mentioned...it's always a unable to read full header error...

I will try to get a copy of that log...

Paul

avatar image Paulhaydock1982 Apr 07 '15 at 11:40 AM

alt text

image.jpg (2.5 MB)
avatar image wittlief ♦♦ STAFF Apr 07 '15 at 03:24 PM

Here, this might help. It's the documentation for how to find various types of logs.

Can you snag the Tappy Chicken project and try to package it for development and for ETC1? if you can successfully package that, then it indicates your SDK is set up correctly, so we can rule that out.

Good luck!

avatar image Paulhaydock1982 Apr 08 '15 at 12:30 PM

Here's that log with the crash for 'MemoryGame'.

Downloading Tappy Chicken now...link text

log.txt (157.0 kB)
avatar image wittlief ♦♦ STAFF Apr 09 '15 at 05:22 PM

Hi Paulhaydock1982,

Were you able to get Tappy Chicken to package? If it failed, can you attach fresh output logs? Tappy is small and optimized for mobile, so it makes problems somewhat easier to diagnose.

avatar image wittlief ♦♦ STAFF Apr 16 '15 at 03:46 PM

Hi Paulhaydock1982,

Were you able to package Tappy Chicken?

avatar image Rask Jun 23 '15 at 12:35 PM

I'm having the same problem with [4.8]. Build works, Launch fails with a similar log ("Unable to read full header"). No issues with Tappy Chicken.

avatar image wittlief ♦♦ STAFF Jun 23 '15 at 01:47 PM

Hey, you say launch fails, is that launch on from the editor or starting your apk on the device? What device are you testing and what is its OS? Can you include your output logs if this is launch on fail or your logcat logs if this is device fail?

Thanks

avatar image Rask Jun 23 '15 at 04:49 PM

Hey there. The game works in editor, but launching on my Android Nvidia Shield Tablet crashes after a successful build (I tried both launching from editor and packaging first). I will try to include my logs later, but the last part is practically identical to the one posted by Paulhaydock1982 (Apr 07 '15 at 1:40 PM).

avatar image Rask Jun 23 '15 at 05:51 PM

The logs:

unrealbug.png (283.1 kB)
avatar image wittlief ♦♦ STAFF Jun 23 '15 at 05:57 PM

can you attach those as a txt file? Please don't take the other user's example as the preferred way to get logs to us :)

avatar image Rask Jun 23 '15 at 06:13 PM

Sure. :)

Logs

mainlog.txt (59.4 kB)
cmdlog.txt (50.2 kB)
avatar image wittlief ♦♦ STAFF Jun 23 '15 at 06:21 PM

Alrighty, since UFE shows it completes, but it appears to be crashing on the device itself can you include logcat logs to this mix? Also, do you mind checking an existing project like Tappy Chicken to see if this is project specific?

Thanks!

avatar image Rask Jun 23 '15 at 06:35 PM

I'm able to build and launch Tappy Chicken with no issues.

Here the logcat: Logcat

Thanks!

logcat.txt (14.3 kB)
avatar image wittlief ♦♦ STAFF Jun 24 '15 at 03:14 PM

ok, is the end of the section you posted about the time when it crashes on your device? I see one minute's worth of log and nothing that immediately indicates a device crash. Do you mind trying one more time and then letting the logs run a little longer, maybe attempting app launch more than once while you're gathering logs? That would help quite a bit.

Thanks!

avatar image Rask Jun 24 '15 at 08:43 PM

Hi. I just updated to 4.8.1 and the game still crashes. Here is another logcat during the crash. I restarted the game 3 times on my device (after deploying), but using Android Debug Monitor I cannot find a way to copy a longer logcat. Anyway, this time there is something new. Let me know, thank you!

logcat2

logcat2.txt (527.0 kB)
avatar image Rask Jun 25 '15 at 11:13 AM

The problem happens to be related to ASTC. I just tried with DXT and it works!

Edit: at least the first time, deploying from editor. Re-launching from the device results in black screen.

Edit2: Building "By the book" instead of "On the fly" solves also this last problem.

avatar image wittlief ♦♦ STAFF Jun 25 '15 at 01:41 PM

Right, ok, that is very good information, thank you.

Just to further narrow down potential problems, do you mind packaging from the Editor itself and not the Project Launcher/Unreal Frontend? UFE is very useful for users who want very granular packaging abilities, but it has a lot more variables than packaging via the Editor itself.

Also please try in ETC1, just to narrow down that is it likely to be only ASTC. ETC1 is the texture compression we feel is the best for general testing, and (I need to double check this) I believe support for ASTC was added fairly recently; I'll see if problems with it are a known issue.

Thanks!

avatar image Rask Jun 25 '15 at 02:22 PM

Ok, now I don't understand anything anymore. RECAP: With 4.8 I tried many times launching (ASTC) from the Editor itself AND from the UFE, with no luck. Then I updated to 4.8.1, I re-tried directly with the UFE (ASTC), same problem. Then I switched to DXT and it worked! Finally I followed your suggestion and tried launching ASTC from the editor (no UFE) and it worked (mmh); it also worked with ETC1. At this point I was convinced that the problem was in the ASTC mode in UFE. But I tried again and now it works. I doubt this experience will be useful to anybody or anything, but at least it is the truth.

avatar image wittlief ♦♦ STAFF Jun 25 '15 at 08:51 PM

So you're good to go building with all textures and from both UFE and the editor?

avatar image Rask Jun 26 '15 at 08:52 AM

Apparently yes, but I have no idea why. Maybe launching with DXT fixed some hole, somewhere?

avatar image wittlief ♦♦ STAFF Jun 26 '15 at 02:05 PM

Sounds good, ok. I'm going to mark this as re-resolved for now. If the problem reappears, come back and comment and we'll do some more digging.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Paulhaydock1982,

We did not hear back from you in response to this issue, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Apr 20 '15 at 07:47 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question