x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Turning off occlusion culling of a static mesh

Hey

In UE3 i manually turned on/off if a static mesh should do occlusion culling or not, but i can't find any way to do it in UE4.

As you see on the picture the trash on the corridor is make the wall modules pop in/out even if it's not hidden by another object so it looks pretty bad.

Is there any way of excluding static meshes from the occlusion culling so they wont hide things behind them?

Poppin

Product Version: Not Selected
Tags:
popping.jpg (301.7 kB)
more ▼

asked Mar 29 '15 at 09:52 AM in Rendering

avatar image

Ashkandi
16 6 8 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Increasing Bounds Scale a little may help.

more ▼

answered Mar 29 '15 at 10:52 AM

avatar image

Jacky
16.7k 671 167 674

avatar image Ashkandi Mar 29 '15 at 12:42 PM

Well, i don't want to increase Bound Scale for all walls, i want to do something with these meshes so they won't hide stuff behind them.

avatar image Ashkandi Mar 31 '15 at 03:32 PM

So there is no any way to do it then i guess.

avatar image Tim Hobson ♦♦ STAFF Apr 01 '15 at 01:09 AM

Increasing the bounds scale is the way to go. You can disable Occlusion culling for the project via the project settings, but that's for the entire project and not for a specific mesh.

For the bounds scaling you do not have to increase it significantly. The default value is 1. Try increasing it by only a fraction at a time until you the results you're happy with. Try values like 1.05, 1.1, 1.15, until you get what you need. It won't hurt doing minute adjustments. Significant adjustments keeping something rendered much longer than needed can be bad though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question