x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Engine] Adding to pre-existing included library (IntelTBB)

I'm trying to use IntelTBB in my own work, but I actually need access to their task system etc, not just the allocator provided in default UE4.

I've tried adding the .lib files to the \ThirdParty\IntelTBB\IntelTBB-4.0\lib\Win64\vc12 folder, and adding in to the .build.cs, underneath the pre-existing lib code for tbbmalloc.lib:

 string LibName2 = "tbb";
 if (Target.Configuration == UnrealTargetConfiguration.Debug && BuildConfiguration.bDebugBuildsActuallyUseDebugCRT)
 { 
     LibName2 += "_debug";
 }
 LibName2 += ".lib";
 PublicAdditionalLibraries.Add(LibName2); 

This part has worked (mostly... sometimes I just get "Error : Failed to generate code for UE4Game - error code: -1073741515 (-1073741515)" over and over every time I try to build UE4) but I can't get it to run without manually placing the .dll files in the working directory.

Obviously UE4 is handling the use of .dll files already, so I tried to tap into that by adding PublicDelayLoadDLLs.Add(LibName2 + ".dll"); to the above section before the += ".lib" line, but again started getting errorcode -1073741515.

What's even more perplexing is that I can't find the tbbmalloc.dll file in UE4 at all. How the hell is it using this functionality without the .dll file, when I have to manually place it. They're not even using the build.cs to copy or incorporate it automatically... it just isn't there!

Any advice on how to add the additional .dll and .lib files to the IntelTBB ThirdParty directory and have them linked in and part of the engine would be super helpful. (Having to place the .dll files manually would be a pain, especially in the editor configurations... and oh god, what about packaged games!)

Thanks!

EDIT: Also, what bloody version is UE4 using? It says 4.0 but that's unlikely - you wouldn't have the vc12 folder then! I'm betting 4.3... but which subversion of that?

Product Version: Not Selected
Tags:
more ▼

asked Mar 29 '15 at 04:06 PM in C++ Programming

avatar image

HateDread
443 40 47 72

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question