x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS shipping using 4.6 GitHub

how can I ship my iOS game with 4.6 using github? I always get 64-bit binary error. This is the only issue I got with 4.6 and do not want to use 4.7 yet. Can you help me with this?

Product Version: Not Selected
Tags:
more ▼

asked Mar 31 '15 at 01:26 AM in Using UE4

avatar image

jedisongoku
26 1 4 8

avatar image trutty Mar 31 '15 at 10:03 AM

It would really help if you could explain your steps so that we can see where you might go wrong. Where do you get the error (when packaging, compiling, uploading to iTunes Connect, ...) and what exactly is the error message?

avatar image jedisongoku Mar 31 '15 at 10:30 AM

I get an error on application loader when uploading my game.

Missing 64-bit support - Beginning on February 1, 2015 new iOS apps submitted to the App Store must include 64-bit support and be built with the iOS 8 SDK. Beginning June 1, 2015 app updates will also need to follow the same requirements. To enable 64-bit in your project, we recommend using the default Xcode build setting of “Standard architectures” to build a single binary with both 32-bit and 64-bit code.

I check armv7, arm64 and armv7s in the project settings, and set build configuration to shipping and for distribution checked as well. I don't know If I'm missing anything.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I fixed it by reinstalling the engine and using Josh Adam's suggestion. thanks.

more ▼

answered Apr 05 '15 at 12:30 AM

avatar image

jedisongoku
26 1 4 8

(comments are locked)
10|2000 characters needed characters left

Alright, from what you posted as a comment, it looks pretty much like an issue I had once. I posted a question back then (see this thread ) and got amazing support from psauer.

I don't know if they fixed it in UE 4.7.3, but in 4.7.2 I had to change some code in order to be able to build for iOS 8.0 (as the dropdown from the packaging setting was kinda useless). This is what fixed the iOS 8.0 issue (in UE4.7.2):

To build with iOS 8 as the minimum version, open up iOSToolChain.cs in Engine/Source/Programs/UnrealBuildTool/IOS. Near the top, you will see a variable called BuildIOSVersion. Change that from 6.1 to 8.0 and then do another File | Package. UBT will automatically build itself and then the game will be rebuilt and packaged with iOS 8 as the minimum version.

The "Missing 64-bit support" error is also mentioned in the thread. Uncheck arm7s and try it again.

Hope this helps

more ▼

answered Mar 31 '15 at 12:44 PM

avatar image

trutty
541 28 32 181

avatar image joshbadams STAFF Mar 31 '15 at 05:44 PM

I can't remember now if the IPhonePackager.exe that's in 4.6 had the fix for fat binary (armv7+arm64) signing. I bet you will need the 4.7 version of IPhonePackager. I should be able to attach it to here if you aren't able to download 4.7 to grab IPP from. (The guy who would know for sure is on vacation at the moment :))

Note that you don't need to change the Minimum Version to 8.0, you just need to have the executable built with the 8.0 SDK, which it has been.

Lemme know if you need IPP, Josh

avatar image jedisongoku Apr 01 '15 at 08:47 AM

I changed the IPhonePackager.exe and I was able to upload my app. Thank you very much.

avatar image jedisongoku Apr 01 '15 at 02:32 AM

I will try these soon, and will get back with the result. thanks a lot

avatar image jedisongoku Apr 01 '15 at 01:36 PM

I tried to open up my app on testflight, but it crashes right after launch screen. Is that mean I have a problem with my app?

avatar image Ravlek STAFF Apr 03 '15 at 01:51 PM

What device are you trying it on (iPhone or iPad type)? That will tell me if it is a 64-bit error.

-Pete

avatar image jedisongoku Apr 07 '15 at 02:34 AM

Can i get help with this, I can't ship my game with this.the last error i have :)

https://answers.unrealengine.com/questions/206188/foliage-paint-issue-with-ios-shipping.html

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question