x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Tournament Editor 4.7.3 Installation Failed A file corruption occurred

Hello!

Today I tried to update the Unreal Tournament Editor to version 4.7.3 and unfortunately my connection dropped in the middle of the update. I am now unable to complete the installation of the editor. I receive the error: "Installation Failed. A file corruption has occurred. Please try again." When I try a second time, I receive the same error. The launcher will show progress up to approximately 40% and jump between "initializing" and "resume" status until ultimately the error pops up again.

I have tried uninstalling the editor and reinstalling it via the launcher but I end up with the same error. I have tried uninstalling the Epic Games Launcher and doing a full reinstall from scratch but keep coming back to the same error. (Antivirus was disabled and I was running the launcher as administrator the whole time.) I am running windows 7 64 bit and I have all of the epic studios content (editor, engine, unreal tournament 4) installed to E:\Program Files (x86)\Epic Games

The launcher log file shows the following "corruption" lines. [2015.04.02-01.39.40:021][ 0]BuildPatchServices: Build Stat: FailureReason: EBuildPatchInstallError::FileConstructionFail Could not create new file UnrealTournament/Content/RestrictedAssets/Environments/Liandri/Meshes/Optimizations/SM_Liandri_DoorA_Floor_Trim02_Strait_Half_OutdoorOPTIMIZED.uasset [2015.04.02-01.39.40:021][ 0]BuildPatchServices: Build Stat: FailureReasonText: A file corruption has occurred. Please try again.

I honestly don't know if this is the cause of the issue, but it's the only thing in the launcher log that makes sense to me. I should note that I am not a guru when it comes to log files. =P

Update: I tried navigating to the mesh in question by going to: "E:\Program Files (x86)\Epic Games\UnrealTournamentEditor\PatchStaging\UnrealTournamentEditorLive-Windows\Install\UnrealTournament\Content\Optimizations" and looking for the mesh but it's not in there.

I tried deleting the optimizations folder and then resuming, but still getting the same error. A fresh debug log shows the same offending mesh.

Edit 2: I should also let you know that I have tried navigating to: "E:\Program Files (x86)\Epic Games\UnrealTournamentEditor\PatchStaging" and deleting the folder: "UnrealTournamentEditorLive-Windows" and then resuming the installation, and it still fails.

link text

Product Version: Not Selected
Tags:
dxdiag.txt (38.9 kB)
more ▼

asked Apr 02 '15 at 01:52 AM in Installation & Setup

avatar image

Tolsarion
26 1 2 3

avatar image TJ V ♦♦ STAFF Apr 02 '15 at 12:37 PM

Hi Tolsarion,

It's possible that some folders from the previous install are still there. Take a look at the answer on this post and see if it helps you out.

If not, make sure that you have tried all of the suggestions in this section of the troubleshooting guide. Then follow the directions towards the bottom of the page to generate your Debug Logs and post them here. They are a bit different than the standard logs that you posted above.

avatar image Tolsarion Apr 02 '15 at 02:21 PM

Hi TJ Ballard,

Thanks for responding to me. I have not been able to try the recommended steps above as I am at work and don't have access to my home machine. I will try the recommended steps when I arrive home.

"Hi kkokialisim & QBert,

We are still investigating the cause of this issue but I believe I know how to fix it. • First uninstall the engine version (QBert has already done this)

• Then go to this folder (your file path may differ slightly): C:\Program Files\Unreal Engine\Launcher\VaultCache

• If there is a folder/file contained inside called 'UE_4.7', delete it

• You should now be able to re-install 4.7.1

Let me know if this works for you or not.

Cheers,

TJ"

I am just curious about one thing in the recommended fix however. When you state to 'uninstall the engine version' is there somewhere specific to do this? The only place I can find an uninstall option is via the Epic Games Launcher on the Unreal Tournament tab and then the remove option. Should I be going to the Library tab via the unreal engine tab to remove it? Maybe this was my issue during my reinstallation attempt. Sorry if this is a noobish question, I'm still getting my bearings with the engine vs. the editor for unreal tournament.

avatar image TJ V ♦♦ STAFF Apr 02 '15 at 04:01 PM

Since this is for the UT version of the editor you would still be removing it from the UT section of the Launcher. Sorry, I should have mentioned that difference.

This file path should be about the same except you will be looking for a UT related folder to delete. C:\Program Files\Unreal Engine\Launcher\VaultCache

avatar image Tolsarion Apr 02 '15 at 11:56 PM

Please see post below. Looks like the same file is causing corruption within the log file.

avatar image Tolsarion Apr 02 '15 at 10:37 PM

Okay I went to E:\Program Files (x86)\Epic Games\Launcher\VaultCache and there is no file or folder called "UE_4.7" I attempted to resume the unreal editor installation and again it returned the same error. Here is my latest log file.link text

avatar image TJ V ♦♦ STAFF Apr 03 '15 at 12:38 PM

Was there any other file/folders in the VaultCache folder?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi TJ,

No there were no additial files of any type in the vault cache folder. However, I have resolved the issue by using a hammer. I fully uninstalled, ran cc cleaner, then reinstalled to my OS drive fresh. I then just moved my backedup maps into the content directory and all is well.

However, I am still curious as to what could be learned from the last log file I provided. It seems that one mesh file was still culprit.

Thanks for your efforts, much appreciated!

more ▼

answered Apr 03 '15 at 01:23 PM

avatar image

Tolsarion
26 1 2 3

avatar image [Epic]Maximusdb3 STAFF Apr 03 '15 at 03:10 PM

I took a look at the logs you provided Tolsarion, unfortunately without getting debug logs on this issue there's no way to pinpoint the issue you're experiencing.

If you happen to run into the issue again please let us know!

-Max B.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Download it on your main hard drive, c:\ worked for me.

more ▼

answered Jun 03 '16 at 12:30 PM

avatar image

KrTheMaster
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question