x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

need help for android

Hi,

whe ni try to run my game to my android phone the build will fail i do not see the android formats just the name of my phone .

thanks in advancelink text

Product Version: Not Selected
Tags:
endlessrungame.log (217.1 kB)
more ▼

asked Apr 02 '15 at 03:07 PM in Bug Reports

avatar image

quintendc
185 43 58 82

avatar image Ben Halliday STAFF Apr 02 '15 at 04:13 PM

Hi quintendc,

We have assigned someone to look into this issue with you, and they will respond as soon as they can. Please be patient and do not open any more posts for the same report. Thanks for your patience.

avatar image quintendc Apr 03 '15 at 01:36 PM

Hi,

i have now 4.7.4 from github and i have compiled the source but in the extra folder there is no android can i install tadp from where the launcher is installed?

and a other question do i need to compile the source also with development editor and android or only development editor and win64?

avatar image quintendc Apr 02 '15 at 04:38 PM

this is what i see at launchalt text

launch.jpg (45.2 kB)
avatar image wittlief ♦♦ STAFF Apr 02 '15 at 06:02 PM

Hi quintendc.

Your screenshot shows that you have made some progress, the editor is recognizing your Android device. However, as you are still seeing a packaging error, I'd like you to try something to test that you have TADP and the Android SDK set up correctly.

If you would, please choose any of the example game projects that are included with the editor and attempt to package. I recommend Tappy Chicken as it is very small and should not take much time. When packaging, please choose 'development' for the build configuration, and choose 'ETC1' for the texture compression. Here is the link from the documentation with steps on how to complete this.

When Tappy has finished, please attach the output logs to this thread, regardless of whether it fails or succeeds. Thanks very much, and good luck!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We no longer show a list of formats there. It ended up being too confusing, so for the Launch button, we choose the best format for the device.

If you need to test a particular format, you can Package your game from the File menu.

Josh

more ▼

answered Apr 02 '15 at 05:52 PM

avatar image

joshbadams STAFF
1.3k 19 7 46

avatar image quintendc Apr 02 '15 at 05:54 PM

can you take a look at the log for why the build failed

avatar image wittlief ♦♦ STAFF Apr 02 '15 at 06:08 PM

Hi quintendc,

Please see my comment above, and try those steps for packaging a sample project. We need to see if your packaging can succeed and then we will dig into why your specific project has failed. Thanks very much!

avatar image quintendc Apr 02 '15 at 06:17 PM

it failed again with tappy chickenlink text

tappychicken.txt (1.1 MB)
avatar image quintendc Apr 02 '15 at 06:36 PM

how can we fix this

avatar image quintendc Apr 02 '15 at 08:16 PM

i can package it now succesful but when i try to install it sayed sd card missing and a other error connection or storage permission

avatar image quintendc Apr 02 '15 at 08:24 PM

hi i have tryed it with tappy chicken too same problem it looks like ue4 have no permission to install something on my phone how can i fix this?

avatar image joshbadams STAFF Apr 02 '15 at 06:11 PM

Did you manually change the SDK version you build with in your project settings? The error is:

C:\NVPACK\android-sdk-windows\tools\ant\build.xml:483: The SDK Build Tools revision (19.0.1) is too low for project 'EndlessRunGame'. Minimum required is 19.1.0

By default, we do latest, but that means it should be able to use what it finds. It sounds like you changed a setting to be 19.1.0

Does that sound familiar?

avatar image quintendc Apr 02 '15 at 06:22 PM

i have not changed that i only set some things in the android sdkalt text

avatar image quintendc Apr 02 '15 at 06:35 PM

what do i need to do

avatar image Chris Babcock STAFF Apr 02 '15 at 07:10 PM

Ok, it looks like your Android SDK Platform-tools and Android SDK Build-tools are out of date. In NVPACK/android-sdk-windows run "SDK Manager.exe". Make sure you have applied the updates and have at least 19.0.1 Android SDK Build-tools installed.

avatar image quintendc Apr 02 '15 at 07:14 PM

hi when i set android-19 in place of latest it failed again how can i update the sdk build tools what do i need to do

link text

endlessrungame.log (204.8 kB)
avatar image quintendc Apr 02 '15 at 07:24 PM

i started a new project without any content just the third person template i updated the tools and now i recieve this

LogPlayLevel: Program.Main: ERROR: ERROR: Unable to find ant.bat (via %ANT_HOME% or %ANDROID_HOME%/../eclipse/plugins/org.apache.ant* LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes. LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 LogPlayLevel: Domain_ProcessExit LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes. LogPlayLevel: copying UAT log files... LogPlayLevel: RunUAT.bat ERROR: AutomationTool was unable to run successfully. LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 28.270908 LogPlayLevel: BUILD FAILED PackagingResults:Error: Error Launch failed! Unknown Error LogEditorViewport: Clicking on Actor (LMB): StaticMeshActor (Floor)

avatar image quintendc Apr 02 '15 at 07:26 PM

alt text

android sdk.jpg (242.6 kB)
avatar image quintendc Apr 02 '15 at 08:02 PM

Ok the game was pushed on the phone but i recieved this error on my phone

How can i fix this or is my phone to weak for running ue4 games

MESSAGE:

default property warnings and errors: Error CDO constructor(editableText): failed to find /engine/fonts/roboto

Error: CDO constructor (editableTextBox): Failed to find /engine/EngineFonts/Roboto

there are a lot more errors on my phone his screen

avatar image quintendc Apr 02 '15 at 08:07 PM

here are the logs but it looks not complete when i look in the output log of the enginelink text

avatar image joshbadams STAFF Apr 02 '15 at 08:39 PM

That Roboto error should not be fatal. Can you get a full log from the device (using "adb logcat" or the Monitor utility in the Android SDK)?

avatar image quintendc Apr 02 '15 at 08:45 PM

you mean the monitor.bat

avatar image quintendc Apr 02 '15 at 08:50 PM

this is the cmd when i try to install it after i packed italt text

cmd install.jpg (246.1 kB)
avatar image joshbadams STAFF Apr 02 '15 at 08:57 PM

That's all fine. It installed okay. We need the runtime log from the device to be able to help.

avatar image quintendc Apr 02 '15 at 08:58 PM

how can i get the log of the device is it the monitor.bat?

avatar image joshbadams STAFF Apr 02 '15 at 08:59 PM

Yes, use monitor.bat

avatar image joshbadams STAFF Apr 02 '15 at 09:02 PM

Sorry, I missed an actual error in the package.

You are missing ant.bat, so your SDK is still not installed properly. Ant is installed by TADP or you should be able to get it in the SDK setup program. Looks like maybe it got uninstalled.

Did you install from NVIDIAs TADP installed, or did you use the one we include with UE4?

avatar image quintendc Apr 02 '15 at 09:05 PM

i used the one in this path C:\Program Files\Epic Games\4.7\Engine\Extras\Android

with this name tadp-2.0r8-windows

avatar image quintendc Apr 02 '15 at 09:07 PM

i changed a path in the android sdk in ue4 of the of the location of ANT this this C:\NVPACK\apache-ant-1.8.2 before it was this C:\NVPACK\apache-ant-1.8.2/bin

and then i was able to launch something on the phone but then on the phone i recieved some errors

avatar image quintendc Apr 02 '15 at 09:14 PM

i can't see the logs of the device

avatar image joshbadams STAFF Apr 02 '15 at 09:20 PM

Run "adb logcat" in a cmd.exe command prompt. That should get you a massive dump. If it works, you can do "adb logcat > logcat.txt" to dump it to a text file you can upload.

avatar image quintendc Apr 02 '15 at 09:28 PM

hope this is the right thing (i think not)link text

log device.txt (15.2 kB)
avatar image joshbadams STAFF Apr 02 '15 at 09:30 PM

Now, that's what happens if you run adb without a command after it, or if you typed it wrong.

Oh, how did you get this earlier?

"Error: CDO constructor (editableTextBox): Failed to find /engine/EngineFonts/Roboto"

avatar image quintendc Apr 02 '15 at 09:35 PM

can't upload the file from monitor.bat

it sayd no such upload

avatar image joshbadams STAFF Apr 02 '15 at 09:40 PM

Not sure what that means :)

avatar image joshbadams STAFF Apr 02 '15 at 09:41 PM

Okay, I see that message was on the phone. Maybe take a screenshot of the errors?

avatar image quintendc Apr 02 '15 at 09:52 PM

here are a few screenshots of the errors but there are a lot more

maybe ist a lot easier if you have a engine that is perfectly setup :)

alt text

alt text

foto 1.jpg (196.5 kB)
foto 2.jpg (170.2 kB)
foto 3.jpg (198.9 kB)
foto 4.jpg (197.1 kB)
foto 5.jpg (199.6 kB)
avatar image quintendc Apr 02 '15 at 10:08 PM

any idea what the problem can be?

avatar image joshbadams STAFF Apr 02 '15 at 10:28 PM

This may be stale data on the device, or on your PC. Can you try running one of the sample games like TappyChicken? Or make a new pproject from a template and trying that?

Are you content-only, or did you write code?

avatar image quintendc Apr 02 '15 at 10:30 PM

its a third person template with blueprint without adding custom content i tryed tappy chicken to ist the same thing

but i did something new:

when i packaged the game with shipping configuration and then installed on the phone my phone sayed

MESSAGE

failed to open descripter file../../../DeployOnAndroid/DeployOnAndroid.uproject

avatar image joshbadams STAFF Apr 02 '15 at 10:32 PM

Hmm that sounds like it wasn't deployed properly to the device. Shipping shouldn't make a difference, but I don't recommend if since logs won't be as helpful.

Are you compiling the engine, or just using the editor from the Launcher?

avatar image quintendc Apr 02 '15 at 10:34 PM

just the launcher

avatar image quintendc Apr 02 '15 at 10:35 PM

do you have some version that is working you can send me over or something

avatar image joshbadams STAFF Apr 02 '15 at 10:41 PM

The Launcher version does work, at least for most people. Something has gone wrong here, and we are trying to track it down :)

At this point, the best thing to do is to wipe everything from your phone, and your project's Saved directory.

It's possible that during the time your SDK was messed up, the state of things on your phone went bad, but I don't really know.

You can get a File Manager program on your phone (like Astro), and delete directories on the SD card. Look for your project names in the root of the SD card, and UE4Game.

avatar image quintendc Apr 02 '15 at 10:47 PM

i think to remove every think of my pc and start back from zero i think a lot of thinks are messed up but can you tell me more in depth how to setup the documentation is not in depth and not up-to-date every time i setup things externally in the engine its going wrong i had a lot of issue's on the console to by setting up the engine

avatar image quintendc Apr 02 '15 at 10:51 PM

there is no SD card in my phone

avatar image quintendc Apr 02 '15 at 11:17 PM

how can i update the tadp

avatar image quintendc Apr 02 '15 at 11:22 PM

all the errors on the phone are CDO Constructor what is that mean?

avatar image quintendc Apr 03 '15 at 01:36 PM

Hi,

i have now 4.7.4 from github and i have compiled the source but in the extra folder there is no android can i install tadp from where the launcher is installed?

and a other question do i need to compile the source also with development editor and android or only development editor and win64?

avatar image joshbadams STAFF Apr 03 '15 at 03:30 PM

It sounds like you already have TADP installed fine. Note that TADP will set some environment variables, so if you clear out the paths in your Android SDK settings, it will use the environment variables. But, as for why you don't have an Extra folder, I'm not sure. You can use the Launcher one.

If you compile source code, then just compile Development Editor Win64, and Development Android.

avatar image quintendc Apr 03 '15 at 07:50 PM

im still experiencing problems do i need to compile the engine with android or the game?

avatar image quintendc Apr 03 '15 at 08:11 PM

here are the logs hope you can find the problem it looks he can't find all the project data and i think descriptor file is the .uproject

link text

avatar image quintendc Apr 03 '15 at 08:48 PM

when i package the game for development and install it on the phone then the crash when i do it under shipping the phone says failed to find the descriptor file please help?

avatar image joshbadams STAFF Apr 03 '15 at 09:06 PM

Are you still getting the CDO error on the device?

avatar image quintendc Apr 03 '15 at 09:07 PM

Yes when i try the run the game through the launch button in the editor

avatar image quintendc Apr 03 '15 at 09:28 PM

any idea how to fix it?

avatar image joshbadams STAFF Apr 03 '15 at 09:33 PM

Nope, I have no clue. We've seen the CDO thing before for some users, and cleaning their Saved and Intermediate/Build directories, in your project or even in Engine, then rebuilding and re-cooking and packaging fixes it...

We haven't been able to figure out what causes it, however. But since you started from scratch with the GitHub build, I am lost. Especially if you create a whole new project, nothing should be left around.

avatar image quintendc Apr 03 '15 at 09:40 PM

ok awesome i have found it there was a space in the path

avatar image joshbadams STAFF Apr 03 '15 at 09:44 PM

What path didn't work with a space? We have tested spaces in a lot of places, but maybe we missed something.

avatar image quintendc Apr 03 '15 at 09:52 PM

the game engine made his own path in my documents unreal Projects that space but its working that is the most imported thing

just a question descriptor file is that the .uproject?

avatar image joshbadams STAFF Apr 03 '15 at 09:59 PM

"Unreal Projects" is totally fine, we make that directory, so there's no reason it shouldn't work. But hey, you have it working, so :)

And yes, the descriptor is the .uproject file.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question